Ubuntu

App icon on the Unity Launcher lost track of running instance

Reported by Lucas Clemente Vella on 2011-04-27
406
This bug affects 83 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
Unity
High
Marco Trevisan (Treviño)
5.0
High
Marco Trevisan (Treviño)
unity-2d
Low
Unassigned
bamf (Ubuntu)
High
Unassigned
Precise
High
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Test Case]
The bug has no clear generic test case, but the proposed fix eliminates possibilities for the problem to happen.

[Regression Potential]
Launchers keeping track of applications could be broken.

Original description:

Binary package hint: unity

The problem occurred on the Unity Launcher where you can't know for sure if the application is running or if it is just a shortcut.

Since some minutes ago, Unity lost track of the running instance of my web browser (Chromium, I am using it right now). Every time I click on Chromium's icon I get a new instance instead of the running one. If I minimize any Chromium windows, the only way to reach them back is through Alt + Tab, since clicking the icon will give me a new window, as if it were not running.

I would expect that clicking on the icon of the running application, it would restore the existing window instead of creating a new one, like what is happening right now with the other program I am using.

I don't know what made Unity lose track of Chromium, and I don't know how to reproduce the problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Wed Apr 27 19:08:38 2011
ProcEnviron:
 LANGUAGE=pt_BR:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-27 (0 days ago)
---
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=pt_BR:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Tags: natty running-unity
Uname: Linux 2.6.35-28-generic i686
UpgradeStatus: Upgraded to natty on 2011-04-27 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Sly (netrefuge) wrote :

Sounds like a minor hooking problem, but I can't confirm that.

Be sure to run "apport-collect 772063" in a terminal to provide developers with as much information as you can for this report.

Changed in unity (Ubuntu):
importance: Undecided → Low

apport information

tags: added: apport-collected
description: updated

apport information

Mohsin Falak (fi8er1) on 2011-05-08
summary: - app icon on the vertical bar lost track of running instance
+ App icon on the Unity Launcher lost track of running instance
description: updated
Mohsin Falak (fi8er1) wrote :

Clicking on the running app shortcut on the Unity Launcher should not open a new window.
Moreover, a running app on the Unity Launcher is indicated by an arrow on the left side of the icon. (as shown in the attached image) and a running app can always be restored by pressing and holding the Super-Key and pressing the displayed desired app number on the Unity Launcher.

Alex Launi (alexlauni) wrote :

This is indicative of bamfdaemon crashing. Could you please run $ ps aux |grep bamf in a terminal and confirm that bamf is not running? You should see a line that ends with /usr/libexec/bamfdaemon

Changed in bamf:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in bamf:
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Didier Roche (didrocks) on 2011-06-07
Changed in bamf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-06-07
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Low

Hi, using up-to-date natty with unity3d. I have this problem every once in a while, too. Not exactly as the screenshot depicts - it loses the "active program" status on the launcher even if it is running. I attached a screenshot of the Remote Transmission program losing its place.

ps aux | grep bamf did return bamf as running:

cornwall 1736 0.0 0.2 229536 7244 ? S Jul13 0:35 /usr/lib/bamf/bamfdaemon
cornwall 29126 0.0 0.0 13128 1056 pts/1 S+ 16:48 0:00 grep --color=auto bamf

It's only a random application every once in a while. Sometimes Firefox, sometimes gnome-terminal, but it seems to target certain programs more than others: Nautilus is by far the most commonly lost.

I'm unsure if I'm properly killing/restarting bamf. Killing the PIDs and letting upstart respawn the daemon does not work.

However, restarting Unity always works. Is it certain that bamf is the affected package or Unity's integration with it?

Bill Briner (briner-bill) wrote :

I experience this problem as well. I added launchers to the Unity bar by opening all applications menu and dragging their icons to the Unity bar and dropping them there. Once I used them to launch the applications there was no triangle indicator showing the application running. My post to the Ubuntu forum is http://ubuntuforums.org/showthread.php?t=1812036 and there is a screenshot showing Chromium open but no indicator that it is in use on the Unity bar. I will try removing that launcher, launching Chromium from "applications" and then right click and select "keep in launcher" as was advised by another user on the forum. However, this behavior should remain consistent no matter how the launcher is added to the Unity bar.

jorisvh (joris-vanhecke) wrote :

I have the same problem with the Gnome Terminal (see the screenshot).

jorisvh@Laptop1:~$ ps aux |grep bamf
jorisvh 1610 0.0 0.5 103200 10632 ? Sl 15:39 0:04 /usr/lib/bamf/bamfdaemon
jorisvh 11392 0.0 0.0 4468 792 pts/2 S+ 18:35 0:00 grep --color=auto bamf

Moreover, the app icon does not appear with the ALT-TAB switcher.

Marcin Juszkiewicz (hrw) wrote :

I have this bug since started playing with Unity/3d. It shows me (single,multiple) marker for gvim but Super+W does not show window, Alt-Tab tells me about one window, "ps fx|grep gvim" tells me about 5 instances running. What happened before was several crashes of Unity (no idea about bamfdaemon as I did not know about it's existence).

Omer Akram (om26er) on 2011-12-05
Changed in bamf (Ubuntu):
importance: Undecided → Low
Changed in bamf:
importance: Low → Medium
Changed in unity:
importance: Low → Medium
Changed in bamf (Ubuntu):
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Omer Akram (om26er) on 2011-12-09
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Mh, as it is hard to reproduce it, it's also hard to fix it.
However I've a workaround in mind that could work.

Just one thing: is this happening only with sticky applications, isn't it?

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Marcin Juszkiewicz (hrw) wrote :

If "sticky" == "one which has icon in launcher even if not run" then yes in my case.

piratemurray (mez-pahlan) wrote :

This is happening even with applications that aren't sticky on the launcher for me. LibreOffice.

LibreOffice is just another particular case, but that is going to be fixed in bug #842566 (actually the code is already there, it just needs to go into the review process).

So, I think we should handle this for other applications too. Any reproducible case is welcome to be reported.

Ian Higginson (xeriouxi) wrote :

I had this happen to me, too... sometimes when I minimise an application it just vanishes and I can't even Alt+Tab into it, though I'm not sure if the Alt+Tab not working is a separate bug or not.

Jason Sopko (jason-sopko) wrote :

The same thing happens to me with VMware Player 4.0.1-528992.x86_64 on Ubuntu 11.10. I launch VMware Player, and it runs fine. I can start a virtual machine and interact with it. But when I click to another window on my desktop, I can no longer access the VMware Player window. When I try to alt-tab to it, there is no icon/option available, and in my Unity sidebar there is no triangle showing that the application is in use. I can see that the process is still running, however, from using 'ps aux' in a shell, and when I try launching VMware Player again it says that the VM is in use.

I had exactly the same behavior right after installing VMWare Player,
however after a reboot things became normal, so I did not consider it a
"real" bug.

On 12/24/2011 07:04 PM, Jason Sopko wrote:
> The same thing happens to me with VMware Player 4.0.1-528992.x86_64 on
> Ubuntu 11.10. I launch VMware Player, and it runs fine. I can start a
> virtual machine and interact with it. But when I click to another window
> on my desktop, I can no longer access the VMware Player window. When I
> try to alt-tab to it, there is no icon/option available, and in my Unity
> sidebar there is no triangle showing that the application is in use. I
> can see that the process is still running, however, from using 'ps aux'
> in a shell, and when I try launching VMware Player again it says that
> the VM is in use.
>

Omer Akram (om26er) on 2012-02-18
Changed in bamf:
importance: Medium → High
Changed in unity:
importance: Medium → High
Changed in bamf (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 5.6.0
no longer affects: unity (Ubuntu)
Dmitry Shachnev (mitya57) wrote :

I don't know if it's the same issue, but sometimes Unity 2D creates a second icon for Chromium when it's running (yes, first one is a pinned icon).

https://launchpadlibrarian.net/94508987/unity-2d-chromium.png

Martin von Gagern (gagern) wrote :

Coming from the duplicate bug #950745: I lost both the glowing launcher indicator and the entry in the alt+tab window list, contrary to most comments above. Does that mean there are two more or less independent bugs? Will you track that switcher aspect here as well?

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Danillo (danillo) wrote :

I'm having this with Firefox right now. I was trying to find out if an add-on was the cause of a problem so I restarted Firefox with add-ons off and ticked "disable all add-ons". After that, everytime I click on its launcher icon it opens a new window instead of scaling the open windows and I never have arrows indicating open instances of it. I reenabled every add-on I have, but the launcher and the alt-tab still don't track Firefox.

Timothy Kross (timkross) wrote :

I have this same problem with firefox. I've unlocked it from the launcher and the icon disappeared (even though firefox was running) and when I tried to add it again via dragging it from the dash to the launcher it didn't reveal the icon at all, I have an empty spot there now (it doesn't show the tooltip when hovered over), I have attatched a screenshot.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
markb (mark-blakeney) wrote :

On 12.04 this is repeatable for me running kmymoney. Appears in Unity launcher as app starts but then disappears. App also never appears in alt+tab list but does appear in super+w. This is the main bug which has always stopped my using Unity. Thought it would be fixed by 12.04 but sadly not - back to gnome-shell for me ..

Jakub (jakub-neubauer) wrote :

Encountered in 12.04 too. With gnome terminal. I also did 2 observations:

1) After I "unlocked" the application launcher, then run terminal from "dash", it didn't appear in the application bar at all, although the terminal was newly run. Also Alt+Tab didn't show it.

2) The second observation is more interesting. After I switched to another application windows, then switched to "Show desktop" to hide all applications, the terminal disappeared (without icon in the launch bar there is no way how to access it), but even listing processes (Ctrl+F1, login, then running "ps xf | grep term") didn't show anything, thus the terminal process was killed by someone!

After logout/login I couldn't reproduce it again...

Jakub (jakub-neubauer) wrote :

Just to complete my previous comment - running other application (I tried another terminal - xfce4-terminal) behaved normally.

Changed in unity:
status: Confirmed → In Progress
Changed in bamf:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: New → Fix Committed
Alan Pope ㋛ (popey) on 2012-05-23
Changed in bamf:
status: In Progress → Invalid
Changed in bamf (Ubuntu):
status: Confirmed → Invalid
description: updated
Changed in bamf (Ubuntu Precise):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
Changed in bamf (Ubuntu Precise):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu2

---------------
unity (5.12-0ubuntu2) quantal; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed

Hello Lucas, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Miloš Jakovljević (milos-sd) wrote :

If it is " unity 5.12-0ubuntu1.1 package, then it doesn't work, at least with Firefox.

Probably the problem you're getting is related to #978401(even if not pinning / unpinning).

markb (mark-blakeney) wrote :

As per comment #26, I installed unity 5.12-0ubuntu1.1 from precise-proposed (which pulled in 3 other unity packages from proposed) to verify my problem described in comment #22. It seems kmymoney does show a launcher icon now but there is odd behaviour. For about the first 80 secs after I log in I get 2 kmymoney icons every time I start it. Also, the super key does not work reliably in this version of unity. It works (slowly?) if there is at least one active window, but does not work if no apps are running or even if no active windows, i.e. does not work if all windows minimised. Pressing the dash launcher icon works, just not the super key.

Sebastien Bacher (seb128) wrote :

@markb: your issue seems a different one, could you open a new bug report with the details on how you trigger it?

Alan Pope ㋛ (popey) on 2012-06-01
tags: added: verification-done
removed: verification-needed

I experience the following: sometimes some applications' lenses are not shown in Unity (last time Shotwell). The lens showd up as the app was loading and than it disappeared completely. Moreover when trying to switch between applications with alt+tab Shotwell was not there either. I have experienced this with various apps. When this happens I have to minimize every other app to see the one not showing up. Once I minimize the app with the problem I have no chance to switch to it.

I have experienced this issue with various apps on a random basis. Logging out and back solves the problem (but Compiz crashing and restarting solves it too...)

I am running a fully updated 64bit precise.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu1.1

---------------
unity (5.12-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
no longer affects: unity/5.0
Changed in unity:
milestone: 5.14.0 → 6.0
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-07-09
Changed in unity-2d:
status: Confirmed → Invalid
Didier Roche (didrocks) on 2012-07-10
Changed in bamf:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
description: updated

This is still affecting me in Ubuntu 12.10 Quantal (Alpha 3)

proteus (proteus) wrote :

Same here, with Ubuntu 12.04 LTS

VMWare Player "disappeared", can't be accessed from Launcher or with ALT+Tab or Magic+W, however I can see that the virtual machines in there are actually running (can be accessed remotely).

Benjamin (nailartcenter) wrote :

Same problem with Ubuntu 12.04 Unity 3d as #34 but with firefox Nightly from PPA

Craig McQueen (cmcqueen1975) wrote :

This is affecting me with Ubuntu 12.10 with apps such as gedit, Archive Manager (aka file-roller), Skype.

To post a comment you must log in.