bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()

Bug #754225 reported by henry adler on 2011-04-08
This bug affects 310 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Unassigned
Unity
Fix Released
Critical
Jason Smith
bamf (Ubuntu)
Critical
Unassigned
Natty
Critical
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Using Firefox to upload mp3s to Amazon Cloud drive

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: bamfdaemon 0.2.84-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashCounter: 1
Date: Thu Apr 7 21:03:42 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/bamf/bamfdaemon
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcCmdline: /usr/lib/bamf/bamfdaemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: bamf
StacktraceTop:
 dbus_g_connection_register_g_object () from /usr/lib/libdbus-glib-1.so.2
 bamf_view_export_on_bus ()
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
UpgradeStatus: Upgraded to natty on 2011-04-06 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

henry adler (anachoret) wrote :
visibility: private → public
zoran (zokiskopje) wrote :

Using Firefox to upload pictures on Facebook

StacktraceTop:
 dbus_g_connection_register_g_object (connection=0x11e5b08, at_path=0x12a4970 "/org/ayatana/bamf/application1317066255", object=0x13338e0) at dbus-gobject.c:2590
 bamf_view_export_on_bus (view=0x13338e0) at bamf-view.c:475
 bamf_matcher_register_view (self=0x11828a0, view=0x13338e0) at bamf-matcher.c:149
 bamf_matcher_setup_window_state (self=0x11828a0, window=<value optimized out>) at bamf-matcher.c:1227
 handle_raw_window (self=0x11828a0, window=<value optimized out>) at bamf-matcher.c:1331

Changed in bamf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Omer Akram (om26er) on 2011-04-08
Changed in bamf:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Namlee85 (namlee85) wrote :

i updated and restarted and then this new error came

Didier Roche (didrocks) wrote :

We get a lot of duplicate on this bug, setting the priority and target it

Changed in bamf:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in bamf (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.8.6
Timothy Kross (timkross) wrote :

Got this while saving an image with GIMP.

Jason Smith (jassmith) wrote :

Try #2 - Getting the second half of the bug

Changed in unity:
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

I started meshlab from terminal, system froze, went to tty and killed meshlab bamf crashed and now the launcher looks like this

Stefan (sbossb) wrote :

Got this error when trying to make a youtube video fullscreen

omarly666 (omarly666) wrote :

no idea what triggered it. all seems ok after a restart. restarts was ok now but earlier they have not shut down correctly

peterzay (peterzay) wrote :

Got this bug when launching KMyMoney for the first time.

Jason Smith (jassmith) wrote :

Should be fixed by mondays release

Changed in bamf:
status: Confirmed → Fix Committed
Juozas Pocius (juozaspo) wrote :

crashed at a time of exiting youtube fullscreen mode on firefox

Juan Montoya (th3pr0ph3t) wrote :

Everytime I open a new window or something it dies.. :S

vininim (vininim) wrote :

I have experimental 3d nouveau driver. Not sure if it's relevant or not since I enabled it since update from 10.10.

Didier Roche (didrocks) on 2011-04-11
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.86-0ubuntu1

---------------
bamf (0.2.86-0ubuntu1) natty; urgency=low

  * New upstream release.
    - bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
      (LP: #752137)
    - bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
      (LP: #754225)
 -- Didier Roche <email address hidden> Mon, 11 Apr 2011 12:41:48 +0200

Changed in bamf (Ubuntu):
status: Confirmed → Fix Released
tfmoraes (tfmoraes) wrote :

I was plotting a graph with gnuplot.

Andre Cataldi (acataldi) wrote :

It just happened to me while trying to attach a file to a web form, using an upload component.

I'm using 11.04 beta 1, 64-bit on a Lenovo T520. The crash occurred when I opened eclipse for the first time. Google Chrome was already running. Eclipse is working and responsive. I don't know what the crash was, or how it has affected the performance of my machine.

Description: Ubuntu Natty (development branch)
Release: 11.04

eclipse:
  Installed: (none)
  Candidate: 3.5.2-8ubuntu3
  Version table:
     3.5.2-8ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages

Expected behavior:
eclipse opens and I use it to do some Drupal coding

What happened instead:
eclipse opened but then "bamf" crashed. I don't think it negatively affects my ability to continue using eclipse, but it does appear to be a problem.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: bamfdaemon 0.2.86-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Mon Apr 11 09:04:20 2011
ExecutablePath: /usr/lib/bamf/bamfdaemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcCmdline: /usr/lib/bamf/bamfdaemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: bamf
StacktraceTop:
 dbus_g_connection_register_g_object () from /usr/lib/libdbus-glib-1.so.2
 bamf_view_export_on_bus ()
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in unity:
status: Fix Released → Triaged
Changed in bamf (Ubuntu):
status: Fix Released → Triaged
sdaau (sd-imi) wrote :

Was just using Thunderbird - then this crash appeared, and seemingly didn't affect anything - the system just kept on working fine...

Lord Delta (lorddefinitia) wrote :

I'm having something similar to this bug very, very often, my bug manager keeps on telling me bamfdaemon crashes, using Natty...

I'll post full logs here next time it crashes, if anyone would like me to/it would be helpful.

Lord Delta (lorddefinitia) wrote :
Download full text (3.3 KiB)

System: Linux 2.6.38-8-generic #41-Ubuntu SMP Tue Apr 5 19:30:49 UTC 2011 x86_64
X Vendor: The X.Org Foundation
X Vendor Release: 11000000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Divinorum-Green Fixed Panel
Icon Theme: Elegant-AwOken
GTK+ Modules: gnomesegvhandler, canberra-gtk-module

Memory status: size: 303235072 vsize: 303235072 resident: 11640832 share: 6717440 rss: 11640832 rss_rlim: 18446744073709551615
CPU usage: start_time: 1302609307 rtime: 31 utime: 17 stime: 14 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

---- Critical and fatal warnings logged during execution ----

** GLib-GObject **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
** GLib-GObject **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
** GLib-GObject **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
** GLib-GObject **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
** GLib-GIO **: g_icon_to_string: assertion `icon != NULL' failed
** GLib-GIO **: g_icon_to_string: assertion `icon != NULL' failed
** bamfdaemon **: Failed to register GObject with DBusConnection

----------- .xsession-errors ---------------------
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (process:2219): DEBUG: zeitgeist-datahub.vala:174: Inserting 1 events
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2061): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwn...

Read more...

Didier Roche (didrocks) wrote :

This one isn't fixed seeing the number of dups of bug #754225. Can you have another look please Jason?

Changed in unity:
milestone: 3.8.6 → 3.8.8
importance: High → Critical
Changed in bamf (Ubuntu):
importance: High → Critical
Changed in bamf:
status: Fix Released → Triaged
importance: High → Critical
Şahin Alp Taşkaya (sahin) wrote :

I got it after I tried to save a screenshot taken with Screengrab extension in Firefox.

Kate Stewart (kate.stewart) wrote :

Using FireFox, and trying to upload crash report about another bug, triggered this for me on fresh 11.04 beta install.

Changed in bamf (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Simon Charette (charettes) wrote :

Launched Empathy

Jan Rathmann (kaiserclaudius) wrote :

I am also seeing this while testing beta-2 candidate images. Don't know whether this is coincidence or not, but the crash dialog appeared exactly when I just clicked to open a text a document in LibreOffice's file chooser.

tags: added: iso-testing
Jared (jared-vanvolkenburg) wrote :

I got this crash when zooming in and trying to save a background from gnome.org using firefox 4.0
I had launched firefox from Appearance Preferences by clicking on the "Get more backgrounds online" link at the bottom of the dialog box. The Appearance Preferences was launched by right clicking on the desktop and choosing to change the background.

http://ftp.gnome.org/pub/GNOME/teams/art.gnome.org/backgrounds/NATURE-Freedom_scalable.jpg

Jared (jared-vanvolkenburg) wrote :

I also am up to date on all the latest updates.

Kate Stewart (kate.stewart) wrote :

11.04 beta candidate image, after doing update from clean 10.10, updated system.

Went to report a bug, and add an attachment, and this crash occured when going to browse for the file to attach.

Have extracted crash log, and transfered it to other system, so can do the upload.

Kate, Could you please double click on the .crash file and report it
using the automatic system.

Changed in bamf (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → none
milestone: none → ubuntu-11.04-beta-2
sdaau (sd-imi) wrote :

Hi, maybe I have discovered something related to this (maybe not).

The thing is, I'm using Firefox from Mozilla (actually, Minefield, while I leave the default Ubuntu Firefox as is).. I have noticed that when I click on a file upload widget (say, as on imageshack.us), and try to type the path while relying on autocompletion - the autocompletion may work a couple of time (i.e. /media/mydrive) - but on subsequent paths, something freezes, and I can usually see the generic program icons (as such is my Minefield icon) getting propped full in the Unity bar on the left hand side.

Here usually the system freezes with varying levels of responsiveness - but I can usually Ctrl-Alt-F1 and login to a shell; and here, if I do `top`, I can often see `bamfdaemon` first on the list running at 40-80% CPU. `sudo service gdm restart` then helps recovery (and if you can exit the file upload window OK, just restarting firefox would do). Maybe this also has to do with me enabling old plugins to work in Firefox too, dunno.

Anycase, hope this can help !

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.86-0ubuntu2

---------------
bamf (0.2.86-0ubuntu2) natty; urgency=low

  * Trunk commit r358, really fixes the crash bug listed before (lp: #754225)
 -- Sebastien Bacher <email address hidden> Tue, 12 Apr 2011 22:19:24 +0200

Changed in bamf (Ubuntu Natty):
status: Triaged → Fix Released
Tony Themelis (tony-athemelis) wrote :

On April 12, 2011 at 5:15 PM Launchpad Bug Tracker <email address hidden>
wrote:

> This bug was fixed in the package bamf - 0.2.86-0ubuntu2
>
> ---------------
> bamf (0.2.86-0ubuntu2) natty; urgency=low
>
>   * Trunk commit r358, really fixes the crash bug listed before (lp: #754225)
>  -- Sebastien Bacher <email address hidden>   Tue, 12 Apr 2011 22:19:24 +0200
>
> ** Changed in: bamf (Ubuntu Natty)
>        Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/754225
>
> Title:
>   bamfdaemon crashed with SIGABRT in
>   dbus_g_connection_register_g_object()
>
> Status in BAMF Application Matching Framework:
>   Triaged
> Status in Unity:
>   Triaged
> Status in “bamf” package in Ubuntu:
>   Fix Released
> Status in “bamf” source package in Natty:
>   Fix Released
>
> Bug description:
>   Using Firefox to upload mp3s to Amazon Cloud drive
>
>   ProblemType: Crash
>   DistroRelease: Ubuntu 11.04
>   Package: bamfdaemon 0.2.84-0ubuntu1
>   ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
>   Uname: Linux 2.6.38-8-generic x86_64
>   NonfreeKernelModules: nvidia
>   Architecture: amd64
>   CrashCounter: 1
>   Date: Thu Apr  7 21:03:42 2011
>   EcryptfsInUse: Yes
>   ExecutablePath: /usr/lib/bamf/bamfdaemon
>   InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
>   ProcCmdline: /usr/lib/bamf/bamfdaemon
>   ProcEnviron:
>    SHELL=/bin/bash
>    LANGUAGE=en_US:en
>    LANG=en_US.UTF-8
>   Signal: 6
>   SourcePackage: bamf
>   StacktraceTop:
>    dbus_g_connection_register_g_object () from /usr/lib/libdbus-glib-1.so.2
>    bamf_view_export_on_bus ()
>    ?? ()
>    ?? ()
>    g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
>   Title: bamfdaemon crashed with SIGABRT in
>dbus_g_connection_register_g_object()
>   UpgradeStatus: Upgraded to natty on 2011-04-06 (1 days ago)
>   UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/bamf/+bug/754225/+subscribe
"

Jason Smith (jassmith) on 2011-04-12
Changed in bamf:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Ant Dickens (antonydickens) wrote :

Crash happened whilst I was using Gwibber

Didier Roche (didrocks) on 2011-04-14
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Natty):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers