some launchers change icons when running

Bug #645849 reported by Didier Roche on 2010-09-23
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Jason Smith
bamf (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Following bug #622146 with latest unity:

1. add a custom launcher (with custom icon, like mahjong, opening totem)
2. at start, you will see the majhong's icon
3. clicking on it, it will launch totem
BUT here the icon changes to totem

look also to duplicate (evolution express icon changing)

Related branches

Didier Roche (didrocks) on 2010-09-23
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2010-09-28
summary: - special launchers still doesn't have the right icons
+ some launchers change icons when running
description: updated
Didier Roche (didrocks) wrote :

there is an annoying side effect with that one, you can't add evolution express (any of the component) to the launcher…

Didier Roche (didrocks) on 2010-09-29
affects: unity (Ubuntu) → bamf (Ubuntu)
David Barth (dbarth) on 2010-09-29
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 2010-09-27
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.58-0ubuntu2

---------------
bamf (0.2.58-0ubuntu2) maverick; urgency=low

  * Fix tons of accuracy matching issues using the gio module
    (LP: #645849, #630066)
 -- Didier Roche <email address hidden> Thu, 30 Sep 2010 17:14:27 +0200

Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) on 2010-11-27
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers