avidemux version 1:2.5.4-0ubuntu7 failed to build in oneiric

Bug #831096 reported by Matthias Klose on 2011-08-22
284
This bug affects 54 people
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
High
Daniel van Vugt
Oneiric
High
Daniel van Vugt

Bug Description

avidemux version 1:2.5.4-0ubuntu7 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2688988

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2688988/+files/buildlog_ubuntu-oneiric-amd64.avidemux_1%3A2.5.4-0ubuntu7_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 7786 lines into the build log:

make[3]: Leaving directory `/build/buildd/avidemux-2.5.4/plugins/build'
make[3]: Entering directory `/build/buildd/avidemux-2.5.4/plugins/build'
[ 11%] Building C object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/interface.c.o
[ 11%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/configGuiLoader.cpp.o
[ 11%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/encoder.cpp.o
/build/buildd/avidemux-2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/encoder.cpp: In member function 'void x264Encoder::printParam(x264_param_t*)':
/build/buildd/avidemux-2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/encoder.cpp:492:48: error: 'x264_param_t' has no member named 'i_open_gop'
make[3]: *** [ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/encoder.cpp.o] Error 1
make[3]: Leaving directory `/build/buildd/avidemux-2.5.4/plugins/build'
make[2]: *** [ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/all] Error 2
make[2]: Leaving directory `/build/buildd/avidemux-2.5.4/plugins/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/avidemux-2.5.4/plugins/build'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110819-2159
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/avidemux-2.5.4

Related branches

lp:~vanvugt/ubuntu/precise/avidemux/fix-831096
Ubuntu branches: Pending requested 2011-10-17
Matthias Klose (doko) on 2011-08-22
Changed in avidemux (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matthias Klose (doko) wrote :

2011-09-06 23:43:36 INFO Removing candidates:
2011-09-06 23:43:36 INFO avidemux 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-qt 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-qt 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-qt 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-cli 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-cli 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-cli 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-common 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-common 1:2.5.4-0ubuntu7 in oneiric armel
2011-09-06 23:43:36 INFO avidemux-common 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-common 1:2.5.4-0ubuntu7 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-plugins-common 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-plugins-common 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-plugins-common 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-plugins-gtk 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-plugins-gtk 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-plugins-gtk 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-plugins-qt 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-plugins-qt 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-plugins-qt 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO avidemux-plugins-cli 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO avidemux-plugins-cli 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO avidemux-plugins-cli 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO libavidemux0 1:2.5.4-0ubuntu7 in oneiric amd64
2011-09-06 23:43:36 INFO libavidemux0 1:2.5.4-0ubuntu7 in oneiric i386
2011-09-06 23:43:36 INFO libavidemux0 1:2.5.4-0ubuntu6 in oneiric powerpc
2011-09-06 23:43:36 INFO Removed-by: Matthias Klose
2011-09-06 23:43:36 INFO Comment: FTBFS, no rdepends, LP: #831096
2011-09-06 23:43:36 INFO 28 packages successfully removed.

Martin Pitt (pitti) on 2011-09-13
Changed in avidemux (Ubuntu Oneiric):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
William (bthomas-akld) wrote :

Shouldn't this be 2.5.5 - bug fix realease came out in June

Doug McMahon (mc3man) wrote :

To resolve the error you'll need to patch avidemux for the current libx264
Attaching debian-multimedia patch for 2.5.5 as an example, info purposes
Works as intended on 2.5.5 source using 11.10's current libs inc. libx264-dev , ect., did not try on 11.10's previous avidemux source as it's been removed

The attachment "03_x264-115.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Martin Pitt (pitti) wrote :

Unfortunately that's not sufficient. With and without the patch the build fails with

[ 86%] Built target ADM_coreAudio
make[3]: Entering directory `/home/martin/ubuntu/tmp/dm/avidemux-2.5.5/build'
make[3]: *** No rule to make target `avidemux/ADM_libraries/ffmpeg/libswscale/libADM5swscale.so.0', needed by `avidemux/ADM_coreImage/src/libADM_coreImage.so'. Stop.

That affects both the upstream tarball as well as the current debian-multimedia version.

Martin Pitt (pitti) wrote :

And before it dies with

LD libavcodec/libADM5avcodec.so.52
/usr/bin/ld.bfd.real: libavcodec/x86/deinterlace.o: relocation R_X86_64_PC32 against symbol `ff_pw_4' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld.bfd.real: final link failed: Bad value

which isn't easy to solve as well, as the sources are already built with -fPIC. Using gcc 4.5 doesn't help either.

Martin Pitt (pitti) wrote :

I'm sorry, I spent some 1.5 hours on it, but this is too involved for a casual drive-by fix. The binaries are removed from oneiric, so this isn't release critical.

Changed in avidemux (Ubuntu Oneiric):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Won't Fix
Changed in avidemux (Ubuntu):
status: In Progress → Triaged
assignee: Martin Pitt (pitti) → nobody
Doug McMahon (mc3man) wrote :

While when previously commenting was on a 32 bit install, now on 64 bit & see no issue with a local build of 2.5.5 as long as x264 patch is applied. (haven't tried a package build

The .so mentioned in #5 is built no issue - ,3 6 doesn't occur
ldd /usr/bin/avidemux2_gtk
 linux-vdso.so.1 => (0x00007fff083ff000)
 libADM5avutil.so.50 => /usr/lib/libADM5avutil.so.50 (0x00007ff6584d0000)
 libADM5postproc.so.51 => /usr/lib/libADM5postproc.so.51 (0x00007ff6582a9000)
 libADM5swscale.so.0 => /usr/lib/libADM5swscale.so.0 (0x00007ff65804f000)
 libADM5avcodec.so.52 => /usr/lib/libADM5avcodec.so.52 (0x00007ff6577e0000)
 libADM5avformat.so.52 => /usr/lib/libADM5avformat.so.52 (0x00007ff6575a8000)
Are you having the included patches applied? (avidemux-2.5.5/cmake/patches

$ avidemux2_gtk
*************************
  Avidemux v2.5.5
*************************
 http://www.avidemux.org
 Code : Mean, JSC, Grant Pedersen
 GFX : Nestor Di, <email address hidden>
 Design : Jakub Misak
 FreeBSD : Anish Mistry, <email address hidden>
 Audio : Mihail Zenkov
 Mac OS X : Kuisathaverat, Harry van der Wolf
 Win32 : Grant Pedersen

Compiler: GCC 4.6.1
Build Target: Linux (x86-64)
User Interface: GTK+ (2.24.6)

Large file available: 1 offset

Initialising prefs
Directory /home/doug/.avidemux exists.Good.
ect.

Doug McMahon [2011-10-01 0:14 -0000]:
> Are you having the included patches applied? (avidemux-2.5.5/cmake/patches

Yes, I did. I also tried building the unmodified source from
debian-multimedia. But I only tried on amd64, I don't have an i386
builder right now. If there's a chance that it builds on i386, I'll
have another go at it next week.

Doug McMahon (mc3man) wrote :

On amd_64 a package build fails exactly as noted (using a slightly edited DM control/rules, though a local build is ok (w/ x264 patch
Taking the supplied ffmpeg source in avidemux-2.5.5 & configuring the same ( using avidemux-2.5.5/build/avidemux/ADM_libraries/ffmpeg/config.fate from package build attempt), produces the same error/fail

If instead I configure that ffmpeg source with attached configure then it builds successfully/completely, possibly it would work in a package build? (haven't tried

tail end -
LD libswscale/libswscale.so.0
CC ffmpeg.o
ffmpeg.c: In function ‘term_exit’:
ffmpeg.c:442:5: warning: zero-length gnu_printf format string [-Wformat-zero-length]
ffmpeg.c: In function ‘do_video_out’:
ffmpeg.c:1145:50: warning: variable ‘resampling_dst’ set but not used [-Wunused-but-set-variable]
ffmpeg.c: In function ‘opt_output_file’:
ffmpeg.c:3868:13: warning: ‘url_exist’ is deprecated (declared at libavformat/avio.h:345) [-Wdeprecated-declarations]
CC cmdutils.o
cmdutils.c: In function ‘opt_default’:
cmdutils.c:302:22: warning: initialization discards ‘const’ qualifier from pointer target type [enabled by default]
cmdutils.c: In function ‘read_file’:
cmdutils.c:808:10: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Wunused-result]
LD ffmpeg_g
CP ffmpeg
STRIP ffmpeg
doug@doug-XPS-M1330:~/Desktop/ffmpeg-0.7-rc1$

Doug McMahon (mc3man) wrote :

ffmpeg test log attached

Doug McMahon (mc3man) wrote :

The problem flag here, (--extra-ldflags created in config.h) seems to be -Bsymbolic-functions

Changed in avidemux (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: added: regression-release
Reinhard Tartler (siretart) wrote :

Excellent, thanks and uploaded to precise!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.4-0ubuntu8

---------------
avidemux (1:2.5.4-0ubuntu8) precise; urgency=low

  * Fix build failure of 1:2.5.4-0ubuntu7 (LP: #831096) due to:
    - changed structure members in x264.h release 115 and later;
    - missing install rule for i18n files;
    - missing dependency on xsltproc, causing unpredictable failures
      on systems without xsltproc.
 -- Daniel van Vugt <email address hidden> Mon, 17 Oct 2011 17:27:32 +0800

Changed in avidemux (Ubuntu):
status: Triaged → Fix Released

Now that the fix is in Precise, should this still be Won't Fix in Oneiric? Doesn't this qualify for the fix to be backported to Oneiric as an SRU? After all, it renders the package completely unusable, as documented here and more explicitly in duplicate bug 875744.

Benjamin Drung (bdrung) wrote :

Yes, this qualifies it for the fix to be backported to Oneiric as an SRU.

Changed in avidemux (Ubuntu Oneiric):
status: Won't Fix → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in avidemux (Ubuntu Oneiric):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Umm, no one has merged the proposal in yet. How is it this is marked Fix Released when the code isn't committed yet?

Changed in avidemux (Ubuntu Oneiric):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: removed: patch
Martin Pitt (pitti) wrote :

It's fine to take the precise package as-is and just reupload as an SRU with smaller version number. But let's have the precise version build first.

Thanks, Daniel!

Daniel van Vugt (vanvugt) wrote :

The Status for precise "avidemux (Ubuntu)" should probably be "In Progress". It is certainly not even Fix Committed yet. That's why I'm confused how we jumped to "Fix Released" already. There has been no commit yet.

See:
lp:ubuntu/avidemux
https://code.launchpad.net/~vanvugt/ubuntu/precise/avidemux/fix-831096/+merge/79534

Martin Pitt (pitti) wrote :

Daniel, see comment 10 -- precise was already uploaded.

Daniel van Vugt (vanvugt) wrote :

(still confused)

Does this mean Bazaar will magically commit the fix to lp:ubuntu/avidemux later?

Reinhard Tartler (siretart) wrote :

Yes, as soon as the launchpad package importer imports the upload. As there has been a mass-sync from Debian just recently, this may take some time at this point.

Marcus Sundman (sundman) wrote :

There was talk about 2.5.5, but apparently we're back to (the very old) version 2.5.4 now. Was that on purpose?

Reinhard Tartler (siretart) wrote :

@Marcus (comment #24): Upgrading to 2.5.5 is tracked in Bug #793581. This bug is about fixing 2.5.4 to build again.

description: updated
Changed in avidemux (Ubuntu Oneiric):
status: Confirmed → In Progress

Hello Matthias, or anyone else affected,

Accepted avidemux into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in avidemux (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
description: updated
Martin Pitt (pitti) wrote :

I binNEWed the packages, so they are ready for testing.

Evan Broder (broder) wrote :

Unsubscribing ubuntu-sponsors, as it looks like there's no sponsorship that still needs to be done. Please feel free to resubscribe if I'm misread the history.

Papamatti (matti-lx) wrote :

I install avidemux and the plugins from proposed without problems.
I test the program tomorrow, for a 5 minute test today it looks very good!

Daniel van Vugt (vanvugt) wrote :

Verification done. 1:2.5.4-0ubuntu7.1 works well on amd64 and i386.

tags: added: verification-done
removed: verification-needed
Papamatti (matti-lx) wrote :

I've tested avidemux gtk from proposed and it works very well on my amd64 oneiric ocelot.
Bug is fixed for me.

Papamatti (matti-lx) wrote :

Thank you all for the fast bugfix!

durnberj (durnberj) wrote :

well done! thx!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.4-0ubuntu7.1

---------------
avidemux (1:2.5.4-0ubuntu7.1) oneiric-proposed; urgency=low

  * Fix build failure of 1:2.5.4-0ubuntu7 (LP: #831096) due to:
    - changed structure members in x264.h release 115 and later;
    - missing install rule for i18n files;
    - missing dependency on xsltproc, causing unpredictable failures
      on systems without xsltproc.
  * Identical to 1:2.5.4-0ubuntu8
 -- Daniel van Vugt <email address hidden> Mon, 17 Oct 2011 17:27:32 +0800

Changed in avidemux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions