Allow only one AWN instance

Bug #258675 reported by Bernhard on 2008-08-17
4
Affects Status Importance Assigned to Milestone
Awn
Medium
Unassigned
avant-window-navigator (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: avant-window-navigator

I noticed that awn and avant-window-navigator processes just keep piling up when I start Avant Window Navigator more than once. Couldn't awn be configured so that any new start of awn is treated as a restart? I guess there is no need to run awn more than once anyway.

I noticed that this bug is related to (and probably the deeper reason for) bug #257939.

Bernhard (b.a.koenig) wrote :

This bug is also related to bug #258960.

Michal Hruby (mhr3) on 2009-01-26
Changed in awn:
importance: Undecided → Medium
milestone: none → 0.4.0
status: New → Confirmed
Julien Lavergne (gilir) on 2009-02-16
Changed in avant-window-navigator:
status: New → Confirmed
Julien Lavergne (gilir) on 2009-03-10
Changed in avant-window-navigator:
importance: Undecided → Low
Julien Lavergne (gilir) wrote :

I think it's fixed in the rewrite.

Changed in avant-window-navigator:
status: Confirmed → Triaged
Changed in awn:
status: Confirmed → Triaged
status: Triaged → Fix Committed
marcuskoze (tekkro-gmail) wrote :

I'm on Jaunty, using the AWN from the official repos (version 0.3.2-0ubuntu2) and have the same problems, specialy after adding something in the bar (launchers, applets etc) or sometimes after i close an app and the icon fades, after which it freezes (but this latter case is much more rare than the addition of items in the bar).

running this:
  gconftool-2 -g '/apps/metacity/general/compositing_manager'

returns 'false', i guess because there's no driver for the ATI graphic card on my laptop.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.3.9~bzr1890-0ubuntu1

---------------
avant-window-navigator (0.3.9~bzr1890-0ubuntu1) lucid; urgency=low

  * New upstream snapshot.
   - Fix autohide behavior (LP: #130235)
   - Allow only 1 instance of Awn (LP: #258675)
  * debian/patches:
   - 10_correct_exception.patch: Dropped, problem fixed in the new version.
   - 00-wm-behavior.patch and 01-tasks-have-arrow.patch: Merged upstream.
   - 03-python-import.patch: Refresh.
  * Bump libawn SONAME.
  * debian/control:
   - Add minimum requirement for libwnck-dev libgtk2.0-dev and libglib2.0-dev.
   - Drop build-depends on libgnome2-dev, libgnome-desktop-dev, libglade2-dev.
   - Bump build-depends for debhelper to (>= 7.0.50~) for overrides.
   - Build-depends on libgtop2-dev.
   - Replace build-depends on python-gnome-dev by python-gtk2-dev (>= 2.12).
   - Build-depends on gconf2, libdesktop-agnostic-dev, libdesktop-agnostic-bin,
     python-desktop-agnostic, vala-desktop-agnostic for desktop-agnostic
     support.
   - Demote the composite manager to Recommends, Awn works without it.
   - Depends on libdesktop-agnostic-* and dbus.
   - Bump libawn SONAME.
   - Rename awn-manager to awn-settings.
   - libawn-dev : drop libgnome*-dev and add libdesktop-agnostic-dev depends.
   - Replace depends on awn-manager by Recommends on awn-settings for
     avant-window-navigator.
   - Add depends on avant-window-navigator, python-desktop-agnostic, bzr and
     python-dbus for awn-settings.
   - Replace vala depends by vala-desktop-agnostic for vala-awn.
   - Bump standard version to 3.8.3, no change needed.
   - Add Conflicts/Replaces to replace separator applets which is in core now.
  * debian/rules:
   - Rewrite with overrides.
   - Remove awn.wrapper.
   - Bump libawn SONAME.
   - Remove LDFLAGS and useless flag from configure.
  * debian/awn.wrapper & debian/avant-window-navigator.links:
   - Dropped, previous configuration is incompatible.
  * debian/avant-window-navigator{,-data}.install:
   - Update installed files in core.
   - Install core applets
  * debian/awn-manager.install
   - Rename to awn-settings.install
   - Update installed files.
  * debian/awn-applet*.1 && debian/avant-window-navigator.manpages
   - Update manpages.
  * debian/awn-manager.*
   - Rename awn-manager to awn-settings.
   - Remove unused manpages.
  * debian/python-awn:
   - Update to the new location.
  * debian/README.Debian:
   - Mention that real transparency is not needed.
   - Add mutter in the list of composite managers.
  * debian/copyright:
   - Update copyright and licenses.
 -- Julien Lavergne <email address hidden> Mon, 11 Jan 2010 22:27:06 +0100

Changed in avant-window-navigator (Ubuntu):
status: Triaged → Fix Released
Mark Lee (malept) on 2010-04-12
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers