missing dependencies

Bug #1868594 reported by Norbert on 2020-03-23
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ausweisapp2 (Debian)
Fix Released
Unknown
ausweisapp2 (Ubuntu)
Low
Unassigned
Focal
Low
Unassigned

Bug Description

The program need this:

sudo apt install qml-module-qtqml-models2 qml-module-qtquick2

I have already fixed this in Debian, see Debian bug #951732, although I'm not aware that "qtdeclarative5-models-plugin" needs to be explicitly installed.

In any case, I don't have any influence on packages in Ubuntu, so one of the Canonical folks need to do that.

FWIW, the package qtdeclarative5-models-plugin doesn't exist in Debian.

Juhani Numminen (jsonic) wrote :

Hello Adrian, I filed a bug #1868603 asking Ubuntu developers to pull the fixed package.

Thanks, Juhani.

Norbert (asterix52) wrote :

> I'm not aware that "qtdeclarative5-models-plugin" needs to be explicitly installed

Sorry c&p fault.

description: updated
Mathew Hodson (mhodson) on 2020-03-26
tags: added: unmetdeps
Changed in ausweisapp2 (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ausweisapp2 (Ubuntu):
status: New → Confirmed
Changed in ausweisapp2 (Debian):
status: Unknown → Fix Released
Mathew Hodson (mhodson) on 2020-04-29
Changed in ausweisapp2 (Ubuntu):
status: Confirmed → Fix Released
Changed in ausweisapp2 (Ubuntu Focal):
importance: Undecided → Low
Changed in ausweisapp2 (Ubuntu Focal):
status: New → Confirmed
Mathew Hodson (mhodson) wrote :

ausweisapp2 (1.20.0-2) unstable; urgency=medium

  * Add missing qml packages to Depends in debian/control (Closes: #951732)
    - Add qml-module-qtquick-controls2 to Depends for ausweisapp2 package
    - Add qml-module-qtqml-models2 to Depends for ausweisapp2 package

 -- John Paul Adrian Glaubitz <email address hidden> Sun, 15 Mar 2020 17:16:50 +0100

Tobias Ginzler (tginzler) wrote :

Reading the bug reports and trying to fix the problem, I think I might have discovered some additional missing dependencies in the package.

I started from an qt-free system and installed ausweisapp2 1.20.0-1build1. Then I installed qml-module-qtquick-controls2 and qml-module-qtqml-models2 manually. The GUI of ausweisapp2 still does not start. Seeing through the log of ausweisapp2, some qml modules are still missing. These are:

qml-module-qtgraphicaleffects
qml-module-qtquick-layouts
qml-module-qtquick-templates2
qml-module-qtquick-window2
qml-module-qtquick2

After installing those, the ausweisapp2 starts also with its graphical front end.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.