Ubuntu

Nautilus audio convert script doesn't activate itself

Reported by Luke Hoersten on 2007-08-02
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
audio-convert (Ubuntu)
Wishlist
Emmet Hikory

Bug Description

Binary package hint: nautilus-script-audio-convert

Installing the package doesn't actually add the audio conversion menu to nautilus. To do so, the user must read '/usr/share/doc/nautilus-script-audio-convert/README.Debian' and discover they must run:

'nautilus-script-manager enable ConvertAudioFile'

This is too confusing for my parents to figure out. This command should probably be added to the post-install script.

description: updated
Emmet Hikory (persia) on 2007-12-17
Changed in audio-convert:
assignee: nobody → persia
importance: Undecided → Wishlist
status: New → In Progress
Emmet Hikory (persia) wrote :

audio-convert (0.3.1.1-0ubuntu4) hardy; urgency=low

  * Add watch file
  * Bump standards to 3.7.3
  * Add postinst & prerm to enable/disable ConvertAudioFile (LP: #130055)
  * Drop no longer needed README.Debian
  * Reset to team maintenance
  * Drop extra pluralisations from debian/copyright
  * Add English README & upstream changelog

 -- Emmet Hikory <email address hidden> Mon, 17 Dec 2007 12:48:54 +0900

Changed in audio-convert:
status: In Progress → Fix Released
mp (m-p) wrote :

Confirm this bug in Intrepid, fresh, clean install.

Luke Hoersten (lukehoersten) wrote :

Works in Intrepid. Thanks!

Luke Hoersten wrote:
> Works in Intrepid. Thanks!
>

Not for me!

Unless you mean the manual post-install activation, which I just did to
get it up and running.

So thanks for your help - I didnt have the problem before, only now in
Intrepid!??!? Strange...

Now I have a range of issues:

All of the following presumably related bugs are present in
Intrepid's/GNOME's new Nautilus:
https://bugs.launchpad.net/ubuntu/+source/audio-convert/+bug/130055
https://bugs.launchpad.net/ubuntu/+source/nautilus-wallpaper/+bug/144208
https://bugs.launchpad.net/ubuntu/+source/nautilus-image-converter/+bug/269213

This also goes for nautilus image-converter:

1. apt-get install nautilus-image-converter
2. Restart Nautilus (still doesn't appear)
3. Reboot machine (still doesn't appear)

Following the advice on
https://bugs.launchpad.net/ubuntu/+source/audio-convert/+bug/130055 -
which says:

"the user must read
'/usr/share/doc/nautilus-script-audio-convert/README.Debian' and
discover they must run:

'nautilus-script-manager enable ConvertAudioFile'"

..solves the problem with _that_ particular extension/add-on, but the
other add-ons remain absent and essentially renders Nautilus half the
tool it used to be. You cannot resize images, cannot rotate them etc. etc.

All of the scripts normally installable via:

apt-get install nautilus-script-collection-svn

suffer the same problem.

Luke Hoersten (lukehoersten) wrote :

You are correct. I'm only confirming that the post-install script now adds the audio converter to the Nautilus scripts menu correctly and automatically.

It seems you are saying that the post-install script did not automatically add the audio converter to the Nautilus menu. If so, please confirm this is still an issue. If you are reporting other bugs, you should probably open new issues on this tracker for clarity.

Benji (benjaminhardy81) wrote :

I can confirm that installing this package doesn't add the menu item to Nautilus until the Nautilus script manager command line is entered, and Nautilus restarted.

Users new to Nautilus and Nautilus scripts will have no clue or idea to how this works.

barbolani (barbolani-gmail) wrote :

At least in Jaunty, running the nautilus-script-manager enable ConvertAudioFile reports the error:

Error: no script with that name available

If I copy the script to ~/.gnome2/nautilus-scripts then it appears in the context menu and works as advertised.

Pietro Battiston (toobaz) wrote :

To everyone still having problems: the problem is that the fix is broken.
(The nautilus-scripts system itself is almost broken)

Currently, the fix just enables the script for the user installing the package. This means that if user A types
"sudo apt-get install nautilus-script-audio-convert"
, user B will still have to manually install the script.

But there's more (and more urgent, that's why I'm reopening the bug): if user A installs the package and user B tries to uninstall it, then dpkg breaks because the postrm script doesn't find the file it should unlink. Notice it's really not unrealistic even in mono-user systems, since it can be reproduced by just:

sudo apt-get install nautilus-script-audio-convert
sudo su
apt-get remove nautilus-script-audio-convert

On this point, I'd ask Emmet to modify his scripts by adding tests if file exists before trying to remove it.

On the more general issue of improving nautilus scripts useability for all users, I'll try to do some work, but I'll open a different bug.

Changed in audio-convert (Ubuntu):
status: Fix Released → Confirmed
Nicolas Diogo (nicolasdiogo) wrote :

Hi folks,

just to say that there is still a problem with the nautilus extension on ubuntu 9.04 x64.
there are no menu entry after install, and it requires user to run the mentioned command above to enable it.

BUT there is also a matter of what should be defined as dependencies and suggestions.
personally, i could not convert any file until i installed all packages listed as suggestions - maybe someone could have a look at this.

many thanks,

Nicolas

Pietro Battiston (toobaz) wrote :

Nicolas, how did you install the extension?
"su" and then "apt-get install"?
or "sudo apt-get install"?
or synaptic from the menu?

Just to understand if my diagnosis of the situation was correct.

Nicolas Diogo (nicolasdiogo) wrote :

Hi,

i have installed it from Synaptic

thanks

Pietro Battiston (toobaz) wrote :

@Nicolas (and other users): Yes, indeed. Synaptic runs as user root, so all happened is that the script was enabled for root user.

I've written a small scripts manager you may want to try. The package is attached to this post (nautilus-scripts-manager_1.2-1_all.deb), and once installed you find it in System -> Preferences. I'm trying to get it into Debian and hence Ubuntu repositories, but with no luck so far.

Otherwise, a dirtier but simpler solution to your problem is just typing:

  ln -s /usr/share/nautilus-scripts/ConvertAudioFile ~/.gnome2/nautilus-scripts/ConvertAudioFile

in a terminal.

@Emmet (or other Ubuntu devs): since nautilus-script-manager is bugged (and ugly), if you think nautilus-scripts-manager (notice the "s") could make it in Ubuntu Universe (and maybe become a "Recommend" for packages currently depending on nautilus-script-manager, effectively replacing it), you can find source at
  http://mentors.debian.net/debian/pool/main/n/nautilus-scripts-manager/
changing "unstable" to "karmic" is all what should be needed. I _can_ also upload it on REVU, but not if it's only to loose time and make the "needs review" list longer (to be clear, I'm not blaming anyone, the difficulty of getting a package sponsored is just a fact).
(just for reference, I'm already Debian maintainer of gvb and python-shapely)

Pietro Battiston (toobaz) wrote :

I have opened bug #406798 to distinguish the "bad" bug (the possibility of breaking apt), from the desire to not have to manually enable scripts in a terminal.

BrianK (baking666) wrote :

I'm using ubuntu 9.10 and yes i'm having similar problems installing nautilus-script-audio-convert...but my question is...

Why not have it laid out in nautilus menu the same as nautilus-image-converter does?? This extension works beautifully :-)

Pietro Battiston (toobaz) wrote :

@BrianK: nautilus-script-audio-convert is not a "nautilus script" in the strict sense: it is something more advanced and complicated from a developer point of view, which indeed integrates in the main nautilus menu.
(notice nautilus scripts in the strict sense aren't "just old technology": I like the idea to have possibly dozens of them in the "scripts" submenu, not cluttering the main nautilus menu)

You may want to install package "nautilus-actions" and then run System->Preferences-> Nautilus actions (or something similar)

Pietro Battiston (toobaz) wrote :

Now that (in Lucid) a graphic interface, nautilus-scripts-manager (notice the "s" in "scripts") , is available (and audio-convert depends on it), I think this bug can be considered as fixed, and I'm hence marking it as such.

What I mean is that
- currently, _really_ enabling a script for _all users_ is impossible without modifications in Nautilus code
- anyway, enabling a script for all users is not necessarily a good thing - every user has his/her tastes, and can choose which/how scripts to enable with nautilus-scripts-manager

so the fact that there is a GUI is the best I can think of.

Changed in audio-convert (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers