asterisk seg faults in masq_park_call

Bug #578613 reported by David Leonard on 2010-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Asterisk
Unknown
Unknown
asterisk (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: asterisk

After an upgrade to 10.04, I get a seg fault in /usr/sbin/asterisk (package version 1:1.6.2.5-0ubuntu1 amd64)

SIGSEGV
(gdb) fr 0
#0 masq_park_call (rchan=0x7f4276028170, peer=0x0,
   timeout=<value optimized out>, extout=<value optimized out>,
   play_announcement=<value optimized out>, args=0x7f424ef90160)
   at features.c:873
873 args->orig_chan_name = ast_strdupa(peer->name);
(gdb) up
#1 0x00007f425083529c in parkandannounce_exec (chan=0x7f4276028170,
   data=<value optimized out>) at app_parkandannounce.c:137
137 res = ast_masq_park_call(chan, NULL, timeout, &lot);
                    https://bit.ly/2BtN52W

This was easily fixed by adding '&& peer' to the conditional at features.c:872.
      if (!play_announcement && args == &pack_args && peer)

thankyou

Paul Belanger (pabelanger) wrote :

Confirmed, already fixed upstream.

Paul Belanger (pabelanger) wrote :

Asterisk 1.6.2.6 or greater includes fix.

Clint Byrum (clint-fewbar) wrote :

Setting to Fix Released since 10.10 included 1.6.2.7, and this fix. Opening lucid task to backport the patch into lucid's asterisk.

Changed in asterisk (Ubuntu):
status: New → Triaged
importance: Undecided → High
status: Triaged → Fix Released
Changed in asterisk (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in asterisk (Ubuntu Lucid):
status: Triaged → Won't Fix
tranadols (tramadols) on 2019-02-13
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.