Ubuntu

Spellcheck doesn't recognize "Ubuntu"

Reported by Chris Zubak-Skees on 2005-04-10
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Bryce Harrington
aspell
Unknown
Unknown
aspell-en (Ubuntu)
Low
Unassigned

Bug Description

When writing "Ubuntu" in the Gaim distributed with Ubuntu the spellcheck does not recognize it as a word and puts a squiggly red line underneath it. The same happens in Evolution and gedit.

Related branches

Luke Schierer (lschiere) wrote :

Gaim's spell checking is provided by gtkspell, which in turn uses aspell. This
should be assigned there.

Lukas Sabota (punkrockguy318) wrote :

Please file this bug upstream.

Ok, I've filed this upstream.

description: updated
Changed in aspell:
status: Unconfirmed → Confirmed
Scott Ritchie (scottritchie) wrote :

This bug is 2 years old now, I think it's time we think about patching it in our branch of aspell :)

Tom Haddon (mthaddon) wrote :

Upstream is recommending creating a personal dictionary. I'm assuming the relevance here would be to create an ubuntu specific dictionary and add the word "Ubuntu" and "ubuntu" to it.

Michael Rooney (mrooney) wrote :

Adding a hundredpapercuts task from the duplicate report. Is there a consensus on how much work would be involved in this; does anyone know if it qualifies as a paper cut? It does seem kind of important that Ubuntu recognize its own name :)

Changed in hundredpapercuts:
status: New → Confirmed
etapombas (brunotrazzini) wrote :

epiphany does not have spellchecker, please enable it

Changed in hundredpapercuts:
milestone: none → round-3

Moving to round-1 so that bug #194213 can move to this round.

Changed in hundredpapercuts:
milestone: round-3 → round-1

"Ubuntu" should not be marked as misspelled.

Changed in hundredpapercuts:
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2009-06-24
affects: aspell (Ubuntu) → aspell-en (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aspell-en - 6.0-0-5.1ubuntu1

---------------
aspell-en (6.0-0-5.1ubuntu1) karmic; urgency=low

  * rules: Add capability for inserting additional words during build,
    using a Feisty-era patch from Soren Hansen.
  * extrawords.txt:
    + Add Ubuntu, UbuntuOne, Canonical, et al (LP: #15200)
    + Add Debian (LP: #93843)
    + Add blog, blogged, blogging (LP: #353522)

 -- Bryce Harrington <email address hidden> Wed, 24 Jun 2009 13:34:10 -0700

Changed in aspell-en (Ubuntu):
status: Confirmed → Fix Released
Chris Zubak-Skees (chriszs) wrote :

Thank you for fixing this bug I filed in April 2005. The Hundred Paper Cuts initiative looks exactly like the mechanism to provide the user experience polish Ubuntu needs, and I am very glad for it.

Vish (vish) wrote :

I can confirm the fix released.

Changed in hundredpapercuts:
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2009-06-25
Changed in hundredpapercuts:
assignee: nobody → Bryce Harrington (bryceharrington)
freakalad (freakalad) wrote :

Same goes for other tech terms, such as USB, bluetooth, FireFox, ThunderBird, etc

Nicolas Delvaux (malizor) wrote :

Ubuntu, UbuntuOne, Canonical and Debian words should ship in every aspell package.

Currently the fix seems to just apply on aspell-en so this bug is still here for a lot of users...

Nicolas Delvaux (malizor) wrote :

Ubuntu, UbuntuOne, Canonical and Debian words should ship in every aspell packages.

Currently the fix seems to just apply on aspell-en so this bug is still here for a lot of users...

I can confirm that this is not fixed for non-english locales in current karmic

Changed in hundredpapercuts:
status: Fix Released → Confirmed
Bryce Harrington (bryce) wrote :

Then file a new bug. I only do english.

Changed in hundredpapercuts:
status: Confirmed → Fix Released

Patching each language individually and maintaining an extra list of words for each of them is certainly not the proper way to add those words to dictionaries IMHO (i.e. extrawords.txt should affect every dictionary)...

I don't care too much about this bug and just thought it was unfair to cater only to English speaking users, Ubuntu philosophy stating "that software tools should be available to people in their local language" other users should not be considered second class citizens (even if this bug is trivial).

Talk is cheap and I don't have code to show so I shall remain silent now ;-)

On Sun, Aug 23, 2009 at 02:08:49AM -0000, Jonathan Ernst wrote:
> Patching each language individually and maintaining an extra list of
> words for each of them is certainly not the proper way to add those
> words to dictionaries IMHO (i.e. extrawords.txt should affect every
> dictionary)...

Of course you're welcome to improve on the patch if you think it could
be better, however since each language-specific dictionary is provided
in a separate package, that'd be pretty hard. Besides, really you want
extrawords.txt to be done specific for each language since some
languages use non-latin letter forms, and most will want to translate
the non-trademark terms.

> I don't care too much about this bug

Evidently you care enough to comment on it. ;-)

> and just thought it was unfair to
> cater only to English speaking users, Ubuntu philosophy stating "that
> software tools should be available to people in their local language"
> other users should not be considered second class citizens (even if this
> bug is trivial).

Dude, that's like the most ungracious response to fixing a bug I think
I've ever read. Instead of taking offense that the bug was fixed for
some language other than yours, you need to recognize that the hardest
part - setting up an infrastructure for patching in wordlists to two
different dictionary formats - has been sorted out. The remaining work
is mere cut-and-paste to get it to additional dictionaries as desired.

If you don't know how to copy-and-paste and or debdiffs, and don't have
time to learn, criticising people for fixing bugs and pontificating
about Ubuntu philosophy to the rest of us is not the right approach.

> Talk is cheap and I don't have code to show so I shall remain silent now
> ;-)

Oops, you were too late!

Le dimanche 23 août 2009 à 03:16 +0000, Bryce Harrington a écrit :
[...] however since each language-specific dictionary is provided
> in a separate package, that'd be pretty hard.
>
And I guess it's even more difficult because some languages use hunspell by default. An extrawords package as a dependency to other dictionaries packages might have looked a nice solution, but this doesn't fix the other problems you wrote about (non-latin, non-trademark).

Dude, that's like the most ungracious response to fixing a bug I think
> I've ever read. [...]
>
Wow, I'm sorry if I have hurt anyone's feeling here, that was certainly not intentional. Text messages (evermore in a foreign language for me) unfortunately don't always carry the full intent of what one's wanted to communicate. I guess I just felt a little bit bad about the "I only do english" short response and bug status reset (my opinion at the time was that someone else than you, even me with some reading, could have fixed other packages affected by this bug which some were still seeing with their respective locales). However, Bryce, be assured that I am very grateful for your hard work here and with Xorg!

Now back to more interesting stuff: I had a look at the patches and couldn't just copy and paste the logic into hunspell so I opened Bug #417657 - as initially recommended - for other languages affected by this bug.

Thanks and sorry for the noise.

Gabe Gorelick (gabegorelick) wrote :

Besides adding words to aspell, there is also the matter of adding these words to the gnome-dictionary packaged with Ubuntu (see bug #424405), which I believe uses a DICT server, and not aspell.

summary: - Spellcheck in Gaim, Evolution, gedit etc doesn't recognize "Ubuntu"
+ Spellcheck doesn't recognize "Ubuntu"
mrvertigo (antonio-vertigo) wrote :

bug still present in kubuntu 10.04 as of today's date for firefox and aspell firefox,kubuntu, and aspell are also marked as incorrect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.