[MASTER] ubufox cannot install Firefox plugins on Karmic

Bug #423438 reported by Ronnie on 2009-09-02
508
This bug affects 95 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Undecided
Unassigned
ubufox (Ubuntu)
High
Micah Gersten

Bug Description

PROBLEM:
apturl changed from python script to shell script
ubufox calls apturl as a python script

Binary package hint: apturl

I think apturl crashed when try to install missing plugins (Adobe Flash Player) in firefox

ProblemType: Crash
Architecture: amd64
Date: Wed Sep 2 23:54:28 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/apturl
InterpreterPath: /usr/bin/python2.6
Package: apturl-common 0.4.0ubuntu4
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apturl apt:flashplugin-installer?section=multiverse?section=universe
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
PythonArgs: ['/usr/bin/apturl', 'apt:flashplugin-installer?section=multiverse?section=universe']
SourcePackage: apturl
Title: apturl crashed with SyntaxError in unknown()
Traceback:
 File "/usr/bin/apturl", line 3
      if [ "$KDE_FULL_SESSION" = "true" ] && [ -x /usr/bin/apturl-kde ]; then
                               ^
  SyntaxError: invalid syntax
Uname: Linux 2.6.31-9-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ronnie (ronnie.vd.c) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Changed in apturl (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Ken Richards (kenrichards) wrote :

ALSO CRASHES IN I386

toobuntu (toobuntu) on 2009-09-05
Changed in apturl (Ubuntu):
status: New → Confirmed
Hellsgator (hellsgate) wrote :

same here. crash.

rowez (info-rowez) wrote :

also crashes in i386 karmic

Soren Hansen (soren) wrote :

I have no clue why it happens, but the problem is that something is calling on python to interpret /usr/bin/apturl, which is a shell script..

Soren Hansen (soren) wrote :

It seems to be the AptInstaller class in the ubufox package that unconditionally calls python. Since apturl isn't a python program (anymore?), this should probably change.

Simon Charette (charettes) wrote :

Same crash when attempting to install adobe flash from firefox.

Micah Gersten (micahg) wrote :

There is enough information for a developer to start work on this now. Apparently apturl changed from a python script to a shell script and ubufox should be updated to call it properly. Please report any other issues you may find. Thanks!

Changed in ubufox (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Micah Gersten (micahg) on 2009-09-07
description: updated
Micah Gersten (micahg) on 2009-09-07
Changed in ubufox (Ubuntu):
assignee: nobody → Alexander Sack (asac)
Celtiore (infos-celtiore) wrote :

i have try to install adobe flash plugin with firefox, and apturl crash .....

xlin (xlin) wrote :

same circumstance - happened when trying to install adobe flash player

Same thing -- tried installing adobe flash player.

blakamin (blakamin) wrote :

same

Harald Sitter (apachelogger) wrote :

Closing apturl task since this needs to be fixed in ubufox.

Changed in apturl (Ubuntu):
assignee: Harald Sitter (apachelogger) → nobody
status: Confirmed → Invalid

Just in case it matters:

My crash happened while attempting to install java6-plugin

AaronSharpe (ubuntu-a-sharpe) wrote :

Crashed for me while trying to install the java iced tea firefox plugin thing.

Dave Morley (davmor2) wrote :

Crashed trying to install swfdec.

This is on iso dated 20090914.2

Micah Gersten (micahg) on 2009-09-15
summary: - apturl crashed with SyntaxError in unknown()
+ [MASTER] ubufox cannot install Firefox plugins on Karmic
Micah Gersten (micahg) on 2009-09-15
Changed in ubufox (Ubuntu):
assignee: Alexander Sack (asac) → Micah Gersten (micahg)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.8~b1-0ubuntu1

---------------
ubufox (0.8~b1-0ubuntu1) karmic; urgency=low

  New upstream release 0.8b1 fixes:
  * fix: LP: #365965 - installing firefox pulls in ubufox and all gnome depends
    through apturl; we add alternative Depends on apturl-kde to make ubufox kde
    friendlier
    - update debian/control
  * fix LP: #423438 - ubufox can't use apturl on karmic; honour shebang by
    calling command directly rather than the python interpreter. Thx to Micah
    Gersten who provided the upstream fix.
    - update content/pluginInstallerService.js
  * fix LP: #403581 - restart required notification and button not shown
    in ffox 3.5; support multiple versions of in updateRestart.js; we use runtime
    application info from extIApplication.version
    - update content/updateRestart.js
  * fix LP: #411222 - restart required notification should be shown with
    less delay; checking for restart notification every 5 seconds (was 10 before) now
    - update content/updateRestart.js
  * fix LP: #429937 - plugin alternative wizard not available if there is no
    plugin content detected; don't disable "Manage Content Addons" initially;
    the dialog even makes sense if there is plugin content used atm.
    - update content/ubuntuAltpluginsOverlay.xul
  * fix LP: #399229 - update ubufox strings from 9.04 to 9.10 in various places
    + update releasenotes url in locale/*/ubufox.properties
    + update HOMEPAGE_ONLINE in startpage.html
    + update plugin finder service database url in ubufox-pfs.js
    + update gethelp and translate urls in overlay.js
    + update execute command to use firefox rather than firefox-3.0 in overlay.js
    + include karmic sources in plugin db creation
      - add pfs/db/sources.list.9.10
  * support firefox 3.6 and 3.7 restart required feature and set maxVersion
    to 3.7.*
    - update content/updateRestart.js
    - update install.rdf

 -- Alexander Sack <email address hidden> Tue, 15 Sep 2009 12:18:32 +0200

Changed in ubufox (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers