Ubuntu

aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Reported by Vladimir Scherbaev on 2011-01-25
This bug affects 269 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
aptdaemon (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: aptdaemon

Description: Ubuntu natty (development branch)
Release: 11.04
aptdaemon:
  Установлен: 0.40+bzr541-0ubuntu1
  Кандидат: 0.40+bzr541-0ubuntu1
  Таблица версий:
 *** 0.40+bzr541-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.40+bzr541-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Tue Jan 25 18:54:04 2011
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with UnicodeDecodeError in _set_status_details(): 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
UserGroups:

Related branches

Vladimir Scherbaev (zemik) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
Changed in aptdaemon (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr582-0ubuntu1

---------------
aptdaemon (0.41+bzr582-0ubuntu1) natty; urgency=low

  [ Sebastian Heinlein ]
  * New upstream version:
    - Strictly use the specified D-Bus types in signal and return values
      allowing to write non-Python bindings
    - New GTK3 client widgets (thanks to Martin Pitt)
    - Greatly enhanced test suite by moving to unittest2, allowing to perform
      package operations in a chroot and running tests on a local session
      dbus: "dbus-launch unit2 discover"
    - Improved error reporting
    - Improved open progress (Thanks to Michael Vogt)
    - Run lintian as the user who initiated the transaction
    - Several bug fixes (fixes LP: #707490, LP: #712838)

  * debian/control:
    - Add python-aptdaemon.gtkwidgets and python-aptdaemon.gtk3widgets
      instead of a shared python-aptdaemon-gtk to follow the package
      naming of the Python policy. Python-aptdaemon-gtk is kept as
      a transitional dummy package
    - Add a new aptdaemon-data package which provides common files
      (e.g. icons) for the client modules
    - aptdaemon recommends lintian to test local packages before
      installing
    - Add build dependencies on python-apt, python-gobject, python-defer,
      python-software-properties, python-dbus, python-debian,
      python-mock, dbus-x11 and python-unittest2 to run unittests at build
      time
    - Add missing dependency on python-dbus and python-debian to
      python-aptdaemon
    - Add a new package python-aptdaemon.test package which provides
      the infrastructure to write unittests for aptdaemon clients
    - Raise Python minimum version to 2.6

  * debian/patches:
    - Remove 09_fix_index_race_659438 - merged upstream
    - Remove 00upstream_gtk3_fixes - merged upstream
    - Remove 05_sources_list_password - merged upstream
    - Add disable_config_parser_test.patch: The test fails on the build
      system. Needs some more investigation. So temporarily disabled.

  * debian/rules:
    - Run the test suite at package build time by overriding dh_auto_test

  * debian/python-aptdaemon.test.(install|examples):
    - Ship the aptdaemon.test module, the silly packages repo, the dpkg
      wrapper and the fake PolicyKit daemon

  * debian/python-aptdaemon.gtk(3)widgets.(install|example):
    - Ship the corresponding Python module and example client

  * debian/aptdaemon-data.install:
    - Ship the icons

  [ Michael Vogt ]
  * debian/control:
    - add missing Replaces
 -- Michael Vogt <email address hidden> Wed, 09 Feb 2011 10:33:15 +0100

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Robert Roth (evfool) on 2011-03-18
visibility: private → public
Robert Roth (evfool) wrote :

This might not be fixed, as there are some bugs coming in recently with the same message, see bug #737742 (reported against aptd 0.41+bzr597-0ubuntu1) and bug #724735 and its latest duplicates, which have been reported after the fix for this one.

Changed in aptdaemon (Ubuntu):
status: Fix Released → Confirmed
phobos (b3phobos) wrote :

Hi.
phobos@natty:~$ dpkg -l |grep aptdaemon
ii aptdaemon 0.41+bzr604-0ubuntu1
Upgrade just this morning, resboot and see this bug.

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Vladimir Scherbaev (zemik) wrote :

What release fix it?

dORSY (dorsyka) wrote :

Version: 0.41+bzr604-0ubuntu1
I am still affected.

macru (zengyun000) wrote :

I guess this problem was caused by the l10n work.
I added 'text=text.strip()' before 'self._status_details = dbus.String(text) ' in File "/usr/lib/python2.7/dist-packages/aptdaemon/core.py", line 537.
And fixed the problem on my own computer. I hope this can be useful.

zerocoolre (zerocoolre) on 2011-03-29
security vulnerability: no → yes
security vulnerability: yes → no
MAKAPOH (makapoh) wrote :

0.41+bzr604-0ubuntu1 same problem

Changed in aptdaemon (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → Medium
Андрей (pante59) on 2011-03-31
description: updated
Changed in aptdaemon (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Alukard1986 (alukard1986) wrote :

и чё делать то?

Обновляться регулярно. Единственный выход.

On Mon, Apr 4, 2011 at 2:21 AM, Alukard1986 <email address hidden> wrote:
> и чё делать то?
>
> --

Changed in aptdaemon:
status: New → Confirmed
Michael Vogt (mvo) wrote :

This should be fixed with the following upload:

aptdaemon (0.41+bzr614-0ubuntu1) natty; urgency=low

  * New bzr bugfix snapshot:
    - fix i18n crash (LP: #724735)
    - Allow to specify package names with an architecture
      (for multiarch)
    - Client: Exit the transaction processing if there has been an
      error
    - Make the run method of the GTK2 progress dialog deferable
      (LP: #626798)
  * debian/patches/01_relax_lintian_checks.patch:
    - add lp:~mvo/aptdaemon/relax-lintian-checks as distro patch
      until upstream (LP: #712377)
 -- Michael Vogt <email address hidden> Tue, 05 Apr 2011 16:31:37 +0200

Changed in aptdaemon (Ubuntu Natty):
status: Triaged → Fix Released
Michael Vogt (mvo) wrote :

This bug is a dupe of #724735 I guess the different line numbers in different releases made the duplicates-finder not mark it as such.

Konstantin (dr.dtyger) wrote :

It seems, that latest update on 07-Apr-2011 solved the problem.
Ubuntu 11.04

psbh (psbh-imap) wrote :

Well, as of today, 7-Apr-2011 - CET 18:13; no it didn't. Bug remains.

psbh (psbh-imap) wrote :

I'm still having the bug in position 1 in "can't decode byte 0xd0 in position 1: ordinal not in range(128)". But you guys say it's a duplicate to position 1, hence no reported bug-data left to refer to.

psbh (psbh-imap) wrote :

correction "duplicate to position 0..."

stoja (stojabreak) wrote :

I get the same error :(

I got this problem with Vietnamese language.

Sebastian Heinlein (glatzor) wrote :

Fixed in 0.43

Changed in aptdaemon:
status: Confirmed → Triaged
status: Triaged → Fix Released
tags: removed: bugpattern-needed
tags: added: bugpattern-written
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers