Use named arguments for translatable plural strings

Bug #630962 reported by David Planella on 2010-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Aptdaemon
Medium
Sebastian Heinlein
Ubuntu Translations
Medium
Unassigned
aptdaemon (Ubuntu)
Medium
Unassigned

Bug Description

Двоичной намек пакет: aptdaemon

Следующие переводимые строки в коде правильно отмечен для множественного перевода:

В следующем НОВЫЙ пакет будет установлен (% ы):
В следующем пакет будет повышен (% ы):
В следующем пакета будут удалены (% ы):
Следующий пакет будет понижен (% ы):
В следующем пакет будет переустановил (% ы):
В следующем пакет был утаил (% ы):

Тем не менее, они используют на неназванные аргументы (% S), которые не позволяют в некоторых языках, таких как арабский и иврит, чтобы правильно переводить строки. Именованные аргументы следует использовать вместо (например% (пакет) с).

Использование неназванных аргументов в питона множественного числа строк также является потенциальным грохот, так Gettext-и расширением Launchpad-браузер не поддерживает проверку ошибок из тех.

David Planella (dpm) on 2010-09-05
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Sebastian Heinlein (glatzor) wrote :

I would like to replace the % operation with python new str.format(). How familiar are transalators with the syntax?

http://docs.python.org/library/string.html#formatstrings

El dg 05 de 09 de 2010 a les 21:33 +0000, en/na Sebastian Heinlein va
escriure:
> I would like to replace the % operation with python new str.format().
> How familiar are transalators with the syntax?
>
> http://docs.python.org/library/string.html#formatstrings
>

I think translators would adapt fine to the new format. However, a big
blocker is that gettext does not support it yet.

Computer-janitor started using the new format, but in the end strings
were reverted to the old due to that reason.

See bug 622720 for further reference. This has been reported at gettext
upstream as well, but there has been no response yet (see the gettext
task on that bug).

Sebastian Heinlein (glatzor) wrote :

I will convert the strings in the trunk branch. So they will land in natty

Changed in aptdaemon (Ubuntu):
status: New → In Progress
Changed in aptdaemon:
status: New → In Progress
assignee: nobody → Sebastian Heinlein (glatzor)
Changed in aptdaemon:
importance: Undecided → Medium
Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
Changed in aptdaemon:
status: In Progress → Fix Committed
Gabor Kelemen (kelemeng) on 2011-05-18
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in aptdaemon:
status: Fix Committed → Confirmed
Changed in aptdaemon (Ubuntu):
status: In Progress → Confirmed
Changed in software-center-aptdaemon-plugins (Ubuntu):
status: New → Incomplete
no longer affects: software-center-aptdaemon-plugins (Ubuntu)
Naylo (naylo1) on 2013-12-21
description: updated
Changed in aptdaemon (Ubuntu):
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers