Hangs when "preconfiguring packages" at the installation of a language

Bug #1163142 reported by Herbert Post on 2013-04-02
78
This bug affects 19 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Colin Watson

Bug Description

While running gnome-language-selector the process hangs while
applying changes during "preconfiguring packages"
No matter how long this process runs it never finishes.

These processes are running
posth 11234 1 21 09:08 ? 00:00:03 /usr/bin/python3.3 /usr/bin/gnome-language-selector
root 11611 10372 0 09:08 pts/2 00:00:00 /usr/bin/python3.3 /usr/sbin/aptd
root 11612 11611 0 09:08 pts/2 00:00:00 [dpkg] <defunct>
root 11613 11611 0 09:08 pts/2 00:00:00 /bin/sh -c /usr/sbin/dpkg-preconfigure --apt || true
root 11614 11613 0 09:08 pts/2 00:00:00 /usr/bin/perl -w /usr/sbin/dpkg-preconfigure --apt
posth 11616 11253 0 09:08 pts/0 00:00:00 ps -ef

Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

language-selector-gnome:
  Installed: 0.108
  Candidate: 0.108
  Version table:
 *** 0.108 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

The program should allow me to install an extra language (dutch for me).
But the problems arise at startup of the program or after I stop the process and manually try to install the dutch language.

The process halts during "preconfiguring packages"

summary: - language support does not finish
+ Hangs when "preconfiguring packages" at the installation of a language
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Herbert,

Thanks for your help to improve Ubuntu by reporting this important bug! It's easily reproducible, and one of our most experienced developers is already working on it.

Hi Gunnar,

Thanks for the quick update.
I had forgotten to mention that I could reproduce it
myself on multiple systems :-(

Herbert

On 02-04-13 13:36, Gunnar Hjalmarsson wrote:
> Hi Herbert,
>
> Thanks for your help to improve Ubuntu by reporting this important bug!
> It's easily reproducible, and one of our most experienced developers is
> already working on it.
>

Colin Watson (cjwatson) on 2013-04-02
affects: language-selector (Ubuntu) → aptdaemon (Ubuntu)
Changed in aptdaemon (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.0-0ubuntu9

---------------
aptdaemon (1.0-0ubuntu9) raring; urgency=low

  * Flush debconf-communicate stdin after writing to it
    (LP: #1163142, #1163163).
 -- Colin Watson <email address hidden> Tue, 02 Apr 2013 14:07:01 +0100

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Herbert Post (roberine) wrote :

Checked on both my systems and they both allow me now to install the Dutch language.

Gunnar Hjalmarsson (gunnarhj) wrote :

Great Herbert, thanks for confirming.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers