Comment 11 for bug 940825

Julian Andres Klode (juliank) wrote :

It should try the Packages.gz and Packages.bz2 files first, and those should succeed. Somehow they don't seem to work or APT is configured to ignore them. APT then asks for the uncompressed file, which the server does not have. The server then wants to be clever and offer you Packages.bz2 instead, but APT told it that it wants an uncompressed file at that point, so the server answers "I cannot send this file to you uncompressed".