Ubuntu

Intrepid: Netboot locks up at 2% installing the selected edubuntu desktop

Reported by Dave Morley on 2008-10-28
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Colin Watson
apt (Ubuntu)
High
Colin Watson
Jaunty
High
Colin Watson
pkgsel (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned

Bug Description

RELEASE: Intrepid
CD/DVD VARIANT: netboot mini.iso 64/32 bit
ISO BUILD: 20081026

SYMPTOMS: Selecting edubuntu on a netboot mini.iso install freezes at 2% of the install.

CAUSE: Unknown

STEPS TO REPRODUCE:
1/ Install from mini.iso
2/ After the base install select edubuntu from the list of desktops
3/ Watch the install lock up at 2%

Henrik Nilsen Omma (henrik) wrote :

Confirmed.

Colin Watson (cjwatson) wrote :

I can see from the log on Alt-F4 that it is actually working - it just doesn't seem to be updating the progress bar for some unknown reason.

Colin Watson (cjwatson) wrote :

It appears that apt doesn't write dlstatus messages to Status-Fd if given the -q option. I'm not sure whether we should have pkgsel stop passing -q, or fix this; however it does seem a little odd for -q to control non-user-visible messages as well as general wittering on stderr.

Changed in pkgsel:
importance: Undecided → High
status: New → Triaged
Colin Watson (cjwatson) wrote :

Release notes text added:

== Slow start to "Select and install software" step in text-mode installer ==

The "Select and install software" step in the text-mode install CD may appear to hang at a low single-digit percentage. This is particularly the case for netboot installations, where there will be no progress b
ar updates at all while downloading packages. This is due to a fault in the interaction between the installer and `apt-get`, which was diagnosed too late to fix for Ubuntu 8.10: [[https://launchpad.net/bugs/290234|bug 290234]].

You can find out whether the installer is making progress by pressing Alt-F4 to switch to the logging console; Alt-F1 switches back to the main installer. (If you are installing in QEMU or KVM, be careful to press Ctrl+Alt or click in the window to have the emulator grab focus before pressing Alt-F4, as otherwise this will close the emulator!)

Changed in ubuntu-release-notes:
assignee: nobody → kamion
status: New → Fix Released
Igor Nikolic (i-nikolic) wrote :

Hello, just attempted to neetboot a Samsung NC10 off a ubuntu 8.04 AMD64, with a i386 net image.

it hangs, and I cant access anything.

Any suggestions on how to provide you with some error logs ?

Twig (pfirth) wrote :

This is also affecting Jaunty alpha 6 although it is locking up at 6%. If I switch to another console, I can see the progress of the installation.

Colin Watson (cjwatson) wrote :

Having looked into the necessary change in apt, it's quite trivial, so I don't think it's necessary to change pkgsel. I've put up an apt branch for review.

Changed in pkgsel (Ubuntu):
status: Triaged → Won't Fix
Changed in apt (Ubuntu):
assignee: nobody → cjwatson
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.20.2ubuntu5

---------------
apt (0.7.20.2ubuntu5) jaunty; urgency=low

  [ Colin Watson ]
  * cmdline/acqprogress.cc:
    - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
      dlstatus messages on the status-fd (LP: #290234).

  [ Michael Vogt ]
  * debian/apt.cron.daily:
    - do not clutter cron mail with bogus gconftool messages
      (LP: #223502)
    - merge fix for cache locking from debian (closes: #459344)
    - run update-apt-xapian-index (with ionice) to ensure that
      the index is up-to-date when synaptic is run (LP: #288797)

 -- Michael Vogt <email address hidden> Mon, 30 Mar 2009 13:22:28 +0200

Changed in apt:
status: In Progress → Fix Released
justin (justin-saeren) on 2009-11-02
Changed in apt (Ubuntu):
status: Fix Released → Incomplete
Steve Langasek (vorlon) on 2009-11-02
Changed in apt (Ubuntu):
status: Incomplete → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers