Spurious "W: You may want to run apt-get update to correct these problems" when "Duplicate sources.list entry" is only warning

Bug #1012398 reported by Scott Ritchie on 2012-06-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Low
Unassigned

Bug Description

If you create duplicate lines in sources.list, and then run apt-get update, you receive something like this:

W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ precise-security/multiverse amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_multiverse_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ precise-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_multiverse_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

The final warning is not helpful.

Changed in apt (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Vlad Orlov (monsta) wrote :

Yes, this warning is totally useless because apt-get update won't magically remove the duplicates.

Actually, apt is full of strange messages that are completely unclear to the users (like "you have held broken packages" when nothing is actually being held). This is just one of them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers