"The AppStream system cache was updated, but some components were ignored. Refer to the verbose log for more information."

Bug #1861631 reported by Jonathan Kamens on 2020-02-02
162
This bug affects 33 people
Affects Status Importance Assigned to Milestone
appstream (Ubuntu)
Undecided
Unassigned
gnome-software (Ubuntu)
Undecided
Unassigned

Bug Description

`apt-get update` and the nightly `apticron --cron` job are reporting:

"The AppStream system cache was updated, but some components were ignored. Refer to the verbose log for more information."

This is pretty much meaningless to most people who have no idea what AppStream is and what "verbose log" is being referred to. I dug around and managed to discover `appstreamcli refresh-cache --force --verbose`, whose output is attached.

I don't know what the "bad" output is or how to fix it. All I know is that I hope Focal isn't going to be generating this message when it ships, because it isn't going to make sense to most people and most people won't know how to fix it and it causes annoying emails from apticron every night.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: appstream 0.12.10-1
ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
Uname: Linux 5.4.0-12-generic x86_64
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Feb 2 16:01:24 2020
InstallationDate: Installed on 2019-08-16 (170 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
SourcePackage: appstream
UpgradeStatus: Upgraded to focal on 2020-01-31 (2 days ago)

Jonathan Kamens (jik) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appstream (Ubuntu):
status: New → Confirmed
Matthias Klumpp (ximion) wrote :

This error message is shown not to alert users, but rather make users report these issues to the distributor, as this particular issue means the distributor has a mistake in their metadata somewhere.
In this case it's not Ubuntu's fault directly, but rather GNOME Software injecting invalid metadata.
This is fixed upstream with commit https://gitlab.gnome.org/GNOME/gnome-software/commit/7c1620990b6361fac370b76c9828f8f77ff77a72 which should land in the next Ubuntu release naturally (but may be cherry-picked to make this issue go away even sooner).

Changed in appstream (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-software (Ubuntu):
status: New → Triaged
Julian Andres Klode (juliank) wrote :

I believe this error message needs rework, people have no idea what AppStream is or where they can find the verbose log or why they even see that.

Changed in appstream (Ubuntu):
status: Invalid → Triaged
Dan Watkins (daniel-thewatkins) wrote :

Agreed, if the intent is for people to file bugs then it should be clearer.

(Alternatively, might there be a better way for us to report this on Ubuntu as a "crash", if users truly can't do anything about it?)

Matthias Klumpp (ximion) wrote :

Technically, PPAs with AppStream data or other repositories with broken data can trigger this as well.
AppStream could make a guess who is to blame for the breakage and give a more specific error, but that will require some more extensive code changes.

Mustapha Hadid (mhadidg) on 2020-03-18
Changed in gnome-software (Ubuntu):
status: Triaged → Confirmed
Naël (nathanael-naeri) wrote :

This bug is still present because the change that Matthias did was unintentionally undone the following week. So it was not shipped as it should have been, as part of gnome-software 3.35.91, which is the current version in Ubuntu. I have signaled this issue upstream.

Russ Burghorn (alienwar) wrote :

Is there a fix yet, I too have this error.

Naël (nathanael-naeri) wrote :

The fix was made upstream on Mar 24 [1], released as part of gnome-software 3.36 on Apr 3 [2], which was packaged for Ubuntu today Apr 6 [3]. I'd say it's just a matter of hours before it's available in the repository :)

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/commit/bb7f58f5f88381857cd9b5dbe608e75d459873f1
[2] https://gitlab.gnome.org/GNOME/gnome-software/-/commits/gnome-3-36
[3] https://launchpadlibrarian.net/473131226/gnome-software_3.36.0-0ubuntu1_source.changes

Changed in appstream (Ubuntu):
status: Triaged → Invalid
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
Naël (nathanael-naeri) wrote :

Please disregard my previous comment. Looking at the code, I realize that the maintainer packaged the upstream gnome-software "3.36.0" tag, not the "gnome-3-36" branch, which makes a lot more sense indeed.

So even though the fix is made upstream, it is NOT YET released, and therefore not packaged for Ubuntu. I think this bug is stuck until upstream releases 3.36.1.

Changed in gnome-software (Ubuntu):
status: Fix Committed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers