Comment 12 for bug 1467588

Ubfan (ubfan1) wrote :

This warning started showing up in 2013 when the gtk devs decided to push
for the standard usage of requiring a parent -- maybe they have future
modifications in mind which require this. Anyway, the march goes: "discouraged",
"deprecated", and finally "removed", so this warning shouldn't be ignored.
Any number of packages may be affected beyond the two indicated in this bug.
Hopefully, zenity is an intermediate to the underlying gtk so fixing zenity
may fix the warning in many packages. Any feedback to the gtk developers on
the number of adversely affected packages might be useful -- they may decide
to allow some environment variable to continue to allow this.