apport reports suspend/resume failure twice on boot (apportcheckresume)

Bug #1372665 reported by Steve Langasek on 2014-09-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt
Trusty
High
Brian Murray

Bug Description

Test Case
---------
1) sudo touch /var/lib/pm-utils/status
2) reboot
3) observe two susres named crash reports in /var/crash/

With the version of apport from trusty-proposed you will only have one crash report in /var/crash.

Something has regressed to cause my laptop to not resume from suspend. But in addition, this has exposed a bug in apportcheckresume, which is reporting the resume failure twice in a row.

$ ls -l /var/crash/susres.2014-09-22_15\:00\:53.7*.crash
-rw-r----- 1 root whoopsie 1314658 Sep 22 15:02 /var/crash/susres.2014-09-22_15:00:53.767701.crash
-rw-r----- 1 root whoopsie 1314630 Sep 22 15:01 /var/crash/susres.2014-09-22_15:00:53.780433.crash
$

As I certainly did not have two resume failures within a second of one another, I think this is an apportcheckresume bug.

ProblemType: BugDistroRelease: Ubuntu 14.10
Package: apport 2.14.7-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic x86_64
ApportLog:

ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Sep 22 15:15:14 2014
InstallationDate: Installed on 2010-09-24 (1459 days ago)InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: allSourcePackage: apport
UpgradeStatus: Upgraded to utopic on 2014-05-23 (122 days ago)

Steve Langasek (vorlon) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

bdmurray@blacklightning:~$ ls -lh /var/crash/
total 2.3M
-rw-r----- 1 root whoopsie 1.2M Oct 13 12:50 susres.2014-10-13_12:48:47.090538.crash
-rw-r----- 1 root whoopsie 1.2M Oct 13 12:50 susres.2014-10-13_12:48:47.119012.crash

I've recreated this more than one time by draining the battery completely.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → Triaged
importance: Undecided → High
Martin Pitt (pitti) wrote :

Theory: Both the upstart job and the init.d script run on boot.

Martin Pitt (pitti) wrote :

The problem is that /etc/init.d/apport sets "PATH=/bin" which breaks /lib/lsb/init-functions.d/01-upstart-lsb: It cannot find initctl in /bin, so it actually does run the init.d file. Hence both that and the upstart job call apportcheckresume in parallel.

Martin Pitt (pitti) wrote :

Fixed in trunk r2869.

Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Brian Murray (brian-murray) wrote :

This would also cause "/usr/share/apport/kernel_crashdump" to run multiple times and create multiple .crash files.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.7-0ubuntu8

---------------
apport (2.14.7-0ubuntu8) utopic; urgency=medium

  * etc/init.d/apport: Stop setting $PATH in the init.d script. It breaks
    assumptions from /lib/lsb/init-functions.d/ which might call other tools
    which are not in /bin; also, we generally shouldn't meddle with $PATH in
    individual scripts. (LP: #1372665)
 -- Martin Pitt <email address hidden> Mon, 20 Oct 2014 14:51:41 -0400

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Changed in apport (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

I've uploaded an SRU for this to the trusty queue.

description: updated
Changed in apport (Ubuntu Trusty):
status: Triaged → In Progress

Hello Steve, or anyone else affected,

Accepted apport into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apport/2.14.1-0ubuntu3.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I'm unable to recreate the original bug report in Trusty. There is only one crash file after proceed with the test case.

Mathew Hodson (mathew-hodson) wrote :

With apport 2.14.1-0ubuntu3.5, I get two error dialogues on boot but one crash file in /var/crash/.

With 2.14.1-0ubuntu3.6 in trusty-proposed, I get one dialogue and one crash file. I think this is the same problem as in this bug, and the proposed package fixes it for me.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.1-0ubuntu3.6

---------------
apport (2.14.1-0ubuntu3.6) trusty-proposed; urgency=medium

  * Stop setting $PATH in the init.d script. It breaks assumptions from
    /lib/lsb/init-functions.d/ which might call other tools which are not in
    /bin; also, we generally shouldn't meddle with $PATH in individual scripts.
    (LP: #1372665)
 -- Brian Murray <email address hidden> Tue, 28 Oct 2014 14:05:01 -0700

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers