Ubuntu

UIFE: Icons for error alerts are hokey

Reported by Matthew Paul Thomas on 2012-11-16
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Apport
Low
Unassigned
apport (Ubuntu)
Low
Martin Pitt
humanity-icon-theme (Ubuntu)
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

UIFE: Apparently there are some problems with the autolanding machinery for ubuntu-themes, and we were asked to not manually upload this package. We need to drop the apport icons from ubuntu-themes so that the ones from apport actually appear.

Original bug:
--------------
1. Trigger an internal error in Ubuntu.

What happens:
* A chunky red starburst icon appears in the Launcher.
    <https://twitter.com/snwh/status/269229050034274306/photo/1>
* The error alert prominently features the Ubuntu logo.
    <http://uxmag.com/articles/your-logo-is-making-me-sick>

What should happen:
* A professional-looking icon appears in the Launcher.
* A reassuring icon (maybe the same icon, maybe not) appears in the error alert.

[Originally reported by Sam Hewitt. <https://twitter.com/snwh/status/269229050034274306>]

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Changed in apport (Ubuntu):
assignee: nobody → Nick Tait (jnick-tait)
Evan Dandrea (ev) on 2012-11-30
Changed in apport:
assignee: nobody → Nick Tait (jnick-tait)
importance: Undecided → Low
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :
Changed in apport:
assignee: Nick Tait (jnick-tait) → nobody
Changed in apport (Ubuntu):
assignee: Nick Tait (jnick-tait) → nobody
Vish (vish) wrote :

I liked Sam's idea of a paper plane crashing. But rather wanted to focus on the reason the window is being displayed to the user - 'to send information'.
So I used the paper plane as a metaphor to information being sent and used the blue color that we use for panel notifications - as in 'a notification about information ready to be sent'.

I recall that we needed a new icon for software updater too, so we can just use the similar paper plane metaphor for updates arriving (not sure if we are still looking for a new updater icon) - as 'in new updates arriving'.. ;-) Right now, the shopping bag is the same color as the software center, but if necessary, we could change it to either green or blue(wouldnt blue be close to Windows?).

Matthew Paul Thomas (mpt) wrote :

Vish, thank you, those icons are your usual exemplary standard. :-) However, the main purpose of the error alert is to explain to you what just went wrong. Sending an error report is a secondary issue, and sometimes it's not even possible at all. An administrator may block all users from sending error reports, but the error alerts will still appear. So it would be incongruous for the alert to have an icon based on the idea of sending information.

So the idea of the crashed paper plane is to represent something going wrong, calmly but not frivolously. Similar ideas include a banana peel, a splat, and a broken window.

Vish (vish) wrote :

mpt: I like the idea of a splat, so played around a bit with that idea and tried 3 variants...

Matthew Paul Thomas (mpt) wrote :

Ooh, lovely. Let's use #3, the one without anything in it. Could you polish that one up and provide the necessary sizes for the launcher etc? Thanks!

Vish (vish) wrote :

Sure, will do!
AFAIK, the launcher only needs a 48px(default), 64px and 32px icon.. Will work on those sizes and upload asap...

Vish (vish) wrote :

Attached are the 3 sizes required for the launcher.
The icons are just named "apport",(I was not sure of the icon name used).. might need to rename the icons when we add them the package.

Vish (vish) wrote :
Changed in apport (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Vish (vish) wrote :
Martin Pitt (pitti) wrote :

Thanks a lot Vish! I'm happy to update them upstream, but note that the red one actually comes from ubuntu-mono, so it needs to be dropped there (or your icon should go there). Do you have any preference?

Vish (vish) wrote :

you're welcome, pitti!
Adding the icon to upstream and dropping the one in ubuntu-mono & Humanity package would be the right way to do it.
 - We are updating the apport branding.
 - This is a bit more work, but better in the long run. If we move to a different default theme at some point we would not have to revisit this issue.
 - When we did the ubuntu-mono/humanity red one it was just meant for the top panel. But we ended up dropping the apport icon from showing up in the top panel. So removing the icons from both ubuntu-mono and Humanity would be the best way to do it. Otherwise the humanity icon would be used even if ubuntu-mono icon is removed.
 - Even if users change themes this new icon would be used, otherwise the red one would keep being used for themes falling back to Humanity. Of course, icon themes can have their own replacement.

Vish (vish) wrote :
Martin Pitt (pitti) wrote :

Whoops, this slipped under the radar. 3 hours until UIF, doing that now.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Applied upstream in r2708.

Changed in apport:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Martin Pitt (pitti) wrote :

Committed to ubuntu-themes, but as it's part of the PS autorelease I won't upload it manually.

affects: ubuntu-mono (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
status: New → Fix Committed
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2013-09-19
Changed in humanity-icon-theme (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.4

---------------
humanity-icon-theme (0.6.4) saucy; urgency=low

  * Drop apport icons, we want to use the ones shipped by apport itself.
    (LP: #1079639)
 -- Martin Pitt <email address hidden> Thu, 19 Sep 2013 12:57:15 -0500

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.12.4-0ubuntu1

---------------
apport (2.12.4-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Update icons to new design from Vishnoo Charan Reddy, many thanks!
      (LP: #1079639)
 -- Martin Pitt <email address hidden> Thu, 19 Sep 2013 13:27:03 -0500

Changed in apport (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

UIFE request: Apparently there are some problems with the autolanding machinery for ubuntu-themes, and we were asked to not manually upload this package. We need to drop the apport icons from ubuntu-themes so that the ones from apport actually appear.

summary: - Icons for error alerts are hokey
+ UIFE: Icons for error alerts are hokey
description: updated
Martin Pitt (pitti) wrote :
Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers