apport-gtk assert failure: python: ../../src/xcb_io.c:273: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Bug #1024202 reported by Razor_alpha on 2012-07-13
This bug affects 184 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Unassigned

Bug Description

I was reporting other bugs while apport crashed after "Report an error" crashed several times.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: apport-gtk 2.3-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Fri Jul 13 06:48:21 2012
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
 TERM=unknown
Signal: 6
SourcePackage: apport
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
Title: apport-gtk crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to quantal on 2012-07-13 (0 days ago)
UserGroups:

Razor_alpha (razoralpha) wrote :

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=0x7fb6f29849d8 "!xcb_xlib_threads_sequence_lost", file=0x7fb6f2984c92 "../../src/xcb_io.c", line=<optimized out>, function=<optimized out>) at assert.c:94
 __GI___assert_fail (assertion=assertion@entry=0x7fb6f29849d8 "!xcb_xlib_threads_sequence_lost", file=file@entry=0x7fb6f2984c92 "../../src/xcb_io.c", line=line@entry=273, function=function@entry=0x7fb6f2984db8 "poll_for_event") at assert.c:103
 poll_for_event (dpy=dpy@entry=0x220a800) at ../../src/xcb_io.c:270
 poll_for_response (dpy=dpy@entry=0x220a800) at ../../src/xcb_io.c:288
 _XEventsQueued (dpy=dpy@entry=0x220a800, mode=mode@entry=2) at ../../src/xcb_io.c:362

Changed in apport (Ubuntu):
importance: Undecided → Medium
summary: - apport-gtk crashed with SIGABRT in raise()
+ apport-gtk crashed with SIGABRT in __assert_fail_base()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
tags: added: running-unity
tags: added: bugpattern-needed
C de-Avillez (hggdh2) on 2012-09-03
visibility: private → public

happens on login for me

Ursula Junque (ursinha) on 2012-10-02
tags: added: rls-q-incoming
Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Medium → High
tags: removed: rls-q-incoming
Bruce Pieterse (octoquad) wrote :

Same as William, crashed when logging in.

Martin Pitt (pitti) wrote :

Similar to bug 419501, bug 901675, or bug 934001. This looks like a crash in libxcb when using multiple threads, but apport has stopped using multiple GUI threads long ago. So I have no clue how to reproduce this, and any hint or recipe is greatly appreciated.

summary: - apport-gtk crashed with SIGABRT in __assert_fail_base()
+ apport-gtk assert failure: python: ../../src/xcb_io.c:273:
+ poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Martin Pitt (pitti) on 2012-12-18
Changed in apport (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
tags: added: raring
martin suc (martin-suc) wrote :

same problem in raring 13.04 development branch

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in apport (Ubuntu):
status: Confirmed → Triaged
RC Lages (rclages) wrote :

This error happens whenever the Ubuntu 13:10 is started after boot.

Edoardo (edoardo-zerbo) wrote :

Happens on Every Boot in ubuntu 14.04 development branch.
Next boot i will put the report of the error.

Susan Cragin (susancragin) wrote :

Mine happens when I run bleachbit. I filed one of the duplicate bugs but would like to add the following:

[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.

starkus (starkus) wrote :

appeared after successful upgrade after update-manager crashed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers