Ubuntu

F10 key opens submenus from local menu bar (in a horrible, broken way)

Reported by Dylan McCall on 2010-12-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Undecided
Unassigned
appmenu-gtk (Ubuntu)
High
Unassigned
Natty
High
Unassigned
gtk+2.0 (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: appmenu-gtk

Pressing F10 to open a local menu opens a submenu from the local menu bar, as with the Alt-key shortcuts in bug #611636. This is thoroughly broken behaviour, as the submenus have no context to describe what they are attached to.

Instead, the client application should catch menu activate signals and pass those along to indicator-application.

Omer Akram (om26er) on 2010-12-12
Changed in appmenu-gtk (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in appmenu-gtk:
status: New → Confirmed
Omer Akram (om26er) wrote :

this needs to be fixed for Natty since we are using global menus in desktop edition too.

Changed in appmenu-gtk (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Michael Terry (mterry) on 2011-01-27
Changed in appmenu-gtk (Ubuntu Natty):
status: Triaged → Invalid
Changed in appmenu-gtk:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.23.90-0ubuntu7

---------------
gtk+2.0 (2.23.90-0ubuntu7) natty; urgency=low

  * debian/patches/043_ubuntu_menu_proxy.patch:
    - Update to proxy F10 presses to the global menu. LP: #689178
  * debian/libgtk2.0-0.symbols:
    - Add new symbol ubuntu_gtk_menu_shell_activate_first
 -- Michael Terry <email address hidden> Thu, 27 Jan 2011 09:45:46 -0500

Changed in gtk+2.0 (Ubuntu Natty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 2.99.2-1ubuntu3

---------------
gtk+3.0 (2.99.2-1ubuntu3) natty; urgency=low

  * debian/patches/043_ubuntu_menu_proxy.patch:
    - Update to proxy F10 presses to the global menu. LP: #689178
  * debian/libgtk3.0-0.symbols:
    - Add new symbol ubuntu_gtk_menu_shell_activate_first
 -- Michael Terry <email address hidden> Thu, 27 Jan 2011 10:01:43 -0500

Changed in gtk+3.0 (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers