package apache2.2-common 2.2.14-5ubuntu8.2 failed to install/upgrade: el subproceso script post-installation instalado devolvió el código de salida de error 1

Bug #621837 reported by Raul on 2010-08-21
106
This bug affects 15 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned
Maverick
Low
Unassigned

Bug Description

Binary package hint: apache2

actualization

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: apache2.2-common 2.2.14-5ubuntu8.2
ProcVersionSignature: Ubuntu 2.6.32-24.41-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Sat Aug 21 10:58:43 2010
ErrorMessage: el subproceso script post-installation instalado devolvió el código de salida de error 1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
SourcePackage: apache2
Title: package apache2.2-common 2.2.14-5ubuntu8.2 failed to install/upgrade: el subproceso script post-installation instalado devolvió el código de salida de error 1

Raul (heroca66) wrote :
Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem. We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.
At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in apache2 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Adam Conrad (adconrad) wrote :

Chuck, there's nothing incomplete about bugs like this. The dpkg terminal log shows you what you need to know:

Configurando apache2.2-common (2.2.14-5ubuntu8.2) ...
ERROR: Module reqtimeout does not exist!
dpkg: error al procesar apache2.2-common (--configure):

I could be going out on a limb here, but I'd assume the user's expected outcome was "that shouldn't happen". :P

Changed in apache2 (Ubuntu):
status: Incomplete → New
Dave Walker (davewalker) wrote :

Is this a dupe of 562370, but with slightly different behavior?

Accepted apache2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apache2 (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Michael Vogt (mvo) wrote :

This is a bit of a odd error, applying the lucid-proposed patch to maverick works fine, but the log shows that apache2.2-bin got unpacked and configured before apache2.2-common, so I wonder why it did not find the reqtimeout module. Its part of apache2.2-bin afaict.

Jean-Baptiste Lallement (jibel) wrote :

It makes sense is the user installed apache2 from the archive, tried to tweak its configuration to install e.g a LAMP server by hand, then upgrade.

You can reproduce in lucid with the following steps
$ apt-get install apache2=2.2.14-5ubuntu8 apache2-mpm-prefork=2.2.14-5ubuntu8 apache2.2-common=2.2.14-5ubuntu8 apache2.2-bin=2.2.14-5ubuntu8
$ a2dismod reqtimeout
$ mv /etc/apache2/mods-available/reqtimeout.* /tmp/
$ apt-get upgrade

You'll also notice the error in the logs ".: 45: Can't open /etc/apache2/envvars
", there is a high probability that the apache2 configuration has been modified manually and I think those errors are user errors.

Anyway the version I have verified that the version of apache2 2.2.14-5ubuntu8.3 in -proposed fixes the issue and the installation is not failing anymore.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.2.14-5ubuntu8.3

---------------
apache2 (2.2.14-5ubuntu8.3) lucid-proposed; urgency=low

  * debian/apache2.2-common.postinst: Don't fail if you can load the reqtimeout module.
    (LP: #621837)
  * debian/patches/Backport fix for upstream bug PR 45444: https://issues.apache.org/bugzilla/show_bug.cgi?id=45444. (LP: #609290, #589611, #595116)
 -- Chuck Short <email address hidden> Mon, 27 Sep 2010 14:06:57 -0400

Changed in apache2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Chuck Short (zulcss) on 2011-03-14
Changed in apache2 (Ubuntu Maverick):
status: New → Triaged
status: Triaged → Fix Released
Chuck Short (zulcss) on 2011-11-07
Changed in apache2 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.