Getting old buffer + header + correct response

Bug #1874932 reported by Sjef Bosman on 2020-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

UBUNTU RELEASE
Description: Ubuntu 16.04.3 LTS
Release: 16.04

APACHE2 VERSION
apache2:
  Installed: 2.4.18-2ubuntu3.14
  Candidate: 2.4.18-2ubuntu3.14
  Version table:
 *** 2.4.18-2ubuntu3.14 500
        500 http://ubuntu.apt-get.eu/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.4.18-2ubuntu3.13 500
        500 http://security.ubuntu.apt-get.eu/ubuntu xenial-security/main amd64 Packages
     2.4.18-2ubuntu3 500
        500 http://ubuntu.apt-get.eu/ubuntu xenial/main amd64 Packages

WHAT I EXPECT TO HAPPEN
That a correct response is sent back, see below.

WHAT ACTUALLY HAPPENS
We have apache2 as a reverse proxy server, doing a lot of things: 4 Virtual Hosts, several RewriteRules, SSL to a non-SSL internal (Domino) server, quite some ProxyPass* lines, and a few Substitutes to fix links in returned HTML.

In 98% of all cases everything works, only, in 2% of the page requests the browser gets the wrong response: it contains the homepage html, then the header for the actual response, and then the correct response.

Here an extract of the middle part of the returned response, where two buffers seem to be joined:
-----------------------------
XSP.addOnLoad(function() {
XSP.attachEvent("view:_id1:_id2:_id3:_id9:_id10:5:_id26:_id28:_id30", "view:_id1:_id2:_id3:_id9:_id10:5:_id26:_id28:query", "onkeydown", view__id1__id2__id3__id9__id10_5__id26__id28__id30_clientSide_onkeydown, false, 2);
XSP.attachEvent("view:_id1:_id2:_id3:_id9:_id10:5:_id26:_id28:_id31", "view:_id1:_id2:_id3:_id9:_id10:5:_id26:_id28:btnSearch", "onclick", view__id1__id2__id3__id9__id10_5__id26__id28__id31_clientSide_onclick, false, 0);
XSP.attachEvent("view:_id1:_id2:_id3:_id9:_id10:6:_id34:_id36:_id38", "view:_id1:_id2:_id3:_id9:_id10:6:_id34:_id36:image1", "onclick", view__id1__id2__id3__id9__id10_6__id34__id36__id38_clientSide_onclick, false, 2);
});

</script>
</body>
</html>HTTP/1.1 200 OK

Date: Fri, 24 Apr 2020 22:03:21 GMT

Content-Type: text/html;charset=UTF-8

Expires: -1

Content-Length: 72703

<!DOCTYPE html>
<html lang="en">
<head>
<base href="//www.website.nl/TA.nsf/Page.xsp/">
<title>Website</title>
<link rel="SHORTCUT ICON" href="/website.nsf/images/favicon.ico/%24file/favicon.ico">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=4.0, user-scalable=yes">
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Rubik" src="" type=""></link>
<meta name="Description" content="info">
<link rel="stylesheet" type="text/css" href="/xsp/.ibmxspres/.mini/css-1.9.7/@Da&amp;@Ib&amp;2Tfxsp.css&amp;2TfxspLTR.css&amp;2TfxspFF.css.css">
-----------------------------

The output comes from one single line in the Firefox 75.0 Developer Tools window, on the Network tab.

The same happens every now and then on a page that regularly refreshes an image on the screen. Usually (98%) the response is correct, but sometimes two responses are combined into one and then the browser flips.

Needless to say maybe, but if I access the website directly, i.e. not through the proxy server, there's no problem whatsoever, the response is always correct.

Thank you for looking into this. If you need more info, please contact me by mail.

Hello Sjef,

Thank you for taking the time to file a bug report.

Would you mind providing more information about your issue ?

1) Have you tried the same with a more recent apache/ubuntu combination ?
2) Have you tried the latest 20.04 LTS with the same configuration ? Does it face this issue ?
3) Could you provide a specific step-by-step reproducer for your issue ?

Since there is not enough information in your report to begin triage or to
differentiate between a local configuration problem and a bug in Ubuntu, I
am marking this bug as "Incomplete". We would be grateful if you would:
provide a more complete description of the problem, explain why you
believe this is a bug in Ubuntu rather than a problem specific to your
system, and then change the bug status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
Sjef Bosman (sjef.bosman) wrote :

Hi Rafael,

Thanks for responding.

Re 1) No, because the server is not mine, and it lacks several updates on other tools and libraries. I'll try to get them installed.

Re 2) I don't know if the owner is willing to upgrade to 20.04 LTS. I did update to the latest apache version though, which made no difference.

Re 3) Don't have to do something specific, as it will fail in 10% of all requests.

I could share two things with you:
- a link to the test-page on the website if you want, but only by mail, so the server won't receive thousands of test requests.
- the configuration file

IMHO it's a bug because
- I open just one page in Firefox, with Developer Tools activated (Network tab)
- the page refreshes itself using Ajax every 60 seconds (I could change that to every 6 seconds or so)
- in 90% of all cases the response is OK
- when it isn't OK, some older (?) buffer is inserted, see my description

Send me a mail from a personal mail address and I'll send you the link.

Changed in apache2 (Ubuntu):
status: Incomplete → New
Sjef Bosman (sjef.bosman) wrote :

I'm sorry to say that it's less urgent now, because a switch to nginx is imminent... we encountered some problems, but not the overrun problem as discussed above.
I still have the old site operational, and the config file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers