Comment 28 for bug 1641238

Folks, can we please backport to 2.4.38 finally?