Package does not work with JDK 5

Bug #264808 reported by Marek Slama
16
Affects Status Importance Assigned to Milestone
ant (Ubuntu)
Fix Released
High
Unassigned
Intrepid
Fix Released
High
Unassigned
antlr (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
commons-daemon (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
gjdoc (Ubuntu)
Won't Fix
Undecided
Unassigned
Intrepid
Won't Fix
Undecided
Unassigned
java-access-bridge (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
javax-servletapi2.3 (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
jsch (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
junit (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libcommons-collections3-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libcommons-net-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libgnuinet-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libgnujaf-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libgnumail-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libjaxp1.3-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libjdepend-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
liboro-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libreadline-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libregexp-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libservlet2.4-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
libxerces2-java (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
rhino (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
tomcat5.5 (Ubuntu)
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned
tomcat6 (Ubuntu)
Won't Fix
Undecided
Unassigned
Intrepid
Won't Fix
Undecided
Unassigned

Bug Description

Binary package hint: ant

It reports wrong class format when used with JDK 5. It looks like it was compiled with JDK 6 without javac param -source 1.5 (which implies -target 1.5). It applies to latest ant version in intrepid. Not sure if it is bug or by design. Anyway it is not possible now to build app using JDK 5 with packaged ant so I had to download original upstream binary.

Revision history for this message
Thom May (thombot) wrote :

Is there any reason not to build for 1.4 by default? That would ensure pretty much anything distributed by Ubuntu would be able to utilise ant.

Revision history for this message
Matthias Klose (doko) wrote :

> Is there any reason not to build for 1.4 by default? That would ensure pretty
> much anything distributed by Ubuntu would be able to utilise ant.

I'm not sure about 1.4, but we should not require 1.6. 1.5 compatibility sounds enough.

Changed in ant:
importance: Undecided → High
milestone: none → ubuntu-8.10-beta
status: New → Triaged
Revision history for this message
Juraci Krohling (partenon) wrote :

Ant itself is compiled correctly. I'm using both java6 and java5 from Sun, using "alternatives", and it works fine. The problem is with some libs included in Debian version. As a workaround, I commented out this code:

# Add the Xerces 2 XML parser in the Debian version
#if [ -z "$LOCALCLASSPATH" ] ; then
# LOCALCLASSPATH="/usr/share/java/xmlParserAPIs.jar:/usr/share/java/xercesImpl.jar"
#else
# LOCALCLASSPATH="/usr/share/java/xmlParserAPIs.jar:/usr/share/java/xercesImpl.jar:$LOCALCLASSPATH"
#fi

These are the jars which are incompatible with Java 1.5.x (JRE included, not only JDK). I commented this out and my builds are now working again.

Revision history for this message
Matthias Klose (doko) wrote :

fixes libxerces2-java. please could you check if that is enough to run ant on a 1.4 vm?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxerces2-java - 2.9.1-2ubuntu2

---------------
libxerces2-java (2.9.1-2ubuntu2) intrepid; urgency=low

  * Set java source and target version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Tue, 30 Sep 2008 00:09:46 +0200

Changed in libxerces2-java:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ant - 1.7.0-6ubuntu3

---------------
ant (1.7.0-6ubuntu3) intrepid; urgency=low

  * Set java source and target version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 29 Sep 2008 22:39:54 +0000

Changed in ant:
status: Triaged → Fix Released
Revision history for this message
Marek Slama (mslama-email) wrote :

Problem is back 17 Oct. From log (even verbose) I am not able to say what class/jar causes this problem. To reproduce unzip attached zip, go into folder JavaApplication1 and run ant. Build will fail. Of course JDK 5 must on on PATH and JAVA_PATH, JAVA_HOME must be set to JDK 5 for ant. I use Sun JDK 5u16. Shall I reopen this issue or shall I file new one?

Matthias Klose (doko)
Changed in ant:
status: Fix Released → Confirmed
Matthias Klose (doko)
Changed in antlr:
status: New → In Progress
Thierry Carrez (ttx)
Changed in commons-daemon:
assignee: nobody → tcarrez
status: New → In Progress
Revision history for this message
Thierry Carrez (ttx) wrote :

The current Tomcat 6 packages require "default-jre-headless | java6-runtime headless" so having it bytecoded for 1.6 is not a bug... I'll file a "support for 1.5" wishlist bug though, because it would still be nice to have.

Changed in libcommons-collections3-java:
assignee: nobody → tcarrez
status: New → In Progress
Changed in tomcat5.5:
assignee: nobody → tcarrez
status: New → In Progress
Changed in tomcat6:
status: New → Won't Fix
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libjaxp1.3-java - 1.3.04-3ubuntu2

---------------
libjaxp1.3-java (1.3.04-3ubuntu2) intrepid; urgency=low

  * Set java source and target version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:01:09 +0200

Changed in libjaxp1.3-java:
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

java-access-bridge (1.24.0-0ubuntu2) intrepid; urgency=low

  * Compile java files with -source 1.5.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:45:59 +0200

Changed in java-access-bridge:
status: New → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :

fixed in 1.7R1-1ubuntu3

Changed in rhino:
status: New → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :

closing the ant task again; libjaxp1.3-java is now built with -source 1.4 as well.

Changed in ant:
status: Confirmed → Fix Released
Thierry Carrez (ttx)
Changed in libservlet2.4-java:
assignee: nobody → tcarrez
status: New → In Progress
Revision history for this message
Thierry Carrez (ttx) wrote :

Debdiff for tomcat5.5
(targeting 1.5 because it fails to compile without patches if we target 1.4)

Revision history for this message
Thierry Carrez (ttx) wrote :

Debdiff for commons-daemon

Revision history for this message
Thierry Carrez (ttx) wrote :

Debdiff for libcommons-collections3

Revision history for this message
Thierry Carrez (ttx) wrote :

New debdiff for commons-daemon, closes the right bug.

Revision history for this message
Thierry Carrez (ttx) wrote :

Debdiff for libservlet2.4-java

Changed in commons-daemon:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Changed in libcommons-collections3-java:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Changed in libservlet2.4-java:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Changed in tomcat5.5:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package junit - 3.8.2-1ubuntu2

---------------
junit (3.8.2-1ubuntu2) intrepid; urgency=low

  * Compile java files with -target 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 14:25:15 +0200

Changed in junit:
status: New → Fix Released
Matthias Klose (doko)
Changed in gjdoc:
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jsch - 0.1.37-3ubuntu2

---------------
jsch (0.1.37-3ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:07:22 +0000

Changed in jsch:
status: New → Fix Released
Matthias Klose (doko)
Changed in gjdoc:
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libjdepend-java - 2.9-4ubuntu2

---------------
libjdepend-java (2.9-4ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:26:56 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcommons-net-java - 1.4.1-1ubuntu2

---------------
libcommons-net-java (1.4.1-1ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:22:01 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package javax-servletapi2.3 - 4.0-10ubuntu3

---------------
javax-servletapi2.3 (4.0-10ubuntu3) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:16:19 +0000

Changed in javax-servletapi2.3:
status: New → Fix Released
Changed in libcommons-net-java:
status: New → Fix Released
Changed in libjdepend-java:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnuinet-java - 1.1.1-3ubuntu2

---------------
libgnuinet-java (1.1.1-3ubuntu2) intrepid; urgency=low

  * * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 14:10:11 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnumail-java - 1.1.2-2ubuntu2

---------------
libgnumail-java (1.1.2-2ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 14:06:18 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnujaf-java - 1.1.1-4ubuntu2

---------------
libgnujaf-java (1.1.1-4ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 14:02:10 +0000

Changed in libgnuinet-java:
status: New → Fix Released
Changed in libgnujaf-java:
status: New → Fix Released
Changed in libgnumail-java:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreadline-java - 0.8.0.1-8.1ubuntu1

---------------
libreadline-java (0.8.0.1-8.1ubuntu1) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:49:40 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcommons-collections3-java - 3.2.1-1ubuntu2

---------------
libcommons-collections3-java (3.2.1-1ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:58:11 +0000

Changed in libcommons-collections3-java:
status: Confirmed → Fix Released
Changed in libreadline-java:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libservlet2.4-java - 5.0.30-8ubuntu3

---------------
libservlet2.4-java (5.0.30-8ubuntu3) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:45:28 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libregexp-java - 1.4-4ubuntu2

---------------
libregexp-java (1.4-4ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:41:26 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package liboro-java - 2.0.8a-4ubuntu2

---------------
liboro-java (2.0.8a-4ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden> Mon, 20 Oct 2008 13:37:24 +0000

Changed in liboro-java:
status: New → Fix Released
Changed in libregexp-java:
status: New → Fix Released
Changed in libservlet2.4-java:
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat5.5 - 5.5.26-3ubuntu3

---------------
tomcat5.5 (5.5.26-3ubuntu3) intrepid; urgency=low

  * Set java source and target version to 1.5 (LP: #264808)

 -- Thierry Carrez <email address hidden> Mon, 20 Oct 2008 13:47:15 +0200

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package commons-daemon - 1.0.2~svn20061127-9ubuntu2

---------------
commons-daemon (1.0.2~svn20061127-9ubuntu2) intrepid; urgency=low

  * Set java source and target version to 1.4 (LP: #264808)

 -- Thierry Carrez <email address hidden> Mon, 20 Oct 2008 11:22:38 +0200

Changed in commons-daemon:
status: Confirmed → Fix Released
Changed in tomcat5.5:
status: Confirmed → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

antlr (2.7.7-6ubuntu2) intrepid; urgency=low

  * Build a libantlr-java package, without dependency on a java runtime.
    Needed to bootstrap gcj without having a java runtime installed.
  * Build a libantlr-java-gcj package, replace cantlr with a shell script to use it.
  * Explicitely call javac with -source 1.4. LP: #264808.

Changed in antlr:
status: In Progress → Fix Released
Revision history for this message
Matthew Buckett (buckett) wrote :

I just got bitten by the Tomcat6 being compiled for JDK 1.6, for someone who is used to the standard distributions from http://tomcat.apache.org/ I lost quite a bit of time chasing down the reason.

It wasn't helped by the fact that in the file /etc/init.d/tomcat6 is the line:

JDK_DIRS="/usr/lib/jvm/java-6-openjdk /usr/lib/jvm/java-6-sun /usr/lib/jvm/java-1.5.0-sun /usr/lib/j2sdk1.5-sun /usr/lib/j2sdk1.5-ibm"

which means that tomcat6 will attempt to use a 1.5 JDK if a 1.6 JDK isn't installed.

Tomcat 6 runs fine on JDK 1.5 and it would be helpful if the packaged version was compiled so that it would run against it.

Revision history for this message
Thierry Carrez (ttx) wrote :

Matthew: see bug 286427. This was fixed in Jaunty. Please followup on that bug if you think we should issue a stable release update to cover this bug in 8.10

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers