pictures taken with flash are almost completely black

Bug #1322121 reported by Selene Scriven on 2014-05-22
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
camera-app
Invalid
Medium
Bill Filler
android (Ubuntu)
Critical
Unassigned
qtubuntu-camera (Ubuntu)
Critical
Unassigned

Bug Description

On the mako / Nexus 4, the camera has an LED to use for camera flash. Our camera app supports the flash, and fires it while taking a picture with flash enabled. However, the resulting image ends up severely underexposed, to the point where almost the entire image is black.

Steps to reproduce:
1. Run the camera app.
2. Take a picture with flash off.
3. Turn the flash setting on and take a picture of the same scene again.
4. Go to the gallery app to view the results.

Expected results: The picture with flash should appear brighter (or, at least, appear how most with-flash pictures look).

Actual results: The picture with flash is almost completely black, with only a few dim details in the brightest parts of the image.

Changed in camera-app:
status: New → Confirmed
Ricardo Salveti (rsalveti) wrote :

Do we know if this is a regression? If so, do we know which was the first image that got the broken behavior?

Not much changed in the camera layer lately, so wonder what changed in the image.

Jim Hodapp (jhodapp) wrote :

Does this happen every time you follow these steps or every so often? I'm trying to reproduce this and can't seem to.

Selene Scriven (toykeeper) wrote :

Yes, it's a regression. I recall it working in the past, and the person who reported it to me (sorry, I didn't catch his name... deiku?) showed me his photo log and that it apparently broke around the beginning of May or end of April. I think he actually saw it break during April, start working again, then break again on May 1st or so.

However, it was broken in at least the past two promoted images (u44 and u28, I think).

It looks like it might be a timing bug. It turns on the light, turns off the light, exposes the image, turns on the light, then turns off the light again. Blink-snap-blink, and the photo ends up with brightness adjusted way down for flash but without the flash actually on during exposure.

We've added this to the manual test plan, in case there are future issues.

tags: added: avengers-3
Changed in camera-app:
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → High
Julien Funk (jaboing) on 2014-05-28
tags: added: avengers
Ugo Riboni (uriboni) wrote :

I looked into this and it seems that down in libhybris we are not doing anyhing that controls directly the sequence of flash and capture. We're just asking android to capture an image as far as I can tell.

However I noticed there is a way to sidestep the problem that, at least for me, is consistently reproducible.

* Take a picture with flash enabled
* Go to gallery (verify it's underexposed)
* Back to camera (verify the flash icon is still active)
* Take a picture (verify that no flash has been fired)
* Switch to no-flash mode, and take another picture
* Switch to flash mode again and take a picture (verify flash fires)
* If you switch to gallery now you will see the last pictures you have taken are all correctly exposed, including the last one with flash.

I hope this is reproducible for others and will provide further clues to those debugging the issue at the lower levels.

tags: added: qa-touch

@Ugo, I don't see that, The old pictures are still badly exposed.

Hm, I have retried reproducing the steps in #4 and on the first picture with flash it's timed badly so you can see (reflection) some flash, but not much. The last picture with flash enabled is fine though.

Changed in camera-app:
assignee: Ugo Riboni (uriboni) → Bill Filler (bfiller)
Adnane Belmadiaf (daker) wrote :

Hi,

Comment #3 : I am the person who did report this to Selene, the first black images start appearing on 1st May for me(that's the time when i reflashed again and start taking photos with flash on)

Comment #4 : Same answer as Popey

Selene Scriven (toykeeper) wrote :

Still happening in Utopic image 140.

Changed in camera-app:
milestone: none → rtm-freeze
tags: added: rtm14
tags: added: qa-daily-testing
removed: ueqa
Selene Scriven (toykeeper) wrote :

Still happens in Utopic 161.

Bill Filler (bfiller) wrote :

this is not a camera-app bug. we are setting the right values

Changed in camera-app:
status: Confirmed → Invalid
Changed in android (Ubuntu):
status: New → Triaged
Changed in qtubuntu-camera (Ubuntu):
status: New → Triaged
Changed in android (Ubuntu):
importance: Undecided → High
Changed in qtubuntu-camera (Ubuntu):
importance: Undecided → High

This needs to be fixed before RTM. Changing importance to critical.

Changed in camera-app:
importance: High → Critical
Pat McGowan (pat-mcgowan) wrote :

This is only reproducible on mako so removing rtm tag

tags: removed: rtm14
tags: added: rtm14
tags: removed: rtm14
Changed in camera-app:
milestone: rtm-freeze → none
Florian Boucault (fboucault) wrote :

Could it be the same bug as https://jira.cyanogenmod.org/browse/CYAN-2644 ?

Jim Hodapp (jhodapp) on 2014-09-25
summary: - pictures taken with flash are almost completely black
+ [mako] pictures taken with flash are almost completely black
Changed in camera-app:
importance: Critical → Medium
Bill Filler (bfiller) wrote :

this happens all the time with Arale

summary: - [mako] pictures taken with flash are almost completely black
+ pictures taken with flash are almost completely black
Changed in qtubuntu-camera (Ubuntu):
importance: High → Critical
Changed in android (Ubuntu):
importance: High → Critical
Changed in canonical-devices-system-image:
milestone: none → ww22-2015
importance: Undecided → Critical
John McAleely (john.mcaleely) wrote :

Has anyone seen it on a vivid/krillin?

Florian Boucault (fboucault) wrote :

John: it does not happen on krillin. Only on Mako. On Arale some symptoms are similar but I'd guess the cause is different.

Bill Filler (bfiller) on 2015-05-15
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
John McAleely (john.mcaleely) wrote :

OK, so over to YC to ask someone in the Arale team to find out what's going on in the android & lower levels of the MTK stack.

Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → Yuan-Chen Cheng (ycheng-twn)
Chunsang Jeong (chunsang) wrote :

@bfiller
I couldn't reproduce it from arale, please check again with arale if the bug below is what you've seen.
https://bugs.launchpad.net/tangxi/+bug/1446069

For mako, flash turned on all the time(when forced flash ON) but the image was darker than the pic without flash, and when it got normal pic I could see this log often (seems more like post image processing)
https://pastebin.canonical.com/131577/
Need to dive into mako code but when I touch the screen to make af work with flash in advance, then I could get normal pic all the time.

When I got normal pic from by touching screen to to make af work with flash in advance are, I got additional log below from logcat;
E/mm-camera( 1069): PROFILE set_parm_AF: : 1431930835.474471730
.....
D/mm-camera( 1069): LG_AF_P : CAF for STILL parms REset after capture

* attached pic - wrong pic from mako.

Chunsang Jeong (chunsang) wrote :

- When I got normal pic from by touching screen to to make af work with flash in advance are, I got additional log below from logcat;
+ When I got normal pic by touching screen to make af work with flash in advance, I got additional log below from logcat;

* attached pic - normal pic from mako.

Yuan-Chen Cheng (ycheng-twn) wrote :

@Bill, can you confirm that if it's https://bugs.launchpad.net/tangxi/+bug/1446069 as you tested on Arale.

If yes, I am not sure if we can decrease the priority for this one, since this is only for mako.

Changed in canonical-devices-system-image:
assignee: Yuan-Chen Cheng (ycheng-twn) → Bill Filler (bfiller)
status: New → Incomplete
Florian Boucault (fboucault) wrote :

@Yuan-Chen: https://bugs.launchpad.net/tangxi/+bug/1446069 is valid but is a different bug to the dark pictures we get with arale. The arale bug is https://bugs.launchpad.net/tangxi/+bug/1455494 where dark pictures are produced with the flash actually firing.

Dario Cavedon (dcavedon) wrote :

Hi,
I have an arale with Ubuntu 15.04 r172, camera-app version 3.0.0.558 and I can confirm this bug (yet I'm not authorized access #1446069), if you need any help.

Cheers,
Dario

Changed in canonical-devices-system-image:
milestone: ww22-2015 → ww24-2015
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → John McAleely (john.mcaleely)
status: Incomplete → Confirmed
Changed in canonical-devices-system-image:
milestone: ww24-2015 → ww34-2015
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Michael (mmcauliff1453) on 2015-09-15
Changed in qtubuntu-camera (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Michael (mmcauliff1453)
Changed in android (Ubuntu):
assignee: nobody → Michael (mmcauliff1453)
Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → Michael (mmcauliff1453)
Changed in camera-app:
assignee: Bill Filler (bfiller) → Michael (mmcauliff1453)
status: Invalid → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in qtubuntu-camera (Ubuntu):
assignee: Michael (mmcauliff1453) → nobody
Changed in camera-app:
status: In Progress → New
assignee: Michael (mmcauliff1453) → Ugo Riboni (uriboni)
assignee: Ugo Riboni (uriboni) → Bill Filler (bfiller)
Michael (mmcauliff1453) wrote :

This Is What The Values Should be

Changed in qtubuntu-camera (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Confirmed
Changed in camera-app:
status: New → Incomplete
assignee: Bill Filler (bfiller) → Michael (mmcauliff1453)
Changed in qtubuntu-camera (Ubuntu):
assignee: nobody → Michael (mmcauliff1453)
Changed in android (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

Michael, please refrain from making this kind of unexplained change to bug statuses.

Changed in qtubuntu-camera (Ubuntu):
status: Fix Released → Triaged
assignee: Michael (mmcauliff1453) → nobody
Changed in android (Ubuntu):
assignee: Michael (mmcauliff1453) → nobody
Changed in camera-app:
assignee: Michael (mmcauliff1453) → Bill Filler (bfiller)
status: Incomplete → Invalid
Changed in canonical-devices-system-image:
assignee: Michael (mmcauliff1453) → nobody
Changed in android (Ubuntu):
status: Fix Committed → Triaged
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
Changed in canonical-devices-system-image:
milestone: ww40-2015 → backlog

Please check if this is the same bug as bug #1368063.

I can always reproduce this issue on my mako and I found a workaround for it: when you open camera-app just tap on screen once (you'll see a flash light for a second), after this step flash works fine and photos are no longer dark/black. This seems to work for me, not sure it will work for you too, please let me know.

Does anyone have an idea of what piece of code handles this?

Jochen M. L. (jochen-x) wrote :

Thanx Devid,
This is a good workaround for my Nexus 4. I can confirm it'll work every time, but it's still a bug in OTA 13.
Hopefully it's fixed soon, because you'll forget to do this step sometimes.

Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers