amule memory usage increases to 100% and makes the whole system unusable

Bug #610385 reported by Jean-Peer Lorenz on 2010-07-27
70
This bug affects 7 people
Affects Status Importance Assigned to Milestone
AMule
Unknown
Unknown
amule (Debian)
Fix Released
Unknown
amule (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amule

After wakeup from standby amule memory usage increases to 100% of my 4GB RAM very fast. The harddisk starts hard working (swap) and the whole system becomes unusable.

What I did:

* selected Standby to pause the machine over night
* wake up the machine next morning
-> wondered whats going on with the harddisk

Don't know if this is reproducable: I'm not keen on crashing my production system.

Description: Ubuntu 10.04.1 LTS
Release: 10.04

amule:
  Installed: 2.2.6+debian0-7
  Candidate: 2.2.6+debian0-7
  Version table:
 *** 2.2.6+debian0-7 0

libwxgtk2.8-0:
  Installed: 2.8.10.1-0ubuntu1
  Candidate: 2.8.10.1-0ubuntu1
  Version table:
 *** 2.8.10.1-0ubuntu1 0

summary: - amule memory usage increases to 100% and make the whole system unusable
+ amule memory usage increases to 100% and makes the whole system unusable
Ohad (ohadle) wrote :

This happened to me twice so far. I do not use standby mode (this is a desktop), this happens just after a while of running the program.

arr (alan-drop-share) wrote :

This happens with me at least once a day.

shankao (shankao) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugs.amule.org/view.php?id=1532

shankao (shankao) wrote :

Confirmed after reporters comments (plus reports in upstream bugtracker)

Changed in amule (Ubuntu):
status: New → Confirmed
shankao (shankao) on 2011-01-18
tags: added: lucid

Also affects aMule AdunanzA 2010.1 in 10.10. No stand-by problems, I simply started the app, then after downloading very fast a couple of files, CPU went to 100%.

Zane (zanetu) wrote :

Same problem on 64-bit Kubuntu 10.10. Disconnecting network and getting reconnected later sometimes results in the same problem.

tx (372046933-qq) wrote :

I can confirm that it happened at most 1 hour once. It exhaust almost 4GB memory and can hardly be killed because the system's response at the precise moment is astoundingly slow.
kernel info: Linux ASUS 2.6.32-31-generic #61-Ubuntu SMP Fri Apr 8 18:25:51 UTC 2011 x86_64 GNU/Linux

Changed in amule (Debian):
status: Unknown → Confirmed
Tiago (toazz) on 2011-05-19
tags: added: natty
Selmi (selmi) wrote :

it happens also in oneiric, i run it in kde
but it doesn't happen all the time, sometimes i have it running for hours, sometimes it happens in 15-20 minutes. i guess it may depend on count of files, connections or something like that

Changed in amule (Debian):
status: Confirmed → Fix Released
Vibhav Pant (vibhavp) on 2012-04-16
Changed in amule (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.