[need 2.2.3] amule crashes when I close a tab (possible GTK+ bug)

Bug #59138 reported by Kurt Kraut
204
This bug affects 9 people
Affects Status Importance Assigned to Milestone
wxWidgets
Unknown
Unknown
amule (Mandriva)
Won't Fix
Medium
amule (Ubuntu)
Medium
Unassigned
Declined for Gutsy by Emilio Pozuelo Monfort
Declined for Intrepid by Emilio Pozuelo Monfort
Edgy
Undecided
Unassigned
wxwidgets2.6 (Ubuntu)
Medium
Matti Lindell
Declined for Gutsy by Emilio Pozuelo Monfort
Declined for Intrepid by Emilio Pozuelo Monfort
Edgy
High
Matti Lindell

Bug Description

Search results are separated by tabs in amule. When I try to close one of these tabs, amule crashes.

Revision history for this message
Kurt Kraut (kurtkraut) wrote : Log

Here is a big log about this crash.

Revision history for this message
Inaldo (inaldo) wrote : Re: amule crashes when I close a tab

Crashes with me in the same situation.

Revision history for this message
Matti Lindell (mlind) wrote :

Confirmed on Edgy
Architecture: i386
Version: 2.1.2-3

I'll test if version on Debian unstable does the same.

Changed in amule:
status: Unconfirmed → Confirmed
Revision history for this message
Matti Lindell (mlind) wrote :

Well same bug is present on 2.1.3-1 too.. Is the crasher actually coming from wxWidgets library?

Revision history for this message
Matti Lindell (mlind) wrote :

Backtrace after libwxgtk2.6-dbg package is installed.

Revision history for this message
Rocco Stanzione (trappist) wrote :
Revision history for this message
Mark Florian (markrian) wrote :

I've encountered this too. The priority should be set to match a crasher bug, shouldn't it?

Revision history for this message
Julien Lavergne (gilir) wrote :

Same error with amule 2.1.3-1
amule gives a backtrace

Revision history for this message
Adam McMaster (adammc) wrote :

Happens here too.

Revision history for this message
Dan Bishop (danbishop) wrote :

Same here. Crashes when closing a search results tab if another tab is still searching.

Revision history for this message
origin of (origin-of) wrote :

same here...

Revision history for this message
tasadar_f (tasadarf) wrote :

I have the same error

Revision history for this message
yostral (y-o) wrote :

Same bug here...

Revision history for this message
Artemis3 (artemis3) wrote :

Same. Also try opening chat tabs and then close them all.

Revision history for this message
writser (writser-gmail) wrote :

Confirmed here too.

Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

Here is a quick way to reproduce this:
1) start amule
2) search for something, e.g. "Ubuntu"
3) Immediately close the tab with the search results
=> Crash.

Revision history for this message
JoseStefan (josestefan) wrote :

the problem can also be reproduced by pressing the "Clear" button. Which essentially closes any open tabs, thus triggering the bug.

Example:
1) start amule
2) search for something, e.g. "Ubuntu"
3) Press the "Clear" button.
=> Crash.

It doesn't seem to matter if the search is in progress or done.

Changed in amule:
importance: Undecided → Medium
Revision history for this message
dresnu (dresnu) wrote :

It happens to me too running aMule 2.1.3 on Edgy.

Actually the problem is presented when you close the last open tab in the search results, which is also triggered when pressing the clear button.

Revision history for this message
JoseStefan (josestefan) wrote :

I have installed aMule (dapper) in edgy for testing. aMule (dapper) did not crash in dapper, so I though it was worth testing.

As a result, aMule (dapper) will crash in edgy in just the same way. I don't know how to provide in-depth crash analysis so that is all I can offer for now. But this could mean the bug lies on another package (like wxwidgets2.6)

To install it:
1) remove all the installed amule packages.
2) add this to your sources.list:
deb http://.archive.ubuntu.com/ubuntu/ dapper universe
3) then:
sudo apt-get update && sudo apt-get install amule/dapper amule-common/dapper

Remember to undo everything after you finish and update repos again, you don't want to keep dapper there.

Revision history for this message
boong (boong) wrote :

This is actually a wxGTK & GTK+ problem and not an aMule bug.

Revision history for this message
ville palo (vi64pa) wrote :

Forwarded to upstream (wxwidgets)

Changed in amule:
status: Unknown → In Progress
Revision history for this message
Marco Cimmino (cimmo) wrote :

the problem is in the wxwidgets and it's solved in new version 2.7.2 and 2.8 according to the last post from amule developer in this bug
http://www.amule.org/abugs/view.php?id=996

> Solved on wx 2.7.2 and 2.8.0

seems so stupid that there is no porting for 2.6 series :(

Revision history for this message
Wladston Viana (wladston) wrote :

I confirm this bug on edgy.

Really anoying :(

Revision history for this message
Montblanc (montblanc) wrote :

It also happens when closing the last message tab... so it happens with every kind of tab, but it HAS to be the last one.
I always keep at least one tab open (the first one)! ;)

TK

Revision history for this message
damvcoool (damvcoool) wrote :

OK, My aMule crashed when i close i tab, that was not difficult to identify, but the apport did not detect the crash. i try doing /usr/share/apport/apport-checkreports
/usr/share/apport/apport-gtk as a normal user and with sudo, but it din't promont me to send anything. so I open amule from a terminal and i recreate the situation. this is part of the output.

Revision history for this message
dresnu (dresnu) wrote :

I've noticed that amule crashes when closing message tabs too. I suppose when you close the last one just like the search tabs but I'm not sure because I discovered this by closing just one message.

Revision history for this message
Carlos Franco (carlosfrancoba) wrote :

There is an important bug in amule. Should you set the maximum impotance to fix this bug? 'Cause the fix releasing is taking a long time and we are losting our position in queues of emule system.

Changed in amule:
assignee: nobody → carlosfrancoba
Revision history for this message
Marco Cimmino (cimmo) wrote :

The bug is NOT in amule BUT in the wxwidgets, I have just said and documented it.
Now there are 2.8.0 final, should backported to Edgy or just the patch that fix this problem.

They are the only two solutions possible here.
Hope to see one in action :)

Marco Cimmino (cimmo)
Changed in wxwidgets2.6:
status: Unconfirmed → Confirmed
Revision history for this message
Matti Lindell (mlind) wrote :

This seems to fix the issue for me. Tested on Feisty wxwidgets2.6_2.6.3.2.1.5build2 with attached patch. Very simple and trivial patch, should be easy to backport for other distros if necessary.

patch taken from wxwidgets cvs
http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/gtk/notebook.cpp.diff?only_with_tag=WX_2_6_BRANCH&r1=1.120.2.2&r2=1.120.2.3&diff_format=u
http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/gtk/notebook.cpp?only_with_tag=WX_2_6_BRANCH

Revision history for this message
Matti Lindell (mlind) wrote :

Possibly working debdiff to fix the issue

Matti Lindell (mlind)
Changed in amule:
assignee: carlosfrancoba → nobody
Revision history for this message
Matti Lindell (mlind) wrote :

Trying again..

Revision history for this message
tasadar_f (tasadarf) wrote :

Someone can upload deb package with the patch for testing???

Revision history for this message
Matti Lindell (mlind) wrote :

full wxwidgets2.6 (+ source package) is too big for me to upload (50MB), so I'll only upload the two binaries that seem to be requirement for amule.

Binaries are compiled on Feisty, i386 arch.

Revision history for this message
tasadar_f (tasadarf) wrote :

Thanks. I test in edgy

Revision history for this message
Marco Cimmino (cimmo) wrote :

The two packages has a lot dependencies problems with Edgy...

Revision history for this message
Matti Lindell (mlind) wrote :

Don't install those on Edgy, binaries are Feisty only.

Revision history for this message
tasadar_f (tasadarf) wrote :

I'm going to build a edgy package from source+patch

Revision history for this message
Marco Cimmino (cimmo) wrote :

thanx tasadar_f :)

Revision history for this message
Marco Cimmino (cimmo) wrote :

any news?
Is it possible that for ONE line patch took THREE months to be committed in a bug so boring and important?

I think time isn't the problem...

Changed in amule:
status: Confirmed → Rejected
Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote : Re: [SRU: EDGY] amule crashes when I close a tab

MOTU has only known about this for 2 days. expecting 1 bug out of about 4000 to be found when it's not tagged as having a fix, or *anything* like that, is ridiculous. Same for 59 people to look at all 4000 jobs, when none of us are employed to work on ubuntu.

For future reference, if it's in the development version, subscribe ubuntu-universe-sponsors so it gets uploaded quickly.

As edgy is released, it will need to follow this procedure:

https://wiki.ubuntu.com/MOTU/SRU

Changed in wxwidgets2.6:
importance: Undecided → High
Matti Lindell (mlind)
Changed in wxwidgets2.6:
assignee: nobody → mlind
Changed in amule:
status: In Progress → Rejected
27 comments hidden view all 107 comments
Revision history for this message
Alberto Milone (albertomilone) wrote :

the packages in tasadar_f links solve the problem.

Amule works great now.

Revision history for this message
Reinhard Tartler (siretart) wrote :

guys, it would help way more if you could test the packages in -proposed rather than tasadar_f's packages. This way we can decide if they go to -updates or not

Revision history for this message
tasadar_f (tasadarf) wrote :

Sorry. I can't see this:

((( you will need to add manually the edgy-proposed repository to /etc/apt/sources.list, install the update, and report whether the new packages fix the crash.)))

I test this packages

Revision history for this message
Mark Florian (markrian) wrote :

As far as I can tell, the updated packages haven't hit -proposed yet, unless I'm missing something. I have the -proposed branch in my sources.list, and I've also searched in http://archive.ubuntu.com/ubuntu/dists/edgy-proposed/universe/binary-i386/Packages.gz but not found anything relating to 'wx'.

Revision history for this message
Marco Cimmino (cimmo) wrote :

> guys, it would help way more if you could test the packages in -proposed rather than tasadar_f's packages. This way we can decide if they go to -updates or not

the problem is that there are NO wxwidgets packages that reached edgy-proposed yet, so there is nothing to test over there!

It's months that I'm pushing for it, but nothing happens!

Revision history for this message
Daniel T Chen (crimsun) wrote :

Already fixed in Feisty.

Changed in wxwidgets2.6:
status: Confirmed → Fix Released
Revision history for this message
Marco Cimmino (cimmo) wrote :

Daniel for Feisty there is another bug, so you don't say fix released here that is related to Edgy without uploading the packages to edgy-proposed.

I think guys you are being crazy! All this time to have a fix in Edgy for one line patch and now this, very disappointing :-/

Revision history for this message
tasadar_f (tasadarf) wrote :

> guys, it would help way more if you could test the packages in -proposed rather than tasadar_f's packages. This way we can decide if they go to -updates or not

I can't find the edgy-propose packages I saw 5 ubuntu mirrors.

My packages (gatoloko) are feisty packages ported to edgy.

I will wait oficial packages for download of edgy-proposed. Now I use my packages(gatoloko)
I tested feisty source code in edgy and work perfectly.

 upload oficial packages to edgy-proposed please

Revision history for this message
Daniel T Chen (crimsun) wrote :

Cimmo, read my change carefully. The status update and comment are related to wxwidgets2.6 in _Feisty_.

Daniel T Chen (crimsun)
Changed in amule:
status: Unconfirmed → Rejected
Revision history for this message
Matti Lindell (mlind) wrote :

Can someone check why packages haven't reached edgy-proposed yet, there's been no announce on https://lists.ubuntu.com/archives/edgy-changes/.

Daniel T Chen (crimsun)
Changed in wxwidgets2.6:
importance: High → Medium
importance: Undecided → High
status: Unconfirmed → In Progress
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

the package for edgy-proposed still awaits approval from ubuntu-archive. I'm sorry for the long delay it takes atm until a package reaches edgy-proposed. We are working on this and will hopefully get the SRU process in a better shape soon.

Cheers,
    Stefan.

Revision history for this message
Marco Cimmino (cimmo) wrote :

Daniel:
for feisty there was another bug opened and just closed
https://launchpad.net/ubuntu/+source/wxwidgets2.6/+bug/76032

so I don't know why here we are talking about this, all report here is related to Edgy, so I don't know why you are talking about Feisty.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Cimmo, before I added the Edgy task, the wxwidgets2.6 bug defaulted to Feisty. Thus I rejected the Feisty task and added an Edgy one. Clear now?

Revision history for this message
Marco Cimmino (cimmo) wrote :

Daniel:
to be clear BEFORE you have closed the bug and AFTER 1h15m you have opened the one for Edgy, to not confuse people please next time do the viceversa or people think that you are rejecting the SRU that was the title of bug.

Of course this is my opinion.

Revision history for this message
Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed; please test as per https://wiki.ubuntu.com/MOTU/SRU

Changed in wxwidgets2.6:
status: In Progress → Fix Committed
Revision history for this message
com4 (com4) wrote :

works for me

Revision history for this message
Matti Lindell (mlind) wrote :

2.6.3.2.1.5ubuntu0.1~proposed1 upload fixes the problem for me on Edgy.

Revision history for this message
tasadar_f (tasadarf) wrote :

Works for me. VLC use wxGTK and work perfectly (not regressions)

Revision history for this message
jmunin (jmunin) wrote : Re: [Bug 59138] Re: [SRU: EDGY] amule crashes when I close a tab

works for me too, in aMule 2.1.3.
Thanks

2007/1/23, tasadar_f <email address hidden>:
>
> Works for me. VLC use wxGTK and work perfectly (not regressions)
>
> --
> [SRU: EDGY] amule crashes when I close a tab
> https://launchpad.net/bugs/59138
>

Revision history for this message
Cyclone (cyclone-antitech) wrote : Re: [SRU: EDGY] amule crashes when I close a tab

Works for me also :D

Thank you

Matti Lindell (mlind)
Changed in wxwidgets2.6:
assignee: nobody → mlind
Revision history for this message
Andrea Vacondio (andrea-vacondio) wrote :

Works for me too.

Revision history for this message
Marco Cimmino (cimmo) wrote :

Works for me, I think can reach edgy updates finally ;)

Revision history for this message
StefanPotyra (sistpoty) wrote :

Format: 1.7
Date: Wed, 31 Jan 2007 00:59:12 +0100
Source: wxwidgets2.6
Binary: wx2.6-headers-msw python-wxversion libwxmsw2.6-dbg python-wxgtk2.6 libwxbase2.6-0 wx2.6-examples libwxgtk2.6-dbg python-wxgtk2.6-dbg wx2.6-doc python-wxtools libwxgtk2.6-dev wx2.6-headers wx2.6-i18n wx-common libwxbase2.6-dev libwxbase2.6-dbg libwxgtk2.6-0 libwxmsw2.6-dev
Architecture: source
Version: 2.6.3.2.1.5ubuntu0.1
Distribution: edgy-updates
Urgency: low
Maintainer: Ron Lee <email address hidden>
Changed-By: Stefan Potyra <email address hidden>
Description:
 libwxbase2.6-0 - wxBase library (runtime) - non-GUI support classes of wxWidgets t
 libwxbase2.6-dbg - wxBase library (debug) - non-GUI support classes of wxWidgets too
 libwxbase2.6-dev - wxBase library (development) - non-GUI support classes of wxWidge
 libwxgtk2.6-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
 libwxgtk2.6-dbg - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
 libwxgtk2.6-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
 libwxmsw2.6-dbg - wxMSW mingw32msvc-cross (debug)
 libwxmsw2.6-dev - wxMSW mingw32msvc-cross
 python-wxgtk2.6 - wxWidgets Cross-platform C++ GUI toolkit (wxPython binding)
 python-wxgtk2.6-dbg - wxWidgets Cross-platform C++ GUI toolkit (wxPython binding)
 python-wxtools - wxWidgets Cross-platform C++ GUI toolkit (wxPython common files)
 python-wxversion - wxWidgets Cross-platform C++ GUI toolkit (wxPython version select
 wx-common - wxWidgets Cross-platform C++ GUI toolkit (common support files)
 wx2.6-doc - wxWidgets Cross-platform C++ GUI toolkit (documentation)
 wx2.6-examples - wxWidgets Cross-platform C++ GUI toolkit (examples)
 wx2.6-headers - wxWidgets Cross-platform C++ GUI toolkit (header files)
 wx2.6-headers-msw - Extra wxWidgets headers for mingw32msvc-cross
 wx2.6-i18n - wxWidgets Cross-platform C++ GUI toolkit (i18n support)
Changes:
 wxwidgets2.6 (2.6.3.2.1.5ubuntu0.1) edgy-updates; urgency=low
 .
   * No-change upload, propagating to edgy-updates.
   * Tested by: Cimmo, Andrea Vacondio, Cyclone, jmunin, tasadar_f,
     mlind, com4.
 .
 wxwidgets2.6 (2.6.3.2.1.5ubuntu0.1~proposed1) edgy-proposed; urgency=low
 .
   * Fix for GTK warnings in wxNotebook::DoRemovePage
     (Closes: LP#59138)
Files:
 cf1b7bdbc6a1d7ae972686eab3faf5b5 1067 libs optional wxwidgets2.6_2.6.3.2.1.5ubuntu0.1.dsc
 b95514cb0381cde9cf8d31720510d06b 15522631 libs optional wxwidgets2.6_2.6.3.2.1.5ubuntu0.1.tar.gz

Revision history for this message
Martin Pitt (pitti) wrote :

accepted into edgy-updates

Changed in wxwidgets2.6:
status: Fix Committed → Fix Released
Revision history for this message
Alberto Milone (albertomilone) wrote :

I have tried the updated packages on a fresh installation of Edgy but the problem persists.

Here is the backtrace.

P.S. I'm using this version of the libraries:
~$ sudo aptitude show libwxbase2.6-0Package: libwxbase2.6-0
State: installed
Automatically installed: yes
Version: 2.6.3.2.1.5ubuntu0.1

Revision history for this message
StefanPotyra (sistpoty) wrote :

Alberto, I cannot reproduce this (however in an edgy chroot, adm64). Are you also using 2.6.3.2.1.5ubuntu0.1 of libwxgtk2.6-0?

If so, what did you do to make amule crash?

anyone else still experiencing problems?

Revision history for this message
Alberto Milone (albertomilone) wrote :

Stefan, all I have to do to reproduce the error is to start a new search and then close a tab. Then amule exits.

here's the version I'm using:

:~$ sudo aptitude show libwxgtk2.6-0
Password:
Package: libwxgtk2.6-0
State: installed
Automatically installed: yes
Version: 2.6.3.2.1.5ubuntu0.1
Priority: optional
Section: universe/libs
Maintainer: Ubuntu MOTU Developers <email address hidden>
Uncompressed Size: 7901k
Depends: libatk1.0-0 (>= 1.12.1), libc6 (>= 2.4-1), libesd-alsa0 (>= 0.2.35) |
         libesd0 (>= 0.2.35), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.3.0),
         libgcc1 (>= 1:4.1.1-12), libgl1-mesa-glx | libgl1, libglib2.0-0 (>=
         2.12.0), libglu1-mesa | libglu1, libgtk2.0-0 (>= 2.10.3), libjpeg62,
         libpango1.0-0 (>= 1.14.5), libpng12-0 (>= 1.2.8rel), libstdc++6 (>=
         4.1.1-12), libtiff4, libwxbase2.6-0 (>= 2.6.3.2.1.5ubuntu0.1),
         libx11-6, libxcursor1 (> 1.1.2), libxext6, libxfixes3, libxi6,
         libxinerama1, libxrandr2, libxrender1, zlib1g (>= 1:1.2.1)
Suggests: libgnomeprintui2.2-0

Revision history for this message
StefanPotyra (sistpoty) wrote :

hm... I still couldn't reproduce it in an i386 chroot. To be sure to have a chance to spot it in a chroot at all, I've also tried without the wxwidgets update, which crashed immediately.

Since you've written, that you're using a fresh installation of edgy, are you reusing your home-directory (or the .aMule dir there to be more specific)? If so, could you try to move this away and retry?

Other than that I'm pretty clueless right now :/

Revision history for this message
Alberto Milone (albertomilone) wrote :

Stefan, I moved my .aMule dir and now I can't reproduce the error any more.

I didn't know that I had to use a new .aMule dir.

Thanks

Revision history for this message
StefanPotyra (sistpoty) wrote :

I didn't know this as well, but I wanted to make sure if it's a wxwidgets bug that we didn't fix. Maybe there is still a bug in amule somewhere that you stumbled upon, but that would be a different issue.
Thanks for trying.

Revision history for this message
paranaense (tuliouel) wrote :

I reported this bug to aMule team. Is this acctually somthing for launchpad or for aMule developpers? Below is the URL of the crash I reported with 3 records generated by gdb.
http://www.amule.org/abugs/view.php?id=1106
You shoud check, since the reports were generated folowing the wiki instructions about tracing cashes. (https://wiki.ubuntu.com/Backtrace)

Changed in amule:
status: Invalid → Won't Fix
Revision history for this message
Götz Christ (g-christ) wrote :

I have had the same problem on Gutsy, but since I use this repo <<deb http://www.vollstreckernet.de/debian/ testing amule>> I didn't have the problem any more.

Revision history for this message
alessio rocchi (nihil-00) wrote :

seems absurd to me that this bug is floating around from 2 years now.
it's gross.

Revision history for this message
Martin Pitt (pitti) wrote :

alessio, the bug is supposed to be fixed. Have you installed the current edgy-updates version of all packages?

Revision history for this message
mathieu (ververlenculeur) wrote :

the bug is also in the version 2.2.2 and I'm on Intrepid.

Revision history for this message
persi (xander-stepanov) wrote :

Another one for 2.2.2/Intrepid

Revision history for this message
Emilio Gallego (egallego-babel) wrote :

I happen to get this bug
I'm puzzled as to why people seem to think this bug is fixed with the previous patch.

It seems the issue is the button_release event (of the last tab closing) is called with no cur_tab, and then GTK+ crashes.

See http://www.amule.org/amule/index.php?topic=16254.0 and http://bugzilla.gnome.org/show_bug.cgi?id=477454

Please people with launchpad-foo reassign this to gtk+

Revision history for this message
Emilio Gallego (egallego-babel) wrote :

Three people have it in Intrepid/Amule 2.2.2

Changed in amule:
status: Invalid → Confirmed
Revision history for this message
Oibaf (oibaf) wrote : Re: amule crashes when I close a tab (possible GTK+ bug)

This should be fixed in amule 2.2.3 (not yet in Ubuntu):
http://www.amule.org/wiki/index.php/Changelog_2.2.3

Changed in amule:
status: Confirmed → In Progress
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

This was fixed long time ago. If the bug has reappeared, you should open a new report as it may well be a different issue with the same symptoms.

As for aMule 2.2.3, I've requested a sync in bug 313492.

Changed in amule:
status: In Progress → Fix Released
Changed in amule (Ubuntu):
status: Fix Released → Invalid
status: Invalid → Fix Released
Changed in amule (Mandriva):
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 107 comments or add a comment.