amavisd-new init script does not work cleanly

Bug #997465 reported by Jens on 2012-05-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
amavisd-new (Ubuntu)
Undecided
Unassigned

Bug Description

After Installation I get the following output, it seems the restart script does not find the running amavisd process.

amavisd-new (1:2.6.5-0ubuntu3) wird eingerichtet ...
Creating/updating amavis user account...
dpkg: Warnung: Version »configure« hat falsche Syntax: Versionsnummer beginnt nicht mit einer Ziffer
Starting amavisd: amavisd-new.
amavisd-new-postfix (1:2.6.5-0ubuntu3) wird eingerichtet ...
postconf: warning: spf-policyd_time_limit: unknown parameter
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
 * Stopping Postfix Mail Transport Agent postfix
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
   ...done.
 * Starting Postfix Mail Transport Agent postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: spf-policyd_time_limit=3600s
   ...done.
Stopping amavisd: (not running).
Starting amavisd: The amavisd daemon is already running, PID: [3926]
(failed).
invoke-rc.d: initscript amavis, action "restart" failed.
dpkg: Fehler beim Bearbeiten von amavisd-new-postfix (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Trigger für libc-bin werden verarbeitet ...
ldconfig deferred processing now taking place
Fehler traten auf beim Bearbeiten von:
 amavisd-new-postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is repeatable by calling

~# /etc/init.d/amavis status
 * amavisd is running
~# /etc/init.d/amavis stop
Stopping amavisd: (not running).
~# /etc/init.d/amavis start
Starting amavisd: The amavisd daemon is already running, PID: [4798]
(failed).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: amavisd-new-postfix 1:2.6.5-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Thu May 10 05:19:35 2012
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-color
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: amavisd-new
UpgradeStatus: Upgraded to precise on 2012-05-04 (5 days ago)

Jens (jens-launchpad-net) wrote :
Jens (jens-launchpad-net) wrote :

Removing "--name ${DAEMONNAME}" from the "STOP" variable in the initscript fixes this issue, but this is probably not an intended way of fixing this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amavisd-new (Ubuntu):
status: New → Confirmed

I tried followings :

<<<<<<<<<

apt-get update && apt-get upgrade ---
and after words i got this massage :

Stopping amavisd: (failed).
invoke-rc.d: initscript amavis, action "restart" failed.
dpkg: Fehler beim Bearbeiten von amavisd-new-postfix (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 amavisd-new-postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@mastermind:~#

>>>>>>>>>>>>

do you have any ideas how to clear this bug ?? - i need your support - thanks a lot !!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers