mp3 installation script crashes and/or hangs

Bug #58617 reported by Richard Johnson on 2006-09-02
106
Affects Status Importance Assigned to Milestone
Amarok
Invalid
High
amarok (Ubuntu)
High
Jonathan Riddell
Gutsy
High
Jonathan Riddell

Bug Description

On a fresh Edgy install, Knot2 + recent updates. You click play, and the window stating you need to install "MP3 Support" pops up. If you select "NO", the KDESU popup comes up asking for your password. If you select "NO" to this as well, you will get a 3rd and final popup stating you have successfully installed MP3 support. I have confirmed it on 2 machines sitting side by side, you can trust me Brandon ;) Thanks bud.

EDIT: mp3 support still crashes and/or hangs with 1.4.5-0ubuntu6 in feisty for many people.

indeed.

Changed in amarok:
status: Unconfirmed → Confirmed
Ketil Malde (ketil-ii) wrote :

I'll just add that this happens on Dapper as well. (Amarok 1.4.3/KDE 3.5.2, from amarok Version: 2:1.3.9-0ubuntu4. That is - apt-cache show amarok gives that version, but dpkg -s reports 2:1.4.3-0ubuntu8~dapper1 as installed? How'd that happen? I even removed it, apt-get update'd, and reinstalled. This prevents amarok-arts to be installed, it depends on the ubuntu4 version. On the other hand, so do amarok-xine and amarok-engines, but they install all right. Go figure.)

Furthermore, the amarok package claims there is an amarok-gstreamer engine, but I can't find it.

huntermix (sm01p) wrote :

Same here, tried to install mp3 support, an error box appeared and then another one telling me "installation successful"
Also in Kubuntu i only have xine engine support even if i install amarok-engines. I would like to have the option to use gstreamer too.

David Johnson (dj-david-web) wrote :

I'm seeing a similar issue. I click no to the question about installing MP3 support, then no to a question asking if I want to enable multiverse, then amarok says that there was an error installing MP3 support. It then promptly goes into a CPU loop until I kill it.

The is in a clean Edgy install on x86_64.

Andrew Ash (ash211) wrote :

The install mp3 support dialog is activated by running /usr/lib/amarok/install-mp3

Basically all that script does is install libxine-extracodecs from multiverse. Make sure you have multiverse enabled from https://help.ubuntu.com/community/Repositories/Kubuntu. Then install libxine-extracodecs from adept and restart Amarok and mp3 support should work just fine.

To fix the dialog making decisions contrary to what you've told it, someone with more coding experience than me will have to play around with that file.

Andrew Ash (ash211) wrote :

It looks like changes in Amarok 1.4.5-0ubuntu6 in feisty have made some mp3 install script related fixes. Could someone please test in feisty if this is still a problem?

Changed in amarok:
assignee: nobody → ash211

Tested with herd 5:
It seems that half the time you say no it freezes amarok. The other half of the time it works and states that the xine engine can't play the mp3 which is correct.

Andrew Ash (ash211) wrote :

Let's confirm what's going on. Can you please provide the output of `apt-cache policy amarok` and `cat /etc/apt/sources.list` ?

amarok policy

sources.list

Andrew Ash (ash211) wrote :

Pascal: it looks like you're using Amarok 1.4.5-0ubuntu5 instead of -0ubuntu6, which has mp3 script fixes. Try upgrading and then installing mp3 support again. If it still doesn't work, let me know step by step what you did and we'll try to figure out what's going on here :)

ok. So I booted herd 5 and upgraded amarok to 0ubuntu6.
The first time I pressed the mp3, amarok just stood there, and I waited for quite a while. So I tried again, and this time(I clicked no) amarok froze. The third time it closed amarok normally after I clicked no.

apt-cache policy amarok
amarok:
  Installed: 2:1.4.5-0ubuntu6
  Candidate: 2:1.4.5-0ubuntu6
  Version table:
 *** 2:1.4.5-0ubuntu6 0
        500 http://archive.ubuntu.com feisty/main Packages
        100 /var/lib/dpkg/status

Andrew Ash (ash211) wrote :

So sometimes it hangs and sometimes it crashes. Looks like we're going to need someone more experienced to keep going from here to fix it.

Maybe observing Amarok command line output might provide a clue here?

Changed in amarok:
assignee: ash211 → nobody
Andrew Ash (ash211) wrote :

"High: Has a moderate impact on a large portion of Ubuntu users" -- https://wiki.ubuntu.com/Bugs/Importance

description: updated
Changed in amarok:
importance: Undecided → High
Andrew Ash (ash211) wrote :

To everyone experiencing the mp3 installation script crash/hang:

Please try to provide crash reports if Amarok crashes on trying to install mp3 from within Amarok. Also provide a detailed description of your system, the steps you took and the buttons you pressed to try to install mp3. Thanks

bertoldic (bertoldic) wrote :

Ok, when I try to listen an mp3 amarok crashes immediately or let me see the do you want to install mp3 support ? And I can't press the button cause the button doesn't work:It's all stopped with the status (in Amarok) creating playlist.
I have to manually install libxine1-ffmpeg and after that it works without any further problem.
This problem was not present in the just previous ubuntu version of amarok.

Shlomi (shlomivaknin) wrote :

I have the same problem too, I use feisty beta

% apt-cache policy amarok
amarok:
  Installed: 2:1.4.5-0ubuntu6+medibuntu1
  Candidate: 2:1.4.5-0ubuntu6+medibuntu1
  Version table:
 *** 2:1.4.5-0ubuntu6+medibuntu1 0
        500 http://medibuntu.sos-sts.com feisty/free Packages
        100 /var/lib/dpkg/status
     2:1.4.5-0ubuntu6 0
        500 http://fr.archive.ubuntu.com feisty/main Packages

if there is any more information you need, or any workaround for the time being, please let me know.

Shlomi

Andrew Ash (ash211) wrote :

Shlomi, packages with medibuntu in the name should generally be filed against medibuntu, ( https://bugs.launchpad.net/medibuntu/+filebug ) but I think since this one's much more prevalent, it doesn't seem like a medibuntu issue.

Aaron Knapp (aknapp-gmail) wrote :

Here is the crash log: http://paste.ubuntu-nl.org/13714/

Andrew Ash (ash211) wrote :

That log attached, in case pastebin drops it.

Andrew Ash (ash211) wrote :

As jazzy_ said, a workaround to install mp3 would be to install libxine-extracodecs with either apt-get, adept, add/remove programs or synaptic, etc.

Yes, now it playes fine,
thank you!

Shlomi

On 4/17/07, Andrew Ash <email address hidden> wrote:
>
> As jazzy_ said, a workaround to install mp3 would be to install libxine-
> extracodecs with either apt-get, adept, add/remove programs or synaptic,
> etc.
>
> --
> mp3 installation script crashes and/or hangs
> https://bugs.launchpad.net/bugs/58617
> You received this bug notification because you are a direct subscriber
> of the bug.
>

BenSimpson (csu16451) wrote :

"Please try to provide crash reports if Amarok crashes on trying to install mp3 from within Amarok. Also provide a detailed description of your system, the steps you took and the buttons you pressed to try to install mp3. Thanks"

I unfortunately cannot recreate the condition that triggered Knotify with the crash output.

My system:
AMD Athlon X2
Asus M2N-MX
Creative Live 5.1
Clean installation of Feisty Fawn (4/19/2007)

I installed Amarok via the "Application" -> "Add/Remove" packages. After a successful installation, I completed the setup by pointing to a folder with music. When it fails, I force the task to end and then restart Amarok. The results of the time I ran it are below:

1st time: Amarok crashes with Knotify message
2nd time: Two message - one about disabling arts output, and another about installing MP3 support (which isn't responding to clicks)
3rd time: Amarok hangs with half drawn installing MP3 support dialogue box.
4th time: I manually ran /usr/lib/amarok/install-mp3 as several forum topics recommended
5th time: Amarok works

hencke (hencke) wrote :

My system:
AMD Sempron 64
Asus M2NPV-MX
Install media: Kubuntu Feisty Fawn 7.04 Desktop AMD64 (final)
Modification made only through Adept such as:
uninstalled Kexi
installed ubuntu-restricted-etras, nvidia-glx, firefox, thunderbird, etc. (but nothing like easyubuntu)

I can't exactly remember what happened during the first times (something like this anyway, but additionally I also might have gotten a KNotify message), but when I try to add a mp3 ("Playlist"->"Add media") then amarok hangs after the "No MP3 Support" dialog comes up.

I can easily reproduce this if needed.

B2DNZ (parvez-a-khan) wrote :

Hi Guys

I have (actually) had the same issue on Feisty x86. The install Mp3 support prompt would crash. As suggested I installed "libxine-extracodecs" from synaptic package manager and upon restarting Amarok the files started playing fine. Hope that helps for those.

B2DNZ

Kieran Hogg (xerosis) wrote :

Just tried opening an mp3 in gutsy, it gets to the dialog with 'mp3 support has been installed, amarok will need to be restarted', when you confirm, it then hangs amarok.

let's get someone to look into this, and not release gutsy with this. tentatively milestoning it.

Kieran Hogg (xerosis) wrote :

Added the upstream bug in the hope of more activity.

Changed in amarok:
status: Unknown → Unconfirmed
Changed in amarok:
assignee: nobody → jr
Kovarththanan Rajaratnam (krj) wrote :

Hello,

I'm also seing this bug. Amorak simply freezes after I've accepted to install MP3 support. However running /usr/lib/amorak/install-mp3 fixes the problem.

My system:
HP Compaq nc6000
Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
Clean install (7/17-2007)

I have the same bug, i think that it can be better to remove the autoinstaller and replace it with an advertisement that say "install lib-xine-extracodecs with sudo apt-get install lib-xine-extracodecs or you favorite packages manager" if you have no choice .

upstream has now fixed this, uploading to gutsy.

amarok (2:1.4.7-0ubuntu3) gutsy; urgency=low

  * Added kubuntu_05_utf8_to_mtp_devices_fix.diff from upstream. (KDE
    Bug #139722)
  * Added kubuntu_06_fix_amarok_freeze_installing_mp3.diff from
    upstream. (KDE Bug #147126, LP: #58617) Thanks markey for fixing
    this!
  * Added amarok Suggests: libxine1-ffmpeg. (LP: #134741)
  * Added kubuntu_07_gnome_multimedia_keys.diff, a script that lets the
    multimedia keys in GNOME work in amarok. (LP: #87299)
  * Use adept_batch update in install-mp3 not apt-get update

 -- Sarah Hobbs <email address hidden> Sat, 01 Sep 2007 00:11:20 +1000

Changed in amarok:
status: Confirmed → Fix Released
hencke (hencke) wrote :

The script seems to work fine in Gutsy (i386), should amaroK status be set to "Fix released"?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yes.

 status fixreleased

hencke wrote:
> The script seems to work fine in Gutsy (i386), should amaroK status be
> set to "Fix released"?
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHKydz7/o1b30rzoURAr9HAJ4jTpaWnlUDeH8nzzFeC37uMWkLcQCgvQU9
RlTNrRI451k7JAiT24Mr6Yc=
=uNb4
-----END PGP SIGNATURE-----

Changed in amarok:
status: New → Invalid
Changed in amarok:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.