Amarok needs phonon-xine-backend to output sound

Bug #349847 reported by Georg Neis on 2009-03-27
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

I've just upgraded to Jaunty. When I start amarok it opens up fine but at the top of the screen the following message pops up:

-----
Phonon: KDE's Multimedia Library
The audio playback device HDA Intel (AD198x Analog) does not work.
Failing back to default.
-----

When I try to play a file now, I don't get any audio output and at some point amarok says "Too many errors encountered in playlist. Stopped playback."

I can play files fine using Totem or VLC.

Georg Neis (gn) wrote :

After installing phonon-backend-xine, the message turns into "[...] Falling back to PulseAudio", but sound works now.

Etienne Lepercq (e-guepe) wrote :

I have the same bug : I tried installing phone-backend-xine but still no sound in amarok.
I don't have any error provided by Amarok, but asking for a track to be played toggles play, then stop in the second.

I have no clue to where is the bug, but it is in the amarok package for sure.

I am using Jaunty x86_64 up to date and an Intel HDA. All other applications (totem, vlc, mplayer, ekiga) have microphone/playback working.
I am using ALSA and not pulseaudio, but when upgrading I was using pulseaudio and the bug was the same (not related to ALSA nor pulseaudio then).

Ask for anything else.

Safwat Saber (egy-1987) wrote :

I've the same problem too after upgrading from 8.10

Wei-Yee Chan (chanweiyee) wrote :

I encountered the same problem.

Try this: http://chanweiyee.blogspot.com/2009/04/ubuntu-904-amarok-2-sound-problem.html

It worked for me.

Etienne Lepercq (e-guepe) wrote :

I tried : does not work.
I installed systemsettings of KDE4 : tests of my audio card through systemsettings WORKS : I am not using pulseaudio by the way.
But still, with only xine backend, systemsettings manages to output nice sounds, but not amarok :-(

I tried uninstalling/reinstalling amarok, still nothing...

Etienne Lepercq (e-guepe) wrote :

I tried playing ONE track in amarok with debug output in console. Attached file is the debug output.

Etienne Lepercq (e-guepe) wrote :

SOLVED : I installed libxine-ffmpeg and it works.
amarok package should have libxine-ffmpeg as a dependancy, no ?

What kind of solution could be done, I mean automatically ? When Jaunty will be released, much more users may have this bug.

Myriam Schweingruber (myriam) wrote :

Etienne: it is unlikely Kubuntu will ship mp3 codecs for the default installation. There are licensing issues with those in many countries, so the user has to install those themself. One solution could be the "ugly" package of gstreamer where Canonical offers to pay the license fee, but unfortunately the gstreamer sound engine is to buggy for Amarok right now.

Dragoneyes (stiu) wrote :

I had the same problem.
I used amarok 2 with Intrepid adding same repositories, and after a message "phonon, Pnp usb audio dosen't work, falling back to default" it worked fine. After upgrading to Jaunty, no message appear, and no audio on amarok (the track doesn't start to be played, and no on screen display show the track information, but down on the right, in the amarok gui, is showed the current track). The solution posted before (http://chanweiyee.blogspot.com/2009/04/ubuntu-904-amarok-2-sound-problem.html ) worked for me.

Alessio (alessioballarin) wrote :

I have the same problem, No sound!

Seth (bugs-sehe) wrote :

Same problem, dist-upgrade from intrepid; no sound, install phonon-xine-backend solved it. Thanks

pyutaros (pyutaros) wrote :

Also installed phonon-backend-xine and sound now works.

Alessio (alessioballarin) wrote :

OK I installed phonon and everything works.

I'm using OSS v4. I installed phonon-xine-backend and it started opening the mp3 files ( I can see the progress bar moving ), but there is still no sound.

OSS HOWTO:
1) Download this file: [URL="http://www.fileupyours.com/view/77985/libphonon.conf"]http://www.fileupyours.com/view/77985/libphonon.conf[/URL]
2) Put it in:~/.config/kde.org/ (where ~/ means your home directory) You may need to create the kde.org directory
3) If you don't have phonon-backend-xine install it.
sudo apt-get install phonon-backend-xine
4) Restart Amarok 2 and have fun.

Plenty of people confirm this, me included...

Changed in amarok (Ubuntu):
status: New → Confirmed
jerkyjones (ben-napper) wrote :

The link in Dragoneyes post above worked for me.

chuse (josemiotto) wrote :

Only the solution of Dimitar works for me.
Thank you very much!!!

After upgrade to 9.04 it was sufficient to install phonon-backend-xine and amarok2 played sound fine.
After one of updates, amarok at start asked me something like:
"one of sound devices has desappeared. Do you want amarok(or KDE?) to forget about it permanently?"
I answered "yes".
After that only the solution of Dimitar Krasimirov Boichev worked for me.
Thans Dimitar!

You are all welcome :)
Here is the file again if something happens to the file in http://www.fileupyours.com/.

After installing phonon-backend-xine, everything works fine. Btw, it could be included in the package of amarok, don't you think?
Thanks.

Ali Sattari (corelist) wrote :

Had the same problem, installed phonon-xine-backend, removed phonon-gstreamer-backend and used Dimitar Krasimirov Boichev config file, it's allright now.

John Nelson (john-nelson2) wrote :

I had a fresh install of Jaunty and had this problem too.... phonom-backend-xine was already installed. Tried phonom-backend-gstreamer, but no help. What did the trick for me was to the systemsettings package for KDE, then go into Multimedia > Music. I selected PulseAudio, and clicked the "Prefer" button until it was on top. Now no errors and audio works in Amarok.

Nik (nsadaran) wrote :

Hi There,

I had the same issue with Amarok. I installed the phonon package, which fixed Amarok but made totem and mplayer play back videos at 1 frame per second. When I uninstalled phonon, totem started working again but I lost sound playback in Amarok. Anybody else seeing a similar problem?

Myriam Schweingruber (myriam) wrote :

To Nik,
you absolutely need Phonon for Amarok and Dragon Player. Both applications send sound (and video for the latter) through that layer.
Make sure to also install and use the phonon-xine-backend, as gstreamer is not reliable.
Also, do not use Pulseuadio with the Xine backend, this is known to cause problems. If you are a KDE user, I strongly suggest you remove (purge) pulseaudio, as there is aboslutely no need for it.

To John,

well, then you are amongst the happy few not bothered by Pulseaudio. Could be related to your hardware, but it is certainly not the recommended way to go for KDE applications, as none of those uses Pulseaudio.

Eddie Dunn (eddie-dunn) wrote :

For me it started working after I installed libxine1-ffmpeg as Etienne suggested.

As it is now, it seems the default package for Amarok 2 is broken.

Leonardo Camargo (flueedo) wrote :

Ubuntu 9.04 here, same problem.
Installing phonon-backend-xine and removing phonon-backend-gstreamer solved it for me!

Here libxine1-ffmpeg was already installed.

Eddie Dunn (eddie-dunn) wrote :

I tested removing phonon-backen-xine and libxine1-ffmpeg and uninstalling/reinstalling Amarok.

Reinstalling Amarok got me the package phonon-backend-xine, but not libxine1-ffmpeg. Consequently, the sound was not working and Amarok was just skipping through my playlist. After installing libxine1-ffmpeg sound started working again.

I don't know why, but apparently libxine1-ffmpeg is needed (for me, at least) to be able to playback audio, and should be included as a dependency when installing Amarok.

I'm attaching the terminal output for when I tried running a freshly installed instance of Amarok.

libxine1-ffmpeg adds support for mp3 files.

Eddie Dunn (eddie-dunn) wrote :

In Amarok only? How come I was able to play mp3's in VLC, Mplayer and Totem before installing libxine1-ffmpeg? (I got video/audio codecs by running "sudo apt-get install ubuntu-restricted-extras" after I installed Ubuntu 9.04 x86_64)

ubuntu-restricted-extras has the gstreamer plugins (including that for mp3)
and libxine1-ffmpeg is a plugin for xine and since amarok is using phonon witch is using xine ( phonon-backend-xine ) you need the xine mp3 plugin to be able to play mp3s

questforsound (marcin-madrzyk) wrote :

I'm fairly new to Ubuntu/Amarok and nearly gave up trying to get Amarok 2 to play sound in Ubuntu 9.04.
After reading these comments I installed phonon-backend-xine and am now very happily listening to my mp3s : )
Thanks to everybody who contributed!!!
Vorsprung durch Ubuntu!

Andrew Ash (ash211) on 2009-07-19
summary: - no sound in amarok
+ Amarok needs phonon-backend-xine to output sound
summary: - Amarok needs phonon-backend-xine to output sound
+ Amarok needs phonon-xine-backend to output sound
r-simecek (roman-simecek) wrote :

For me it help to install the package libxine1-ffmpeg on Ubuntu 9.10

Angel Negron (angel-negron) wrote :

This quickly solved it for me. Thanks

******************************************************************
Etienne Lepercq wrote on 2009-04-15: #7

SOLVED : I installed libxine-ffmpeg and it works.
amarok package should have libxine-ffmpeg as a dependancy, no ?

What kind of solution could be done, I mean automatically ? When Jaunty will be released, much more users may have this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers