Bug 188444 – playback is unreliable and broken in Amarok and JuK using phonon gstreamer backend

Bug #351319 reported by Simon Ruggier on 2009-03-30
104
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Phonon
Invalid
Medium
phonon-backends (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Thomas Horsten

Bug Description

Binary package hint: phonon-backend-gstreamer

When running Amarok or JuK with only the gstreamer backend of phonon installed,
I get a popup (shown in the attached screenshot) at startup, and playback only
sometimes works. When playback fails, there are no errors printed to stdout,
and no indication of what could be wrong in the UI. Amarok sometimes displays a
box saying that there have been too many errors and that it is stopping
playback, while JuK seems to do nothing. Both cases are confusing for the user.

With the Xine backend installed, I've had no similar problems so far.

Also note that in systemsettings, the test button works, and yet these sound
problems occur nevertheless.

Description: Ubuntu jaunty (development branch)
Release: 9.04

Simon Ruggier (simon80) wrote :
Changed in phonon:
status: Unknown → New

This problem seems similar to mine, on Kubuntu Jaunty and a HDA Intel ALC861.
When I use Gstreamer Phonon engine, Amarok doesn't play anything at all, although other apps do.

When I switch to the Xine backend (the default one in Kubuntu) from systemsettings panel, then Amarok plays. But then, Amarok sound volume doesn't follow the KMix sound volume. By experimenting (Xine backend) I found out that Amarok "follows" the "Front" channel while KMix gives me only the PCM channel (the Front channel can only be muted, there's no apparent way to adjust it).

I found a similar bug report in KDE bugzilla, but the developers say it's a Phonon issue. I' m not sure about that, since Amarok2 plays OK in Manriva 2009.1.
See: https://bugs.kde.org/show_bug.cgi?id=189755

I run Kubuntu Jaunty with these packages installed:
amarok 2:2.0.2mysql5.1.30-0ubuntu3
amarok-common 2:2.0.2mysql5.1.30-0ubuntu3
phonon-backend-gstreamer 4:4.3.1-0ubuntu3
phonon-backend-xine 4:4.3.1-0ubuntu3
libxine1-ffmpeg 1.1.16.3-0ubuntu1
gstreamer0.10-fluendo-mp3 0.10.7.debian-1
gstreamer0.10-ffmpeg 0.10.6.2-1ubuntu2
gstreamer0.10-alsa 0.10.22-5

King Oleg (kingoleg) wrote :

>>With the Xine backend installed, I've had no similar problems so far.

Can you say how change playback backend in gnome to make amarok works?

King Oleg (kingoleg) wrote :

Oh, I found that sudo apt-get install phonon-backend-xine helped

pinzia (pinzia) wrote :

same problem with karmic

Changed in phonon (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
ioggstream (rpolli) wrote :

installing libxine1-ffmpeg solved on 9.04

pinzia (pinzia) wrote :

install libxine1 isn't a solution for gstreamer backend, ma xine-backend.

Thomas Horsten (thomas-horsten) wrote :

In Karmic: Installing phonon-backend-xine didn't help, but after also installing libxine1-ffmpeg then it works.

Thomas Horsten (thomas-horsten) wrote :

May I suggest that as a temporary fix libxine1-ffmpeg is added as a dependency to the packages with this problem..

affects: phonon (Ubuntu) → phonon-backends (Ubuntu)
Flavio Tordini (zarlino) wrote :

I can confirm this. The bug is not Amarok specific, it applies to any Phonon app using the Gstreamer backend.

Changed in phonon:
status: New → Confirmed
Changed in phonon:
status: Confirmed → Unknown
Changed in phonon:
status: Unknown → Fix Released
Changed in phonon:
status: Fix Released → Confirmed
Changed in phonon:
status: Confirmed → Unknown
Changed in phonon:
importance: Unknown → Medium
Changed in phonon:
status: Unknown → Invalid
Chris Samuel (chris-csamuel) wrote :

I'm not sure if I have the same issue, but with Kubuntu Natty 11.04 beta the gstreamer backend produces no sound at all, only the Xine backend works properly. My audio device is:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

referred to as "Intel HDA (ALC889A Analog)" in the Multimedia->Phonon settings.

Simon Ruggier (simon80) wrote :

It's probably not the same problem, given the differences in software versions and symptoms. You'll also probably get more attention if you file a separate bug.

Myriam Schweingruber (myriam) wrote :

Chris: you are using a very outdated setup, the xine backend is deprecated upstream since over 3 years now, you really should consider an upgrade to a more recent Amarok and KDE version, 11.04 is not exactly new and has reached its End of Life on October 28, 2012. I suggest you use version 13.04 which is the current release.

Myriam Schweingruber (myriam) wrote :

the release has reached its EOL on October 28, 2012

Changed in phonon-backends (Ubuntu):
status: Triaged → Invalid
Chris Samuel (chris-csamuel) wrote :

Hi Myriam, my last comment was from 2011, using the beta of what was to be 11.04. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.