Ubuntu

Wikipedia page lookup should load the right page

Reported by Wouter Stomp on 2005-09-16
8
Affects Status Importance Assigned to Milestone
Amarok
Won't Fix
Wishlist
amarok (Ubuntu)
Wishlist
Unassigned

Bug Description

The wikipedia lookup function should load the right page. For a band, e.g.
Queen, it should first look for 'Queen (band)' and only if that does not exist
it should load 'Queen'. Same goes for albums, songs, etc.

Caroline Ford (secretlondon) wrote :
Andrew Ash (ash211) wrote :

This has also been briefly discussed on the amarok wiki: http://amarok.kde.org/wiki/Wikipedia_Tab_bugs

Changed in amarok:
status: Unknown → Unconfirmed
Changed in amarok:
status: Unconfirmed → Rejected
Andrew Ash (ash211) wrote :

It appears that upstream won't be fixing this bug, I'm guessing since there are so many corner cases.

1.4.5 is expected to act much better in this regard for English speaking users, since it will try "Tool (band)" before "Tool" Part of the problem is that different languages will have different suffixes than "band".

See the upstream bug report for more information.

Changed in amarok:
status: Unconfirmed → Confirmed
Andrew Ash (ash211) wrote :

I'm using a pretty recent SVN build of Amarok ( <3 days) and I can confirm that it does the correctly behavior of searching for 'Queen (band)' before 'Queen'. I'm marking Fix Committed, since Amarok 1.4.5 will have this change included.

Let me know if it doesn't work once 1.4.5 is released. Thanks.

Changed in amarok:
status: Confirmed → Fix Committed
Andrew Ash (ash211) wrote :

Amarok 1.4.5 has been released with this change in both edgy and feisty. Yay!

http://kubuntu.org/announcements/amarok-1.4.5.php

Changed in amarok:
status: Fix Committed → Fix Released
Changed in amarok:
status: Invalid → Won't Fix
Changed in amarok:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.