Re: Heads-up: small xine-lib transition in hardy

Bug #159338 reported by Reinhard Tartler on 2007-11-01
8
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned
codeine (Ubuntu)
Undecided
Emmet Hikory
gimageview (Ubuntu)
Undecided
Emmet Hikory
kaffeine (Ubuntu)
Undecided
Unassigned
kde4base (Ubuntu)
Undecided
Unassigned
kdemultimedia (Ubuntu)
Undecided
Unassigned
klear (Ubuntu)
Undecided
Reinhard Tartler
kmediafactory (Ubuntu)
Undecided
Jonathan Davies
kmplayer (Ubuntu)
Undecided
Jonathan Davies
lsongs (Ubuntu)
Undecided
Emmet Hikory
miro (Ubuntu)
Undecided
Unassigned
oxine (Ubuntu)
Undecided
Emmet Hikory
pornview (Ubuntu)
Undecided
Emmet Hikory
pyxine (Ubuntu)
Undecided
Unassigned
qdvdauthor (Ubuntu)
Wishlist
Unassigned
quark (Ubuntu)
Undecided
Emmet Hikory
totem (Ubuntu)
Undecided
Unassigned
ultrastar-ng (Ubuntu)
Undecided
Unassigned
xfmedia (Ubuntu)
Undecided
Lionel Le Folgoc
xine-plugin (Ubuntu)
Undecided
Daniel T Chen
xine-ui (Ubuntu)
Undecided
Unassigned

Bug Description

"Emmet Hikory" <email address hidden> writes:

> Am Fritag, den 2.11.2007, schrieb Reinhard Tartler:
>> Btw, do we currently have some sort of transition tracker? If not, I'd
>> suggest to have a malone bug with a bugtask for every package (which
>> means ~20 tasks). We can track progress this way by using
>> debian/changelog)
>
> I'd like to second the use of many-tasked bugs in Malone to address
> these, for both easier tracking and easy changelog updates.

Okay, I'm trying out the malone way for this transition as guinea
pig. This is clearly not a change in workflow (yet). If you think it is
a good idea, then please help to close the bug by fixing the packages
and upload it mentioning this bug in debian/changelog.

The list of packages have been caluculated by the following means:

packages=`apt-cache rdepends libxine1 | sort | uniq | grep "^ " `
srcpackages=`for p in $packages; do apt-cache showsrc $p | \
             awk '/^Package:/ {print $2}'; done | sort | uniq`
echo $srcpackages

The list below has been 'manually' tuned.

  affects ubuntu/amarok
  affects ubuntu/codeine
  affects ubuntu/gimageview
  affects ubuntu/kaffeine
  affects ubuntu/kde4base
  affects ubuntu/kdemultimedia
  affects ubuntu/klear
  affects ubuntu/kmediafactory
  affects ubuntu/kmplayer
  affects ubuntu/miro
  affects ubuntu/oxine
  affects ubuntu/pornview
  affects ubuntu/pyxine
  affects ubuntu/qdvdauthor
  affects ubuntu/quark
  affects ubuntu/totem
  affects ubuntu/ultrastar-ng
  affects ubuntu/xfmedia
  affects ubuntu/xine-plugin
  affects ubuntu/xine-ui

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

klear (0.6.0-0ubuntu2) hardy; urgency=low

  * Adjust dependencies for new xine packages, LP: #159338

 -- Reinhard Tartler <email address hidden> Thu, 01 Nov 2007 15:53:26 -0400

Changed in klear:
status: New → Fix Released
Changed in xfmedia:
assignee: nobody → mrpouit
Lionel Le Folgoc (mrpouit) wrote :

xfmedia (0.9.2-0ubuntu3) hardy; urgency=low

  * debian/control:
    - b-ds updated & cleaned
    - Homepage, XS-Vcs-Bzr & XS-Vcs-Browser fields added
    - Adjust dependencies for new xine packages. (LP: #159338)
  * debian/compat: bump to 5.

 -- Lionel Le Folgoc <email address hidden> Fri, 02 Nov 2007 17:25:15 +0100

Changed in xfmedia:
status: New → Fix Released
Emmet Hikory (persia) on 2007-11-03
Changed in codeine:
assignee: nobody → persia
status: New → In Progress
Jonathan Davies (jpds) on 2007-11-03
Changed in kmediafactory:
assignee: nobody → jpatrick
Emmet Hikory (persia) wrote :

codeine (1.0.1-3.dfsg-2ubuntu1) hardy; urgency=low

  * Update dependencies for xine-lib transition (LP: #159338)
  * Set Ubuntu Maintainer

 -- Emmet Hikory <email address hidden> Sat, 03 Nov 2007 19:40:09 +0900

Changed in codeine:
status: In Progress → Fix Released
Jonathan Davies (jpds) wrote :

kmediafactory (0.5.2-0ubuntu2) hardy; urgency=low

  * Adjust dependencies for new xine packages. (LP: #159338)

 -- Jonathan Patrick Davies <email address hidden> Sat, 3 Nov 2007 11:54:45 +0100

Changed in kmediafactory:
status: New → Fix Released
Emmet Hikory (persia) on 2007-11-03
Changed in gimageview:
assignee: nobody → persia
status: New → In Progress
Jonathan Davies (jpds) on 2007-11-03
Changed in kmplayer:
assignee: nobody → jpatrick
status: New → In Progress
Emmet Hikory (persia) wrote :

gimageview (0.2.27-1ubuntu1) hardy; urgency=low

  * Update dependencies for xine-lib transition (LP: #159338)
  * Set Ubuntu Maintainer

 -- Emmet Hikory <email address hidden> Sat, 03 Nov 2007 11:08:29 +0000

Changed in gimageview:
status: In Progress → Fix Released
Emmet Hikory (persia) on 2007-11-03
Changed in klear:
assignee: nobody → siretart
Emmet Hikory (persia) on 2007-11-03
Changed in oxine:
assignee: nobody → persia
status: New → In Progress
Emmet Hikory (persia) on 2007-11-04
Changed in pornview:
assignee: nobody → persia
status: New → In Progress
Emmet Hikory (persia) wrote :

pornview (0.2pre1-7ubuntu1) hardy; urgency=low

  * Update dependencies for xine-lib transition (LP: #159338)
  * Set Ubuntu Maintainer

 -- Emmet Hikory <email address hidden> Sun, 04 Nov 2007 00:52:14 +0000

Changed in pornview:
status: In Progress → Fix Released
Emmet Hikory (persia) on 2007-11-04
Changed in quark:
assignee: nobody → persia
status: New → In Progress
Emmet Hikory (persia) wrote :

From a quick look at pyxine, the correct dependencies of python-pyxine are not clear, given that one could write either an X or console binding. The only reverse dependency of python-pyxine is lsongs. I see two options, and encourage someone more familar with python or xine to select one (or suggest something preferable)

A) Add libxine1-x | libxine1-console | libxine1 (<< 1.1.8-2) to pyxine-xine dependencies
B) Add libxine1-x to lsongs dependencies & nothing to pyxine-xine

Changed in pyxine:
status: New → Incomplete
Jonathan Davies (jpds) wrote :

kmplayer (1:0.10.0a-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes:
    - Ubuntu maintainer spec.
    - kmplayer-base instead of kmplayer-common.
    - kmplayer-konq-plugin instead of kmplayer-plugin.
    - Added kubuntu_ patches to series.
    - No overrides.
    - Remove 10_xine_default_player.diff - done by kubuntu_01_kmplayerrc.diff.
    - Drop 12_remove_audio_mimetypes and kubuntu_04_real_mimetype - applied
      upstream.
    - docbook2x dep for docbooks.
  * New upstream release. (LP: #131620)
  * Adjust kmplayer's xine deps for new packages. (LP: #159338)
  * Bumped Standards-Version to 3.7.2.2.
  * Updated kmplayer.1.docbook.
  * New Homepage field location.
  * Drop kubuntu_03_no_audio_mimetypes - applied upstream.
  * Drop kubuntu_05_gxx32 - changed upstream.
  * Remove quilt patch system.
  * And drop build dep on quilt.

 -- Jonathan Patrick Davies <email address hidden> Sat, 03 Nov 2007 12:26:24 +0100

Changed in kmplayer:
status: In Progress → Fix Released

Emmet Hikory <email address hidden> writes:

>>From a quick look at pyxine, the correct dependencies of python-pyxine
> are not clear, given that one could write either an X or console
> binding. The only reverse dependency of python-pyxine is lsongs. I see
> two options, and encourage someone more familar with python or xine to
> select one (or suggest something preferable)
>
> A) Add libxine1-x | libxine1-console | libxine1 (<< 1.1.8-2) to pyxine-xine dependencies
> B) Add libxine1-x to lsongs dependencies & nothing to pyxine-xine

My current guess is that we should go with option B. I've CC'ed the
debian pyxine maintainer in this email.

Jaldhar, what are your plans regarding the pyxine package in Debian?

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Jaldhar (jaldhar) wrote :

On Sun, 4 Nov 2007, Reinhard Tartler wrote:

> Emmet Hikory <email address hidden> writes:
>
>>> From a quick look at pyxine, the correct dependencies of python-pyxine
>> are not clear, given that one could write either an X or console
>> binding. The only reverse dependency of python-pyxine is lsongs. I see
>> two options, and encourage someone more familar with python or xine to
>> select one (or suggest something preferable)
>>
>> A) Add libxine1-x | libxine1-console | libxine1 (<< 1.1.8-2) to pyxine-xine dependencies
>> B) Add libxine1-x to lsongs dependencies & nothing to pyxine-xine
>
> My current guess is that we should go with option B. I've CC'ed the
> debian pyxine maintainer in this email.
>
> Jaldhar, what are your plans regarding the pyxine package in Debian?
>

Actually, I am slowly in the process of orphaning lsongs and all its
dependencies. I am willing to fix all outstanding bugs first though.

--
Jaldhar H. Vyas <email address hidden>
La Salle Debain - http://www.braincells.com/debian/

Based on model B) Add libxine1-x to lsongs dependencies & nothing to python-pyxine, the pyxine task doesn't need an action.

Changed in pyxine:
status: Incomplete → Invalid
Changed in lsongs:
assignee: nobody → persia
status: New → In Progress
Emmet Hikory (persia) wrote :

quark (3.21-3.3ubuntu1) hardy; urgency=low

  * Update dependencies for xine-lib transition (LP: #159338)
  * Set Ubuntu Maintainer

 -- Emmet Hikory <email address hidden> Sun, 04 Nov 2007 01:32:57 +0000

Changed in quark:
status: In Progress → Fix Released
Emmet Hikory (persia) wrote :

lsongs (0.2.46-1ubuntu1) hardy; urgency=low

  * Update dependencies for xine-lib transition (LP: #159338)
  * Set Ubuntu Maintainer

 -- Emmet Hikory <email address hidden> Mon, 05 Nov 2007 01:04:45 +0900

Changed in lsongs:
status: In Progress → Fix Released
Chris Halse Rogers (raof) wrote :
Download full text (4.3 KiB)

miro (1.0-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable (LP: #162310). Remaining Ubuntu changes:
    + debian/control:
      - libxul-dev -> firefox-dev
      - DebianMaintainerField
      - Provide real transitional democracyplayer package
    + debian/pyversions
      - 2.4 -> 2.5
    + debian/rules
      - Use pyversions rather than hardcoding 2.4
  * New upstream version fixes invalid mime file (LP: #150851, LP: #150674)
  * debian/rules:
    + Remove remaining hardcoded python version numbers;
      use DEB_PYTHON_COMPILE_VERSION everywhere.
  * debian/control:
    + Break the long depends lists into one depends per line for readability
    + Add libxine1-x dependency (LP: #159338)
    + Bump standards version; no changes needed.
  * debian/watch:
    + Add a shiny new watch file.
  * debian/patches/50_honour_xine_driver.patch
    + Make Miro honour the --xine-driver command line option (Debian: #453406)
  * debian/patches/60_xine_extractor_path.patch
  * debian/miro.install
    + Install xine_extractor into /usr/lib/miro rather than /usr/libexec,
      and make Miro look for it there (Debian: #454603, #451980, #452708,
      #452486)

miro (1.0-1) unstable; urgency=low

  * New upstream release (Closes: #449131, #451207).
    + Fixed malformed miro.xml file (Closes: #445871, #443510).
    + Drop several patches which were applied upstream.
  * Add missing libxv-dev build-dependency (Closes: #442832, #443006, #443045).
  * Miro shipped with a menu file since the beginning (Closes: #443211).
    It's currently in the 'Applications/Network/Web News' category.
  * Fix small typo in German translation (Closes: #451333).
  * Cannot reproduce the following bugs with this release. Please
    reopen if you still experience problems:
    + Miro crashes on play (Closes: #443266).
    + Used to work; now segfaults on startup (Closes: #444484).
      Please try removing the ~/.miro directory if the problem persists.
    + Segfault on startup (quicktime related?) (Closes: #444051).
    + Cannot install Miro (Closes: #443045). Unlikely to be a real bug,
      probably stems from mixing packages from stable/unstable.
  * New 'Recommends: libxine1-ffmpeg'.

miro (0.9.9.1-1) unstable; urgency=low

  * New upstream release (Closes: #433752).
     + Democracy Player was renamed to Miro upstream, so we now
       use Provides/Conflicts/Replaces to transition existing installs.
     + Update the package description (and improve it a bit).
     + Now supports proxy settings (Closes: #426992). Miro uses the
       default GNOME proxy, which you can set/enable using gconf-editor.
  * Update debian/copyright.
  * Several improvements inspired by the Ubuntu version of the package:
    + Remove unneeded RPATH from MozillaBrowser.so (using chrpath).
    + debian/menu: Move package into 'Applications/Network/Web News'.
    + Drop shebang from feedparser.py, not needed (and silences lintian).
    + Only suggest python-psyco on [i386 hurd-i386 netbsd-i386 kfreebsd-i386].
  * miro.desktop improvements:
    + Drop 'Encoding=UTF-8', no longer necessary (lintian).
    + Change categories to 'AudioVideo;FileTransfer;News;P2P;TV;Player;'.
  * Cannot reproduc...

Read more...

Changed in miro:
status: New → Fix Released
Maia Everett (linneris) on 2007-12-27
Changed in qdvdauthor:
status: New → Confirmed
Maia Everett (linneris) on 2008-01-14
Changed in qdvdauthor:
importance: Undecided → Wishlist
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qdvdauthor - 1:1.0.0-0.0ubuntu1

---------------
qdvdauthor (1:1.0.0-0.0ubuntu1) hardy; urgency=low

  * Merged from debian-multimedia.org (LP: #182784), remaining Ubuntu changes:
    + debian/source.lintian-overrides:
      - Re-added source-contains-cvs-control-dir.
    + debian/control:
      - Depend on libxine1-x | libxine1 (LP: #159338).
      - Updated maintainer field.
    + debian/qdvdauthor.desktop:
      - Removed Encoding field.

qdvdauthor (1:1.0.0-0.0) unstable; urgency=low

  * New upstream release.
  * Add menu and icon from Ubuntu.

qdvdauthor (1:1.0.0~rc3-0.2) unstable; urgency=low

  * Forgot to modify the depends field from Ubuntu.

qdvdauthor (1:1.0.0~rc3-0.1) unstable; urgency=low

  * Merged changes from Ubuntu :
    o manpages
    o Homepage field in debian/control.
  * I don't know why but some binaries was missing in the previous package.
    Fixed now.

 -- Matvey Kozhev <email address hidden> Mon, 14 Jan 2008 15:54:02 +0600

Changed in qdvdauthor:
status: Triaged → Fix Released

Marking as fix released for amarok - these deps are only getting picked up by shlibdeps. I presume the shlibdeps are picked to ensure the correct package gets chosen, or you need to split out into different -dev packages with different shlibs?

Changed in amarok:
status: New → Fix Released
Changed in totem:
status: New → Fix Released
dukat (dukat) wrote :

Not sure if this fits here, but if I manually remove libxine1-console, amarok will be also removed. Not what I intended ...

Kubuntu Hardy, latest beta

Daniel T Chen (crimsun) on 2008-11-11
Changed in xine-ui:
status: New → Fix Released
Daniel T Chen (crimsun) wrote :

Not sure if this transition remains relevant for intrepid->jaunty, but here's a debdiff regardless.

Changed in xine-plugin:
assignee: nobody → crimsun
status: New → In Progress
Daniel T Chen (crimsun) wrote :
Jonathan Thomas (echidnaman) wrote :

kde4base is an obsolete package.

Changed in kde4base:
status: New → Won't Fix
Changed in kdemultimedia (Ubuntu):
status: New → Fix Released
Jonathan Thomas (echidnaman) wrote :

Kaffeine no longer build deps against xine, and the transition was probably even taken care of before it didn't.

Changed in kaffeine (Ubuntu):
status: New → Fix Released

The package ultrastar-ng has been renamed to performous and the current version does not use Xine.

Changed in ultrastar-ng (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.