Amarok wont play music files

Bug #1298380 reported by Zach Leigh on 2014-03-27
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Critical
Jonathan Riddell
libqapt (Ubuntu)
Critical
Harald Sitter

Bug Description

From today, Amarok will not play any music files. It opens fine, but when I click play or double click a music track, nothing happens. Ive restarted twice with no change in behavior. System is up to date.

Kubuntu 14.04
Amarok 2:2.8.0-0ubuntu3

Debug output from when I click Play:

 BEGIN: void EngineController::playPause()
amarok: [EngineController] PlayPause: EngineController state 0
amarok: BEGIN: void EngineController::play()
amarok: BEGIN: void Playlist::Actions::play()
amarok: BEGIN: void Playlist::Actions::play(quint64, bool)
amarok: BEGIN: void EngineController::play(Meta::TrackPtr, uint, bool)
amarok: BEGIN: void EngineController::stop(bool, bool)
amarok: END__: void EngineController::stop(bool, bool) [Took: 0s]
amarok: [EngineController] play: bounded is QObject(0x0) current "Come On"
amarok: [EngineController] Just a normal, boring track... :-P
amarok: BEGIN: void EngineController::playUrl(const KUrl&, uint, bool)
amarok: [EngineController] URL: KUrl("file:///home/zachleigh/Music/V/Verve, The/The Verve - Urban Hymns/14 - Come On.flac") "file:///home/zachleigh/Music/V/Verve,%20The/The%20Verve%20-%20Urban%20Hymns/14%20-%20Come%20On.flac"
amarok: [EngineController] Offset: 0
amarok: END__: void EngineController::playUrl(const KUrl&, uint, bool) [Took: 0s]
amarok: END__: void EngineController::play(Meta::TrackPtr, uint, bool) [Took: 0s]
amarok: END__: void Playlist::Actions::play(quint64, bool) [Took: 0s]
amarok: END__: void Playlist::Actions::play() [Took: 0s]
amarok: END__: void EngineController::play() [Took: 0s]
amarok: END__: void EngineController::playPause() [Took: 0s]

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amarok (Ubuntu):
status: New → Confirmed
Leo Iannacone (l3on) wrote :

I had more or less same problem.

I fixed it installing phonon-backend-gstreamer1.0 (which replaces phonon-backend-gstreamer for gstreamer 0.10).

Zach Leigh (zachleigh-8) wrote :

I fixed it by purging the gstreamer backend and installing vlc backend.

Changed in amarok (Ubuntu):
assignee: nobody → Jonathan Riddell (jr)
importance: Undecided → Critical
milestone: none → ubuntu-14.04
tags: added: kubuntu
Tom Fields (udzelem) wrote :

Hi,

situation here with Kubuntu 10.04 Beta 2:
Amarok does not even start with phonon-backend-gstreamer (v. 0.1).

I can confirm that after purging phonon-backend-gstreamer and phonon-backend-gstreamer-common and installing phonon-backend-gstreamer1.0, as suggested by Leo Iannacone, Amarok now starts and works fine again.

Tom Fields (udzelem) wrote :

meant 14.04

Adrien Beau (adrienbeau) wrote :

I have just encountered this while testing Kubuntu 14.04 Beta 2. (I booted the amd64 ISO from a USB key, on an Intel-based EFI laptop.)

When started with a click on any audio file in Dolphin, Amarok crashes upon start. When started from the command line (using Konsole), using commands in the form of "amarok <audio-file>", I also get crashes. This was tested with MP3, OGG, FLAC and WAV files stored on an NTFS partition. The same OGG, FLAC and WAV files play just fine using the Dragon video player. (MP3 support is most likely not present in the ISO.)

I have not tried the workarounds reported by others here, since I was only testing the ISO without persistence.

Mark Fraser (launchpad-mfraz) wrote :

With gstreamer0.1 Amarok won't start, with gstreamer1.0 Amarok plays, but I have no audio. VLC seems to work OK.

Harald Sitter (apachelogger) wrote :

With bug 1301192 out of the way this most likely is an issue with missing codec plugins. As gstreamer0.10-qapt was not ported to gst1.0 yet, there is no on-demand plugin installation provided at this point.

Someone please try whether installation the following packages improves the situation:
gstreamer1.0-libav gstreamer1.0-nice gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly

Changed in amarok (Ubuntu):
status: Confirmed → Incomplete
Changed in libqapt (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Harald Sitter (apachelogger)
Harald Sitter (apachelogger) wrote :

I just uploaded a version that should be able to find plugins and install accordingly, which should fix this bug (assuming the playback does not work because the codecs are missing).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqapt - 2.1.70-0ubuntu3

---------------
libqapt (2.1.70-0ubuntu3) trusty; urgency=medium

  * Import upstream commits 07 to 10 (LP: #1298380)
    + These commits include fixes to the qapt-gstreamer installer that port
      it to gstreamer1.0 native API for 14.04
    + Also fixes return values of the gstreamer installer to enable auto
      cache reloading to enable playback without restart
  * Adjust dependencies for gstreamer1.0 native port
    - removed: libqtgstreamer-dev
    - added: libgstreamer1.0-dev, libglib2.0-dev,
             libgstreamer-plugins-base1.0-dev
 -- Harald Sitter <email address hidden> Mon, 07 Apr 2014 11:57:20 +0200

Changed in libqapt (Ubuntu):
status: Triaged → Fix Released
Harald Sitter (apachelogger) wrote :

Ping ping, does anyone still have this problem?

Jonathan Riddell (jr) on 2014-04-10
Changed in amarok (Ubuntu):
milestone: ubuntu-14.04 → none
qimmer (twicfall) wrote :

Problem still occurs on my freshly installed Kubuntu 14.10 machine. Amarok opens fine, but when i click an mp3 file, nothing happens. I can play it by opening it from within Amarok tho. Using the VLC backend for phonon did not resolve the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers