Ubuntu

[Xubuntu Karmic] Pulseaudio doesn't save volumes when rebooting

Reported by Sebastian Schepens on 2009-10-12
92
This bug affects 14 people
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

The title is self-explaining, after installing pulseaudio in xubuntu karmic and using the gnome-volume-control-applet to manage the volume, every time I reboot the computer, the sound resets to being muted and 0%. If i change the volume, say 50%, and log out and in again, the sound stays in 50%, but if I reboot the computer, pulseaudio sets the sound to muted and 0%.
I don't know if it has something to do, but researching in the man pages y found about the configuration files, and realised that under ~/.pulse the aren't any of the configuration files.

summary: - [Xubuntu Karmic] Pulseaudio doen't save volumes when rebooting
+ [Xubuntu Karmic] Pulseaudio doesn't save volumes when rebooting
description: updated

This symptom should already be resolved as of this morning's updates.

This is definitely not working even with that update, i tried deleting ~/.pulse adn then i set the volume to 50%, and reboot the system, after the reboot the system starts with 17% volume, not 50 so then i reboot it again without changing anything and after the second reboot, the volume is muted and 0%.

Please attach your /var/lib/alsa/asound.state

On Oct 12, 2009 4:50 PM, "Sebastian Schepens" <email address hidden>
wrote:

This is definitely not working even with that update, i tried deleting
~/.pulse adn then i set the volume to 50%, and reboot the system, after
the reboot the system starts with 17% volume, not 50 so then i reboot it
again without changing anything and after the second reboot, the volume
is muted and 0%.

-- [Xubuntu Karmic] Pulseaudio doesn't save volumes when rebooting
https://bugs.launchpad.net/bugs...

So, any idea why this is not working?

Daniel T Chen (crimsun) wrote :

On Wed, Oct 14, 2009 at 1:03 PM, Sebastian Schepens
<email address hidden> wrote:
> So, any idea why this is not working?

Did you install updates from this morning? I fixed the alsa-utils
issue earlier and called for testing on my blog.

Still not working, is there something i should be doing, like deleting any files or something? I only tried deleting ~/.pulse

Daniel T Chen (crimsun) wrote :

On Wed, Oct 14, 2009 at 2:49 PM, Sebastian Schepens
<email address hidden> wrote:
> Still not working, is there something i should be doing, like deleting
> any files or something? I only tried deleting ~/.pulse

Disable autospawn, killall pulseaudio, pulseaudio -vvvv

I think i got it, had to "sudo service alsa-utils restart" twice as the first one failed just as in latest comments from 449589.

Didn't work with what i just posted.
How do i disable autospawn?

Figured it out, but it's not working, if i restart puleaudio or alsa-utils the sound settings remain, but if i reboot the computer, the sound is reset, once again.

hads (hads) wrote :

I had this issue, stopped gdm, killed pulseaudio removed .asound* .pulse* and rebooted. This appears to have fixed it here.

I had the same problem on xubuntu jaunty. I added the following two lines to /etc/pulse/default.pa:

### Automatically restore the volume of a module (e. g. a sink) after reboot
load-module module-volume-restore

This has fixed the problem for me consistently.

hads (hads) wrote :

I spoke too soon with my comment #12 - that didn't fix it for subsequent reboots.

Adding the 'load-module module-volume-restore' as per clemenstimpler appears to be working though. Thanks :)

krakenfury (krakenfury) wrote :

I had the same problem, but when I tried adding 'load-module module-volume-restore' my problems got worse. Now I have no audio and I can't run pavucontrol. The window pops up, then it gives error message 'Connection failed: Connection Refused'. I can open the xfce alsa mixer, unmute and change levels, but it mutes as soon as I try to feed it audio.

I tried undoing the change I made to 'default.pa', but it didn't make any difference. I also tried reinstalling all the pulse audio packages I had installed in synaptic, so it seems like there's a rotten config file somewhere.

I should also mention that I installed pulse audio while running the generic kernel, but booted into the realtime kernel afterwards. I didn't experience any problems after this except for everything being muted. pavucontrol worked fine and I had sound. It wasn't until I tried the fix mentioned above that everything went out.

Stéphane Marguet (stemp) wrote :

Same as krakenfury here.

trying to restart pulseaudio with load-module module-volume-restore give this message :

W: module.c: module-volume-restore is deprecated: Please use module-stream-restore instead of module-volume-restore!
W: module-volume-restore.c: We will now load module-stream-restore. Please make sure to remove module-volume-restore from your configuration.
E: module.c: Module "module-stream-restore" should be loaded once at most. Refusing to load.
E: module.c: Failed to load module "module-volume-restore" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Échec lors de l'initialisation du démon

And indeed module-stream-restore is already loaded in /etc/pulse/default.pa :

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

And it's also in /etc/pulse/system.pa :
### Automatically restore the volume of streams and devices
load-module module-stream-restore
load-module module-device-restore

krakenfury (krakenfury) wrote :

Yeah, I got this and removed module-volume-restore, too. Now I have to reset the volume whenever I restart, but at least everything works.

hads (hads) wrote :

Same here, I again spoke too soon about module-volume-restore fixing the problem.

I have to reset the volume on boot for the moment too.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed

I'm not quite sure how to handle this, and right now I don't have the time to acquaint myself with the details of bug administration in the ubuntu community, but the same problem has been reported for Jaunty in bug 369822.

krakenfury (krakenfury) wrote :

Maybe it's just the way pulseaudio works. Maybe in order to function, it has to sync all the volumes at init, and what better way to do that than set them all to zero?

Daniel T Chen (crimsun) wrote :

@krakenfury No, it's definitely a bug somewhere in GSt or PulseAudio.
It's being investigated.

I'm experiencing this bug too. It goes to full volume though which is always quite embarrassing in my lecturers

krakenfury (krakenfury) wrote :

Haha! Your bug = 1/Everyone else's bug

ThomasMartitz (thomas-martitz) wrote :

Seems to work on my new laptop and ubuntu karmic now.

Ashy (drashy) wrote :

Also experiencing similar things with Ubuntu Karmic 64bit.

Whenever I reboot, all audio channels reduce down to 14% volume apart from the Center channel (which stays at 100%).
A quick trip to pavucontrol lets me adjust the volumes back to 100% and everything works fine.

On a sidenote, why does the gnome volume applet not allow you to adjust the channels separately, it took me ages to work out that I had to use pavucontrol.

krakenfury (krakenfury) wrote :

Adjusting the volumes separately is pretty much the defining feature of pulseaudio. The gnome volume applet is probably just for controlling alsa. I use Xubuntu, so I don't know if this will work for you, but if you right-click on your volume control icon from your panel, there should be a Properties or Settings or something to click on. You can change the command to pavucontrol, so that may be more convenient for you.

1guy0cups (tony-morgan) wrote :

It sounds (and is) stupid but a lot of my frustration with muted volumes after reboot was fixed by right-clicking on the volume control icon and un-muting there. For whatever reason, un-muting in gnome-alsa-mixer doesn't persist.

I *suspect* the reason is that pulse requires an obsessive degree of control over ~/.pulse. Most of my attempts to un-mute/kill/restart from the command line ended in a variant of "home dir is not ours". BTW this makes having /home on an NTFS partition "problematic". I hope this sticks - it seems like most of my Ubuntu time for the past 18 months has been spent googling sound fixes.

Brian Richardson (brian-cubik) wrote :

Seems to be fixed now. I've rebooted several times and haven't needed to touch the audio controls.

M.C. (botmc) wrote :

The problem still persist and since I dual boot I can see the effect in XP so that it has the volume set to 0 when I boot into that OS.
Can it be that Karmic sets the sound in the BIOS?

scott (whittaker007) wrote :

Same for me. I have the additional complication of needing to use ALSA so I can get AC3 passthrough for movies which Pulse doesn't seem to allow for some reason. With Pulse mixer set to output regular stereo I can get system sounds in stereo and AC3 passthrough on XBMC (but not VLC or MediaPlayer). But I still have to manually unmute and set the volume every reboot. What a mission...

florin.balate (florin-balate) wrote :

I have the same problem on Xubuntu Karmic 32-bit, and on Mythbuntu Karmic 64-bit.
Problem appeared on both systems after the dist-upgrade from Jaunty.

Brian Richardson (brian-cubik) wrote :

Problem was resolved after removing all desktop-related configurations (.gconf, .gnome, etc.). I can't be any more specific about which configuration, unfortunately.

skam (cbissuel) wrote :

this bug already existed with Xubuntu Jaunty

Maybe this will help, or to contact the author :
http://0pointer.de/blog/projects/pa-in-ubuntu.html

Dianne Reuby (pramclub) wrote :

This is a solution given in the forums:
http://ubuntuforums.org/showthread.php?t=1326505&highlight=audio+muted+startup&page=2

But I'm reluctant to edit files when I'm not 100% sure what I'm doing, so I haven't tried it out myself.

Daniel T Chen (crimsun) wrote :

Dianne, the solution we're using in Lucid is not to mute the card(s) on reboot/shutdown. See the changelog for [Lucid's] alsa-utils for the historical situation and change rationale.

affects: pulseaudio (Ubuntu) → alsa-utils (Ubuntu)
Changed in alsa-utils (Ubuntu):
status: Confirmed → Fix Released
bcrowell (launchpadcrowell07) wrote :

I've switched the status from Fix Released back to Confirmed. I upgraded from jaunty to karmic, and the bug is still present.

 $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
$ apt-cache policy alsa-utils
alsa-utils:
  Installed: 1.0.20-2ubuntu6
  Candidate: 1.0.20-2ubuntu6
  Version table:
 *** 1.0.20-2ubuntu6 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Changed in alsa-utils (Ubuntu):
status: Fix Released → Confirmed
bcrowell (launchpadcrowell07) wrote :

I just noticed that this is filed against [Xubuntu Karmic]. I'm actually running Ubuntu Karmic, not Xubuntu Karmic, so it doesn't appear to be specific to xubuntu as opposed to vanilla ubuntu.

I am also having this bug: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/504947 I think they are separate bugs, and have tried to do tests that separate them, but they may be related.

AlexRou (alex-rou-sg) wrote :

Hi i found the solution to all sound muting problems this is because alsa mutes the sound when it exits and also if pulseaudio is installed it only exits after alsa meaning when alsa mutes the volume pulseaudio in turn saves that value thus it is mute after every boot

i found the solution here http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556971

in case u do not understand

edit /etc/init.d/alsa-utils with mousepad or some other editor and find the following lines

 esac
 card_OK "$TARGET_CARD" || log_action_end_msg_and_exit "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
 store_levels "$TARGET_CARD" || EXITSTATUS=1
 mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1
 log_action_end_msg_and_exit "$EXITSTATUS"

change mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1
to #mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

thus disabling the muting and saves all your troubles

if does not work then:

sudo chmod 777 /var/lib/alsa/asound.state
alsactl store

set alsactl restore to load on startup if it is still mute

AlexRou (alex-rou-sg) wrote :

ohh forgot to mention set your volume before doing alsactl store

hhh (hhh) wrote :

I'm running Ubuntu Karmic standalone Openbox sessions and Gnome sessions. The fix in comment #38/39 WFM in both Openbox and Gnome if I add 'alsactl restore &' to ~/.config/openbox/autostart.sh (for Openbox) AND 'alsactl restore' to /etc/rc.local (for Gnome). Now I have unmuted sound ready-to-go no matter where I login/logout/change session/reboot. Thank you Alex!

Sam_ (and-sam) wrote :

Not sure if new users are happy about editing scripts or files.
Found this solution though.
http://ubuntuguide.net/how-to-fix-sound-muted-on-startup-in-ubuntu-910karmic
btw. I've downloaded and booted yesterday Lucid daily build and sound was muted.

Daniel T Chen (crimsun) wrote :

Sam, can you get a verbose log from a fresh boot of the latest daily-live cd
(https://wiki.ubuntu.com/PulseAudio/Log)?

On Mar 7, 2010 3:15 PM, "Sam" <email address hidden> wrote:

Not sure if new users are happy about editing scripts or files.
Found this solution though.
http://ubuntuguide.net/how-to-fix-sound-muted-on-startup-in-ubuntu-910karmic
btw. I've downloaded and booted yesterday Lucid daily build and sound was
muted.

--
[Xubuntu Karmic] Pulseaudio doesn't save volumes when rebooting
https://bugs.launchpad.net/bugs...

Audio Team, which is subscribed to alsa-utils in ubuntu.

Status in “alsa-utils” package in Ubuntu: ...

Bug description:
Binary package hint: pulseaudio

The title is self-explaining, after installing pul...

Sam_ (and-sam) wrote :

Daniel, here it is.
Open terminal, paste the cmds.
Open Rhythmbox to play a radio stream. Result: No sound.
I also added a screenshot of sound preferences which shows muted.
After ctrl+c in terminal, I went to open sound preferences again. Result: Message waiting for sound system to respond.

btw. is it meant that reboot from LiveCD session doesn't work and I need to do always alt+sysrq+B?
If not I'll log a bug for it.

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

> I'll log a bug for it
done. #534547

Colin Watson (cjwatson) wrote :

alsa-utils (1.0.23-2ubuntu2) maverick; urgency=low

  * debian/init: Restore change from 1.0.21-1ubuntu2 lost during merge
    that skips muting and zeroing levels prior to shutdown/reboot,
    which was a hack for broken drivers. This change closes LP: #21804,
    LP: #208920, #227505, #360108, #432660, #449783, #553132, #564472,
    LP: #584609, #592016, #596360, #613054, #617516, #622487, #632019.
  * debian/patches/alsactl_init_update_to_52bd2f8a_head.patch: Add
    upstream git changesets:
    dcb90a77 - Use "Found hardware:" instead "Unknown hardware:"
    7f6a55e2 - use "generic method" instead "guess method"
    52bd2f8a - Handle "Capture Source" and "Mic Boost"
    ef919a47 - Initialize also "Master Front Playback Volume" & "Switch"
    (yes, this last changeset is included despite the patch filename)

 -- Daniel T Chen <email address hidden> Sun, 05 Sep 2010 11:57:59 -0400

Changed in alsa-utils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.