Ubuntu

sound randomly working or broken in successive login sessions

Reported by bcrowell on 2010-01-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

When I boot my computer, I do not get the short bongo sound effect. When I log in to a Gnome session, I randomly (about 10% of the time) get the longer percussion sound effect, but usually (90% of the time) do not. When I log back out, I randomly (about 50% of the time) sometimes get the short sound effect at the gdm screen and sometimes don't. Within a Fluxbox login session, I can sometimes get sound to work (amixer -- set Master playback 100% unmute , and then madplay), but sometimes can't (50/50).

---- rintintin ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
---- rintintin ~ $ apt-cache policy pulseaudio
pulseaudio:
  Installed: 1:0.9.19-0ubuntu4
  Candidate: 1:0.9.19-0ubuntu4
  Version table:
 *** 1:0.9.19-0ubuntu4 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bcrowell 1563 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf5100000 irq 21'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1458e601,00100002'
   Controls : 40
   Simple ctrls : 22
CurrentDmesg:
 [ 30.430012] eth0: no IPv6 routers present
 [ 30.475723] usb 2-4: usbfs: interface 0 claimed by usblp while 'usb' sets config #1
 [ 94.300027] Clocksource tsc unstable (delta = -272033878 ns)
 [ 97.631233] end_request: I/O error, dev fd0, sector 0
 [ 109.718516] end_request: I/O error, dev fd0, sector 0
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Tags: lucid
Uname: Linux 2.6.32-19-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/26/2006
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: M61P-S3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd12/26/2006:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnM61P-S3:rvrx.x:cvn:ct3:cvr:

Please use apport-collect -p alsa-base 504947

On Jan 8, 2010 4:05 PM, "bcrowell" <email address hidden>
wrote:

Public bug reported:

Binary package hint: pulseaudio

When I boot my computer, I do not get the short bongo sound effect. When
I log in to a Gnome session, I randomly (about 10% of the time) get the
longer percussion sound effect, but usually (90% of the time) do not.
When I log back out, I randomly (about 50% of the time) sometimes get
the short sound effect at the gdm screen and sometimes don't. Within a
Fluxbox login session, I can sometimes get sound to work (amixer -- set
Master playback 100% unmute , and then madplay), but sometimes can't
(50/50).

---- rintintin ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
---- rintintin ~ $ apt-cache policy pulseaudio
pulseaudio:
 Installed: 1:0.9.19-0ubuntu4
 Candidate: 1:0.9.19-0ubuntu4
 Version table:
 *** 1:0.9.19-0ubuntu4 0
       500 http://us.archive.ubuntu.com karmic/main Packages
       100 /var/lib/dpkg/status

** Affects: pulseaudio (Ubuntu)
    Importance: Undecided
        Status: New

--
sound randomly working or broken in successive login sessions
https://bugs.launchpad.net/bugs/504947
You received this bug notification because you are a member of Ubuntu
Audio Team, which is subscribed to pulseaudio in ubuntu.

Status in “pulseaudio” package in Ubuntu: New

Bug description:
Binary package hint: pulseaudio

When I boot my computer, I do not get the short bongo sound effect. When I
log in to a Gnome session, I randomly (about 10% of the time) get the longer
percussion sound effect, but usually (90% of the time) do not. When I log
back out, I randomly (about 50% of the time) sometimes get the short sound
effect at the gdm screen and sometimes don't. Within a Fluxbox login
session, I can sometimes get sound to work (amixer -- set Master playback
100% unmute , and then madplay), but sometimes can't (50/50).

---- rintintin ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
---- rintintin ~ $ apt-cache policy pulseaudio
pulseaudio:
 Installed: 1:0.9.19-0ubuntu4
 Candidate: 1:0.9.19-0ubuntu4
 Version table:
 *** 1:0.9.19-0ubuntu4 0
       500 http://us.archive.ubuntu.com karmic/main Packages
       100 /var/lib/dpkg/status

Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bcrowell 2884 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf5100000 irq 21'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1458e601,00100002'
   Controls : 40
   Simple ctrls : 22
CurrentDmesg:
 [ 16.862629] usplash:368 freeing invalid memtype ffffffffe0000000-ffffffffe4000000
 [ 19.242516] eth0: no IPv6 routers present
 [ 81.890035] Clocksource tsc unstable (delta = -273280752 ns)
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (firefox:2897): GLib-WARNING **: g_set_prgname() called multiple times

tags: added: apport-collected
bcrowell (launchpadcrowell07) wrote :

Hi, Daniel T Chen -- Thanks for the reply. I uploaded the apport data. Note that this apport data was from a session in which sound was not working. --Ben

Daniel T Chen (crimsun) wrote :

Please reproduce this symptom using the most current daily-live desktop Lucid image.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
bcrowell (launchpadcrowell07) wrote :

I booted from an ISO of the 2010 Mar 7 daily build of Lucid, but it didn't get to a state in which I could test the bug. I got a purple background on my screen and a mouse cursor, but everything was frozen. When I hit control-alt-F1, I was not able to get to a terminal session.

bcrowell (launchpadcrowell07) wrote :

I was able to boot Ubuntu 10.04 beta 2 successfully on this machine. The bug is still present in Lucid.

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

bcrowell (launchpadcrowell07) wrote :

After further testing, I've found that the probability of having broken sound is greatly reduced in lucid beta 2 compared to karmic. In karmic, approximately 95% of boots would give broken sound. In lucid, I just did a sample of 8 reboots, and sound was only broken once. The fact that sound was only broken on the first of the 8 reboots (the first one after I upgraded to lucid) makes me wonder whether the remaining problem is deterministic rather than random. The first time I booted into lucid, I played with all the volume controls, made sure everything was set to maximum volume and unmuted, and still couldn't get any sound output. But then when I rebooted, sound was working without my even needing to touch any sound controls.

bcrowell (launchpadcrowell07) wrote :

This problem seems to be fixed in the latest version of lucid beta 2 (kernel 2.6.32-21).

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
DarkRedman (darkredman) wrote :

Hello, I've the same problem on Ubuntu 11.10 !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers