Microphone does not work in Aus eeePC 1001px!

Bug #689258 reported by paulo bessa on 2010-12-12
68
This bug affects 11 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

***Fixed in Natty***

I am using Ubuntu lucid 10.04.1 LTS

I have sound but internal microphone does not work.
This seems to affect every user of ubuntu in Asus eeePC 1001px, and also other eeePCs.

I am using alsa-utils and pulseaudio.
I set left channel of microphone capture to 100% and right to 0%: this did not work
I tried to remove pulseaudio: this did not work
I tried editing /etc/modprobe.d/alsa-base.conf as suggested by other users.

# Keep snd-pcsp from being loaded as first soundcard:
options snd-pcsp index=-2
# Patch to solve audio in Ubuntu Lucid 10.04 Asus eeePC 1001PX:
options snd-hda-intel model=lifebook

Still this does not work, would anyone have another idea?
Help would be greatly appreciated!
I am still working to know how to solve this microphone bug on Asus eeePCs.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-26.48-generic 2.6.32.24+drm33.11
Uname: Linux 2.6.32-26-generic x86_64
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Dec 12 2010 for kernel 2.6.32-26-generic (SMP).
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: paulobessa 9910 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7cf8000 irq 29'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,10438437,00100100'
   Controls : 11
   Simple ctrls : 7
CheckboxSubmission: c9e09536282aaad10d9906e269ef12c7
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
Date: Sun Dec 12 14:17:08 2010
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt:pt_BR:en
 LANG=pt_PT.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC269VB] Recording problem
dmi.bios.date: 08/12/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0904
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1001PX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0904:bd08/12/2010:svnASUSTeKComputerINC.:pn1001PX:pvrx.x:rvnASUSTeKComputerINC.:rn1001PX:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1001PX
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

paulo bessa (pcbessa) wrote :
paulo bessa (pcbessa) on 2010-12-12
description: updated
Changed in ubuntu:
status: New → Incomplete
Daniel T Chen (crimsun) wrote :
affects: ubuntu → alsa-driver (Ubuntu)
paulo bessa (pcbessa) wrote :

I have latest Alsa drivers!!! Internal microphone does not work!!

paulo bessa (pcbessa) on 2011-01-01
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → New

Confirmed, using:

Asus EEE PC 1001PX
Ubuntu 10.10 (2.6.35-24-generic)
ALSA 1.0.23

Microphone does not work at all.
Basically tried all solutions suggested here on launchpad, on wikis and forums.

To be more specific, I've tried everything in this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580183

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Yuri (yu-tkachov) wrote :
Download full text (20.2 KiB)

In my EeePC 1001PX-BLK37W buit-in microphone does not work in any settings:

options snd-hda-intel model=lifebook (now this settings - the sound is both in speakers, and in earphones)

or

options snd-hda-intel model=fujitsu (no sound in earphones)

Ubuntu 10.10, amd64, last core
$ uname --all
Linux lilichka-eeepc 2.6.35-25-server #44-Ubuntu SMP Fri Jan 21 19:09:14 UTC 2011 x86_64 GNU/Linux

-------------------------------------
Desktop Management Interface information

/sys/class/dmi/id/uevent:MODALIAS=dmi:bvnAmericanMegatrendsInc.:bvr1102:bd12/01/2010:svnASUSTeKComputerINC.:pn1001PX:pvrx.x:rvnASUSTeKComputerINC.:rn1001PX:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
/sys/class/dmi/id/bios_vendor:American Megatrends Inc.
/sys/class/dmi/id/bios_version:1102
/sys/class/dmi/id/bios_date:12/01/2010
/sys/class/dmi/id/sys_vendor:ASUSTeK Computer INC.
/sys/class/dmi/id/product_name:1001PX
/sys/class/dmi/id/product_version:x.x
/sys/class/dmi/id/board_vendor:ASUSTeK Computer INC.
/sys/class/dmi/id/board_name:1001PX
/sys/class/dmi/id/board_version:x.xx
/sys/class/dmi/id/board_asset_tag:To Be Filled By O.E.M.
/sys/class/dmi/id/chassis_vendor:ASUSTeK Computer INC.
/sys/class/dmi/id/chassis_type:10
/sys/class/dmi/id/chassis_version:x.x
/sys/class/dmi/id/chassis_asset_tag:0x00000000
/sys/class/dmi/id/modalias:dmi:bvnAmericanMegatrendsInc.:bvr1102:bd12/01/2010:svnASUSTeKComputerINC.:pn1001PX:pvrx.x:rvnASUSTeKComputerINC.:rn1001PX:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
/sys/class/dmi/id/power/control:auto
/sys/class/dmi/id/power/runtime_status:unsupported
/sys/class/dmi/id/power/runtime_suspended_time:0
/sys/class/dmi/id/power/runtime_active_time:0

-----------------------------------------
cat /proc/asound/card*/codec#*

Codec: Realtek ALC259
Address: 0
Function Id: 0x1
Vendor Id: 0x10ec0269
Subsystem Id: 0x10438437
Revision Id: 0x100100
No Modem Function Group found
Default PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=2, o=0, i=0, unsolicited=1, wake=0
  IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
  IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
Node 0x02 [Audio Output] wcaps 0x1d: Stereo Amp-Out
  Device: name="ALC259 Analog", type="Audio", device=0
  Amp-Out caps: ofs=0x57, nsteps=0x57, stepsize=0x02, mute=0
  Amp-Out vals: [0x54 0x54]
  Converter: stream=5, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Node 0x03 [Audio Output] wcaps 0x1d: Stereo Amp-Out
  Amp-Out caps: ofs=0x57, nsteps=0x57, stepsize=0x02, mute=0
  Amp-Out vals: [0x54 0x54]
  Converter: stream=5, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Node 0x04 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x05 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  PCM:
    rates [0x5e0]: 44100 48000 88200 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Node 0x07 [Vendor Defined Widget] wcaps 0xf000...

EdwardoiD (edward-sarkisyan) wrote :

It work's for me now. I just downloaded and compiled last stable kernel source from kernel.org. :)

Kernel version: 2.6.37.3

lsmod's output:

Module Size Used by
aes_i586 7280 2
aes_generic 26875 1 aes_i586
binfmt_misc 6412 1
parport_pc 26084 0
ppdev 5238 0
snd_hda_codec_realtek 248339 1
snd_hda_intel 21656 6
arc4 1165 2
ath9k 93026 0
snd_hda_codec 83326 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5072 1 snd_hda_codec
snd_pcm 71538 4 snd_hda_intel,snd_hda_codec
joydev 8743 0
i915 373043 3
snd_seq_midi 4652 0
mac80211 234133 1 ath9k
snd_rawmidi 17836 1 snd_seq_midi
drm_kms_helper 31725 1 i915
ath9k_common 2563 1 ath9k
drm 174055 4 i915,drm_kms_helper
uvcvideo 57275 1
ath9k_hw 269575 2 ath9k,ath9k_common
ath 13001 2 ath9k,ath9k_hw
cfg80211 138563 3 ath9k,mac80211,ath
snd_seq_midi_event 6047 1 snd_seq_midi
videodev 67493 2 uvcvideo
v4l1_compat 13519 2 uvcvideo,videodev
intel_agp 9842 1 i915
eeepc_wmi 3214 0
sparse_keymap 3406 1 eeepc_wmi
snd_seq 46801 2 snd_seq_midi,snd_seq_midi_event
snd_timer 18657 2 snd_pcm,snd_seq
snd_seq_device 5776 3 snd_seq_midi,snd_rawmidi,snd_seq
i2c_algo_bit 4704 1 i915
intel_gtt 12830 3 i915,intel_agp
psmouse 55873 0
snd 48853 19 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
video 11506 1 i915
serio_raw 3990 0
output 1851 1 video
soundcore 880 1 snd
snd_page_alloc 7280 2 snd_hda_intel,snd_pcm
agpgart 30657 3 drm,intel_agp,intel_gtt
lp 7181 0
shpchp 25010 0
parport 31531 3 parport_pc,ppdev,lp
ahci 18338 3
atl1c 28909 0
libahci 19074 1 ahci

description: updated

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

Nevyn (nevynh) wrote :

Have been using a kernel backport. Was using alsa-backports but found the noise levels far too high.

https://launchpad.net/~kernel-ppa/+archive/ppa

Am currently using 3.0.0-14 but about to update it as I am having some isolated wireless issues.

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions