Ubuntu

asus eeepc 1001px in/out jack not functionnal and screen microphone

Reported by microzonepl on 2010-05-13
216
This bug affects 38 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Leann Ogasawara
Declined for Maverick by Leann Ogasawara

Bug Description

asus 1001px laptop speaker sound is ok. But the screen microphone and the in/out jack is not functionnal. (there is only 1 sound jack with both functions ) When the jack is plugged in the speaker turn off but there is no sound in the headset.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.33
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gilbert 1243 F.... pulseaudio
 /dev/snd/pcmC0D0c: gilbert 1243 F...m pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7cf8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10438442,00100004'
   Controls : 9
   Simple ctrls : 5
Date: Thu May 13 16:07:11 2010
HibernationDevice: RESUME=UUID=abb9c6a2-48ad-406a-81e1-d28b395629a9
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: ASUSTeK Computer INC. 1001PX
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=5584601a-88cd-4964-800e-7a43030e1900 ro quiet splash
ProcEnviron:
 LANG=fr_CA.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
dmi.bios.date: 02/10/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0201
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1001PX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0201:bd02/10/2010:svnASUSTeKComputerINC.:pn1001PX:pvrx.x:rvnASUSTeKComputerINC.:rn1001PX:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1001PX
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

microzonepl (nicolas-rodrigue) wrote :
affects: ubuntu → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi microzonepl,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
tet (flashkaisel) on 2010-06-06
description: updated

Having the exact same issue OOTB with Kubuntu 10.04. Tried changing the snd-hda-intel to model=auto and a few other variations with no success on getting the jack to output sound.

Simon Richelle (simon-richelle) wrote :

Same Problem here, but on Fedora 13. So, not distro specific. kernel 2.6.32.12-115.fc12.x86_64, pulseaudio 0.9.21

irwjager (jager49) wrote :

Can confirm this on Ubuntu Netbook Edition
2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux

irwjager (jager49) on 2010-07-04
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Steve Warren (steve-warren) wrote :

Confirmed on Ubuntu Netbook Edition 10.04 LTS using
linux 2.6.35-6-generic (from xorg-edgers)

Pierre Sanfourche (p-sanf) wrote :

Confirmed on Ubuntu 10-04 LTS (standard edition, not UNE) using 2.6.32-23 kernel.

Confirmed on Ubuntu 10.04 LTS using 2.6.34-020634rc7 kernel.

Oguz Han Asnaz (o-asnaz) wrote :

Confirmed on Ubuntu 10.04 UNE using 2.6.32-21-generic kernel.

Pablo (pablogfdez) wrote :

Here is a little solution until ALSA developer team include a specific file for this computer: http://www.ubuntu-es.org/node/137762

Josep M. Riera (jmriera) wrote :

Pablo's link solution works perfectly!

Thanks

Confirmed, the solution found by Pablo worked like a charm - without even installing the latest alsa drivers.
Thanks a lot!

Luca (pogush) wrote :

The sound is played in your headset with Pablo's solution, but still the microphone stops working when you plugin the jack..

Luca (pogush) wrote :

#edit

the still works when you plug the jack, does not when you set model=lifebook in alsa-base.conf

Pierre Sanfourche (p-sanf) wrote :

Many thanx Pablo ! Wonderful solution, and really easy to set up !
Great !

kevind (kevind256) wrote :

And if you use Google Translate to translate entire instruction from Pablo's link to English, beware that it adds spaces before and after an = in following line:

options snd-hda-intel model=lifebook

after which ALSA won't work at all. Dont' fall into same trap as me :)

chocobanana (sergioc) wrote :

I have the exact same issue here with my 1001px.

I found that if you do "sudo apt-get install pavucontrol" to install the PulseAudio Volume Control, and then lower the right channel of the microphone, the internal microphone then works.

The solution from Pablo in http://www.ubuntu-es.org/node/137762 also solves the line-out issue for me too but, HOWEVER, then the internal microphone stops working even when using the PulseAudio Volume Control as described in the previous paragraph...

Any idea how to make both play along nicely?

Kjetil Fleten (kjetil-fleten) wrote :

I have:
-Upgraded alsa to 1.0.23
-Set "options snd-hda-intel model=lifebook" in the end of alsa.conf
-installed pavucontrol
-lower the right channel of the microphone

...but the internal mic still dont work on my 1001px with 10.04

The input section of the sound settings offer "Line in+Microphone1+Microphone2". None of them record any sound.

Any idea of next step ?

buasaard (buasaard) wrote :

Netbook Asus 1001PX

Upgraded to alsa 1.0.23

If I set options snd-hda-intel model=lifebook it works the output but doesn't work the microphone, if I set the model=basic it works the microphone if I plug the jack and set the type of input = line in, and works the output from the speakers but not from the headphone.
Any suggestion for any other kind of model that could make work both?

buasaard (buasaard) wrote :

Tried with model=fujitsu, work both the input and output integrated, but not the microphone and the headphone plugging the jack.

Kjetil Fleten (kjetil-fleten) wrote :

model=fujitsu solved the internal mic problem for me :-)
Thats all I need, have not tested the jack.

tet (flashkaisel) wrote :

model=fujitsu solved the internal mic problem for me too.
thx all.

Lubensius (lubensius) wrote :

Hi,
I played around with hda-analyser and 9.10 and it seems, that the initial mixer setting is not correct. The headphone output is not connected to the sound source.
Puting this line in /etc/rc.local is a work around:
#Bugfix für EeePC 1001PX
hda-verb /dev/snd/hwC0D0 0x1a SET_CONNECT_SEL 0x0c

This sets the correct connection for headphone output.
Does someone know how to correct this in the alsa configuration files?

Jeremy Foshee (jeremyfoshee) wrote :

Resetting to incomplete per my request to microzonepl not having been answered.

Those of you affected by this issue, please review the information located in https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs.
In the future please open separate bugs for your issues and refrain from setting bug status unless you are either the original reporter or a developer working on the problem.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I have tried Pablo's link. Headphone audio works great. Speakers work fine. Internal and jack microphones don't work at all. I've tried changing that one line in /etc/modprobe.d/alsa-base.conf to several different options to no avail. A speedy fix for this would be much appreciated.

Dima Krasner (dima-k) wrote :

Here's a workaround. Works 100% with my Fedora, 2.6.33.x and alsa 1.0.23.

1) Get hda-analyser: http://www.alsa-project.org/main/index.php/HDA_Analyzer

This cute thing lists all pins, channels, etc'.

Run it and go to the 0x1a pin: unmute it (untick both)! That will ... unmute it.

2) Select "Audio Mixer [0x0c]" instead of d. That will assign the port to your output instead of input.

3) Reboot.

You can also try hda-verb as suggested above, but you'll still need to unmute the channels, you can get it in http://kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/.

Cheers!

buasaard (buasaard) wrote :

I tell you how I managed to make everything working : speakers only, earphone only, and built-in microphone. Tested on Skype and it seems it works everything.

Ubuntu netbook remix 10.04

Run Hda Analyzer
Go to 0x1a pin
set audio mixer to 0x0d
unmute vol[0] and vol[1] output
in widget control check all boxes (HP , IN, OUT)

Go to audio preferences , in output put the balance all on the right

All this with options snd-hda-intel model=lifebook in alsa-base.conf file.

The only problem is when restarting, must run hda analyzer again. Does anybody know how to fix these parameters?

buasaard (buasaard) wrote :

APologize, the options is more exactly options snd-hda-intel model=fujitsu

Dima Krasner (dima-k) wrote :

I guess it's a problem with ALSA. I can't get this persistent either, I must run the hda-verb thing on each boot, manually, somehow it doesn't work when I put it in /etc/rc.local.

 Maybe the 1001PX needs a specific model in snd-hda-intel just like the 700 and 900 models. Kinda funny the 1005P doesn't suffer from this, despite of the fact both models are almost identical.

buasaard (buasaard) wrote :

I managed to set the audio mixer to 0x0d on startup, as well as checking the widget control boxes using hda-verb and putting the proper verbs in the /etc/rc.local file, but I don't understand which verb should I use to unmute the output amp. When I manually unmute with hda-analyzer the analyze.diff file shows the output

QUOTE
Diff for codec 0/0 (0x10ec0269):
---
+++
@@ -194,17 +194,17 @@
   Pin-ctls: 0x24: IN VREF_80
   Unsolicited: tag=0x00, enabled=0
   Connection: 2
      0x0c* 0x0d
 Node 0x1a [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
   Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
   Amp-In vals: [0x00 0x00]
   Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
- Amp-Out vals: [0x00 0x00]
+ Amp-Out vals: [0x80 0x80]
   Pincap 0x0000373c: IN OUT HP Detect
     Vref caps: HIZ 50 GRD 80 100
   Pin Default 0x01214c1f: [Jack] HP Out at Ext Rear
     Conn = 1/8, Color = Green
     DefAssociation = 0x1, Sequence = 0xf
   Pin-ctls: 0xe0: IN OUT HP VREF_HIZ
   Unsolicited: tag=0x00, enabled=0
   Connection: 2
UNQUOTE

The key is that - and + Amp-out vals, but I don't know which verb to use in the rc.local file to have the proper parameters set at startup.

buasaard (buasaard) wrote :

With Fedora I managed to get everything working, using hda-verb

Without any option in the alsa configuration file, writing into /etc/rc.local the following lines and rebooting.

/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_CONNECT_SEL 0x0c
/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_PIN_WIDGET_CONTROL 0xe0

In the audio preference, set as speakers and with balance on the left, works the headphone plugging the jack and the speakers unplugging, and of course works also the microphone.
I tried without any option in the alsa.conf file in Ubuntu, but it doesn't work.

buasaard (buasaard) wrote :

Gotcha! I managed to make everything working using hda-verb (or almost everything).

In alsa-base.conf file add

options snd-hda-intel model=fujitsu

Then using hda-verb

wget http://kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/hda-verb-0.3.tar.gz
tar -xvjf hda-verb-0.3.tar.gz
cd hda-verb-0.3
make
sudo cp hda-verb /usr/local/bin
sudo gedit /etc/rc.local

add at the end before exit(0)

/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_CONNECT_SEL 0x0d
/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_PIN_WIDGET_CONTROL 0xe0
/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a 0x3a0 0x00
/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x1a 0x390 0x00

save and reboot.

Now the last thing to do to have the microphone working is to put all the output balance either on the left or on the right. Oddily enough the microphone doesn't work with the output balance centered. So go to System-Preferences-Sound (or whatever, I have Ubuntu in italian) and put the balance on the left.

So can use voip and messenger application (tested with skype).

To hear music of course is better to center the balance.

If you set in the output as "analog headphone" the output works with headphone and if you unplug the headphone you can hear the speakers.

buasaard (buasaard) wrote :

Sorry, of course not tar -xvjf hda-verb-0.3.tar.gz
but tar -xvf hda-verb-0.3.tar.gz

Dima Krasner (dima-k) wrote :

Got everything working, even the microphone, Fedora 13.

I moved hda-verb to /usr/bin and added this to /etc/rc.local:

/usr/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_CONNECT_SEL 0x0c
/usr/bin/hda-verb /dev/snd/hwC0D0 0x1a SET_PIN_WIDGET_CONTROL 0xe0

No "options snd-hda-intel model=something".

Now everything works perfectly and persistently. I can use my microphone, but for some reason the volume is very very high, I guess it's because I used hda-analyzer to reset everything to the defaults, probably one of the capture channels is at 100% and the Xfce mixer hides it.

Dima Krasner (dima-k) on 2010-09-02
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Declining the Lucid and Maverick specific nominations for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nominations should a fix be narrowed down which we can confirm specifically resolves this issue in Lucid and Maverick and qualifies for a Stable Release Update.

Dima Krasner (dima-k) wrote :

Tested Fedora 13 with 2.6.35.4, the problem persists.

Will the Maverick fix go upstream too?

Dima Krasner (dima-k) wrote :

Fixed in 2.6.35.5, the fix also appears in 2.6.32.22.

I can confirm the bug is gone in 2.6.35.7 and 2.6.32.24.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

The output jack works with kernel 2.6.35.22, but the internal microphone stopped working.
(alsa-base 1.0.23+dfsg-1ubuntu4)

Martín Ferrari (tincho) wrote :

I found something related to this: in my case (1001px-WHI050S), everything worked out of the box, and I *thought* the mic didn't work because of the balance issue. In fact, it works, but the mic in mono, and is converted into a stereo stream with one channel having the same values as the other, but with the polarity inverted. The result is that, when reproducing this with the mono output (the loudspeaker) both channels get mixed and therefore they cancel themselves.

The right fix for this would be to find the right register to change to make the mic a mono input, or to fix the polarity of one of the channels.

Can someone please change this back to confirmed as the internal microphone was working with RC versions of 10.10 but has since broken again with either ALSA or kernel updates.

Fresh install of Ubuntu Netbook Remix 10.10 (installed and updated 8/11 2010).
Problem with internal microphone presists, it does not work.
I've had no luck with any of the workarounds above.

Per-Erik Makitalo (per-erik) wrote :

Same here. Fresh install of Ubuntu Netbook Remix 10.10, (updated 8/11 2010) on ASUS EEE PC 1001PX.
Internal microphone doesn't work, no luck with any of the workarounds above.

tcrespi (tcrespi) wrote :

I'm using Ubuntu 10.10 with the buasaard instruction, speaker, phone and internal mic work. Also I installed pavucontrol to balance mic channel one side. Cheese does not capture audio (int. mic) and skype does not allow to change sound settings. It's a known bug between skype and pulseaudio. So I start skype with "PULSE_SERVER=192.168.0.101 skype" and after all it works!

elvito (vitus-hanemann) wrote :

@ #43: it's not necessary to start skype withe the pulse_server argument. Just do the test call via skype with opened pulse volumecontrol and change in tab "Aufnahme" (I think it's called "Recording" in English) during the test call from "monitor..." to "Intern analog stereo". After that skype worked here like a charm.

Nevyn (nevynh) wrote :

Back to the subject on hand (Don't really care about skype - it's the sound card that I need working)....

I have 100 of the Asus eee 1001px machines out on a pilot program at the moment with 2000 of these machines being deployed next year. I REALLY need a fix for this - the pressure is really on now as this is essentially a trial of what will become a nationwide programme.

I did try the 2.6.35-RC1 kernel have had no joy as well as updated alsa drivers.

Let me know what you need from me to get this sorted.

Juan Gonzalez (jglopez) wrote :

Running Maverick 10.10 with latest kernel 2.6.35-22 and alsa-base 1.0.23+dfs.

By default (/etc/modprobe.d/alsa-base.conf untouched, no hda-verb nor hda-analyser):

Internal mono speaker works (good)
Plugging headphones:
- Headphones work (good)
- Internal speaker is silenced (good)
Unplugging headphones:
- Internal speaker starts sounding again (good)
Plugging microphone:
- Internal speaker is silenced, just as if the mic were a headphone (bad)
- Neither mic works (bad)
Unplugging microphone:
- Internal speaker works again (good, but it shouldn't have been silenced in the first place)

In all cases, the internal microphone never works.

FWIW, I have pulseaudio removed and purged, and I don't have any Gnome/KDE stuff running.

Juan Gonzalez (jglopez) wrote :

After the kernel update to 2.6.35-23, internal mic seems to be working OK.

Per-Erik Makitalo (per-erik) wrote :

Juan. Exactly what other changes have you made to your system? I updated to 2.6.35-23 with update manager, and my internal mic doesn't work.

Juan Gonzalez (jglopez) wrote :

I just found out that the mic won't work from a cold boot, but once I suspend to RAM, it seems to be working fine after waking up.

Don't know if it's related, but the touchpad also acts up from a cold boot sometimes (unstable, jumpy cursor) and this gets fixed with a suspend-resume cycle as well.

Per-Erik Makitalo (per-erik) wrote :

My install is an out of the box ubuntu 10.10, upgraded with update manager. The internal mic is
still dead, no mater what I do. So the new kernel doesn't fix the problem, not for me anyhow.

@ #49

I can confirm the mic part. After waking-up it works fine.

Running Lubuntu 10.10 (with PulseAudio, kernel: 2.6.35-23-generic), suspend-resume did not work.

Nevyn (nevynh) wrote :

Is anything happening with this at all?

There appears to be two problems here:
1. I've not been able to get the microphone to work once - neither via external microphone or internal microphone.
2. Noise cancellation or something means that you have to shift the balance of the microphone essentially making it mono.

Now the question is, is anyone, anyone at all, actually working on this problem? Or are we sitting around hoping that something will change in alsa or the kernels?

So I'm at the same stage as Juan Gonzalez only I need this for 2,000 netbooks this year. If you're going to report something working, can you please provide full details? i.e. versions of applications (the kernel and alsa), what version of Ubuntu you're using etc.

I need this to be working in Lucid.

#53
Unless someone is working on this without saying, I don't think anyone is.

For some reason this bug got declined for Lucid (Declined for Lucid by Leann Ogasawara) also Status says 'Fix Released' for some reason?

I have very little programing experience, but if there's ANY way I can help, please let me know.

Nevyn (nevynh) wrote :

Okay - I've had a bit more of a thorough look.

If I shift the balance all the way to the left, the noise stops. All the way to right and center, noise.

Looking at the source code there was something about nomicbias which I'm hoping addresses the balance stuff though I'd have to get something from the microphone to get an idea of the balance issue.

So how do I go about getting the sound card working? By the looks of the source code, the only thing that differentiates the different models are verbs and more specifically, the vendor specific pins. HDA-Analyser is next to useless in this regard as it doesn't describe anything about what can and can't be set with with those pins.

Does anyone know how hard it would get to get that information?

Nevyn (nevynh) wrote :

The other thing to note: The inputs show up in sound preferences as Microphone 1, Microphone 2 and Line-In. I checked the balancing trick on each Microphone and it appears they are treated exactly the same. I'm guessing that the two microphones are actually the one stereo microphone?

Juan Gonzalez (jglopez) wrote :

FWIW, here's my situation. Just updated today. Versions are:
Ubuntu Maverick 2.6.35-24-generic
alsa-base 1.0.23+dfsg-1ubuntu4
(Alsa only - I don't have pulseaudio nor jack nor any Gnome/KDE audio-related stuff installed.)

The computer is an ASUS 1001PX-BLK033S.

The internal mic does not work from a cold boot. After I suspend to RAM and restore, it just works.

I am using Audacity to test it. Doesn't matter if I set the input to stereo or mono under "Preferences"; both seem to work, but only after a suspend-restore cycle.

If set to mono, Audacity only picks up the left audio channel; if set to stereo, picks up the same signal on both left and right channels. No noticeable noise other than the CPU fan. So, after a suspend-resume everything looks OK.

However, If I plug an external mic then, the computer believes it is a speaker and disables the internal speaker, but the internal mic still works. So, plugging an external mic does not work yet.

#57 Doesn't work for me, using:

ASUS 1001PX-BLK044S (not sure what differs 44S from 33S)
Lubuntu 10.10, 2.6.35-24-generic
ALSA 1.0.23

I used to have pulseaudio installed, but purged it together with pavucontrol.
I've tried muting one channel and also tried using both, all tests done were done with Audacity.

I also have the same problem with external microphones, the computer treats it as a speaker/headphone and disables the internal speaker.

Nevyn (nevynh) wrote :

The internal speaker switching thing shouldn't be too much of a hassle to figure out. It's just a verb thing I think. At this stage, it's really important to try and get a microphone working (for my scenario) - I can play around with the rest once I've gotten that bit of functionality going. I'm going to play with 10.10 and see if I can replicate #57.

#58 - That's a bit more interesting. A slightly different version of Alsa which I wouldn't have thought would have made too much of a difference. It might be interesting to do a diff on the source code for that module.

I'm hoping that if I am able to replicate #57, then it might be interesting to see what the module does on wake up. Of course, that adds the complication in providing a patch and people having to compile it themselves (unless someone wants to make up a ppa for it).

Nevyn (nevynh) wrote :

*grumble* Unable to replicate. I have a:
ASUS 1001PX-BLK042W

I'm guessing at the very least our first 100 are 042W's (I haven't seen the new laptops yet so they could very well be a slightly different model number).

So this could very well be multiple bugs - what works on the 033S doesn't look like it's going to work on the 044S and 042W.

I'll see if I can come up with a likely patch for the 033S - though I won't be able to test so it may or may not work.

As for the other two models - I'm at a complete loss. I'm guessing someone would have already done this, but I'm going to have a go loading up the drivers with the various models and see if any of them work with a microphone. That'll at least give me somewhere to start from.

Nevyn (nevynh) wrote :

I have been having a look at the output of lspci. It turns out the different cards can be differentiated. These are my results:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device 8437
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 46
        Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

The lspci attached to this bug report is thusly:
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device [1043:8442]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

The important line seems to be the subsystem. I've asked our vendor to contact Asus about possibly getting some information on the model I've got. Can I get some more results from "lspci -v" pertaining to the audio device from those having issues?

This should enable us to get an idea of how many different revisions there appear to be for this sound card and hopefully means we'll be able to fix a range of them.

Juan Gonzalez (jglopez) wrote :

My lspci -vv report is exactly the same as #61 save for the IRQ line, which shows 45 instead of 46.

My 'lspci -vv':

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device 8437
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 46
 Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Same as Juan Gonzalez, exactly the same result with an IRQ 45 instead of 46.

Paul Abrahams (abrahams) wrote :

Include me on the list of people with speaker/mike woes on an Asus laptop. My machine is a K60IJ. I'm running Kubuntu 10.10 with pulseaudio installed and everything fully updated. The result of lspci -vv is:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Santa Cruz Operation Device 1043
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 45
        Region 0: Memory at fe9f4000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

so I'm an IRQ45 case with an SCO subsystem rather than an Asus one, according to lspci.

I have problems on both the input and output sides, but the input is worse. I cannot get the built-in mike to work at all. I've been fiddling with alsamixer, pavucontrol, etc., to no avail. I've tried muting one side, switching from mike 1 to mike 2, and several other things. Nothing seems to help.

On the output side, there's great confusion between the internal speaker and the headphone. Since I have the headphone jack connected to an external speaker system, that's the one I want to have work. I finally discovered that the necessary settings in the pulseaudio volume control are:

Output devices port: analog headphones
Configuration: analog duplex
alsamixer: front muted (to turn off internal speakers)
  Unmuting front turns on internal speakers but does not affect headphone output
Independent hp: off

It also turns out that after starting up the sound, the internal speakers are unmuted, but unplugging and replugging the headphones mutes them.

All the sound components work correctly in my Windows partition, so the problem is clearly with the Linux software.

Paul Abrahams (abrahams) wrote :

Addendum: I just discovered that the external mike works as Microphone 1. So it's only the internal one that's the problem.

Paul Abrahams (abrahams) wrote :

Further discovery: the internal speaker isn't totally muted, but it's operating at what I would guess is the 5% level. Not enough to be of any use, though.

Nevyn (nevynh) wrote :

Paul Abrahams - can you file a separate bug report for your problems please? The solution that we come up with here might help you (though it seems kind of unlikely to me), but you're mostly just hijacking this bug report.

Read this page:
https://help.ubuntu.com/community/ReportingBugs

It's a whole other piece of hardware.

Milos Kovacik (kovacik-milos) wrote :

I have:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device 8442
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 45
 Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

same as frankbooth except:
    Subsystem: ASUSTeK Computer Inc. Device 8442
    Interrupt: pin A routed to IRQ 45

Nevyn (nevynh) wrote :

@Milos

Can you also provide the full model number? Have you tried the various solutions? i.e. putting to sleep and waking up and testing microphone then. Check with altered balance levels etc.

Milos Kovacik (kovacik-milos) wrote :

Asus EEE 1001PX
***********************
lshw
    description: Notebook
    product: 1001PX
    vendor: ASUSTeK Computer INC.
    version: x.x
    serial: ....
    width: 32 bits
    capabilities: smbios-2.6 dmi-2.6 smp-1.4 smp
***********************
cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"
***********************
ALSA version 1.0.23
***********************
uname -a
Kernel: 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 01:41:57 UTC 2010 i686 GNU/Linux
***********************
internal speakers: work OK
after connecting external speakers, external speakers work OK
***********************
I have to admit I haven't checked "sleep and waking up" so far. Usually I do not need hibernation feature.
***********************
playing with levels of microphone and Skype
levels:
  Master: L=R=83
  Headphone: L=R=98
  Speaker: L=R=98
  Microphone: L:0, R:91
Skype: sound OK, microphone doesn't work regardless internal or external speakers are connected
levels:
  Master: L=R=83
  Headphone: L=R=98
  Speaker: L=R=98
  Microphone: L=R=100
Skype: sound OK, microphone doesn't work regardless internal or external speakers are connected
levels:
  Master: L=R=83
  Headphone: L=R=98
  Speaker: L=R=98
  Microphone: L:91, R:0
Skype: sound OK, microphone doesn't work regardless internal or external speakers are connected
***********************
By the way it is not possible to enable Wifi in this kernel .. but this is, I think, different bug
when I start PC with Wifi enabled .. wifi works .. but it's not possible to turn it on (with Fn+F2) if started without

================================================================
I have also another bootup option with kernel: "Ubuntu, with Linux 2.6.32-25-generic"
here Skype works.. I use
levels:
  Master: L=R=83
  Headphone: L=R=98
  Speaker: L=R=98
  Microphone: L:0, R:91

and here also turning ON/OFF of WiFi works

I have not played so much with this kernel so far .. I use it just for Skype-ing

Nevyn (nevynh) wrote :

@Milos

On the bottom of your computer, where you'd find your serial number, it'll say something along the lines of:

ASUS 1001PX-BLK042W

The 042W seems to be kind of an indication of sub-versions or revisions. I'm looking to be able to map the different models to the type of sound card they have (i.e. the different models appear to have a slightly different implementation of the sound card).

So there are all sorts of "solutions" or "work arounds" for the 1001px but it's not clear what version of the sound card these work on. So if we can get an idea of what does and doesn't work, on various revisions of the sound card, we should be able to come up with solutions.

So those people who can load up snd-hda-intel with model=fujitsu and use model=lifebook to get the microphone and headphones working respectively is probably just a matter of looking at the verbs.

Those where sleep works, is probably a case of looking at the source code to see what happens when they wake up.

And those like me, where I'm unable to confirm whether the microphone works at all (i.e. there has never been a scenario where I've had the microphone working at all). This is probably going to require figuring out if any of the vendor pins need to be used and trying to reverse engineer them or getting information out of Asus about their implementation.

So it's kind of important to figure out what models there are, which laptops they affect, and what solutions work for which models.

Milos Kovacik (kovacik-milos) wrote :

it's 1001PX-BLK045S
MB REV 1001PX 24

Nevyn (nevynh) wrote :

Juan: Given that #61 has two pci id's and yours seems to be the odd one out - can you please confirm that your pci-id (under subsystem) is a 8437?

I've started charting the issues we're seeing.

If anyone has a 1001px WHI050S - given that an earlier report shows it to work out the the box bar the balance issue - I'd really like to know if I'm on the right track in terms of the sub system pci id's.

And if anyone else can help me complete this picture:
I need:

Full model number of laptop (at the bottom of the laptop on the same sticker as the serial number)
The full output of the subsystem line from running "lspci -vv" which pertains to the Audio device.
If any prior workarounds have worked for you.
If you have tried all of the suggestions on this bug report.

And please don't reference other messages while doing this as it makes it a little awkward. IRQ's shouldn't be important here so feel free to omit that detail.

Thanks,
Nevyn.

Juan Gonzalez (jglopez) wrote :

@Milos (#69): Try updating your BIOS to the latest version available from ASUS. IIRC, on this netbook, WiFi toggling via Fn+F2 is now handled in the BIOS, that's why recent kernels ignore it. This might not be relevant to the audio jack/internal mic issue, but I'm reporting here my BIOS version as well, just in case.

@Nevyn (#64): The Subsystem line shows a 8437 indeed. Here's all the info:

***********************
Model number:
ASUS 1001PX-BLK033S
MB REV 1001PX 12
***********************
BIOS info (pressing F2 on boot):
BIOS Revision 1102
EC Firmware Version EPCD-044
"Boot Booster" option is: disabled
***********************
kernel version:
2.6.35-24-generic
***********************
alsa-base version:
1.0.23+dfsg-1ubuntu4
***********************
pulseaudio version:
not installed
***********************
lspci -vv:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device 8437
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 44
 Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel
***********************
Workarounds:
-Suspending to RAM and resuming makes the internal microphone work, but external microphones never worked (they behave like an external speaker)

Juan Gonzalez (jglopez) wrote :

sorry - I meant @Milos (#71) and @Nevyn (#74). If there's any further data I can provide, feel free to ask.

Nevyn (nevynh) wrote :

@Juan
Thanks :) I think you may have just given me a solid lead.

@Everyone else
I'm unable to flash the BIOS (as an anti-theft measure, the BIOS has been locked by the vendor on the machine I have so that if it is stolen, the image asking people to call the support line if they have received the laptop isn't removable). So can someone have a go at flashing their BIOS with the latest version (I've currently got 0904 on this laptop but it should be 1104) and confirm whether this exhibits the behaviour Juan has described:
Running linux-image-2.6.35-23, with alsa-base 1.0.23. Putting the computer to sleep and waking it up seems to make the internal microphone work. The external microphone still isn't working but this shouldn't be too hard to figure out once we've got the internal mic working (hopefully).

Checked my BIOS, I've got 0802 (build date: 24/06/10)

Haven't come around to flashing it yet since I've been busy.
Is it possible to backup the BIOS or some other safety precautions I should take before going forward? (never flashed BIOS before)

***********************
Model & BIOS:
ASUS 1001PX-BLK044S
MB REV 1001PX 24
BIOS Revision 1102
EC Firmware Version EPCD-044
***********************
uname -a:
Linux 1001PX 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux
***********************
cat /proc/asound/version:
Advanced Linux Sound Architecture Driver Version 1.0.23.
***********************
lspci -vv:

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device 8437
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 45
 Region 0: Memory at f7cf8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel
***********************
Comments:
No PulseAudio. Suspend & resume does not work. Microphone balancing (100% left, 0% right | 0% left, 100% right) does not work.

Additional comments: I've got a 'Realtek ALC259' chip (not sure if that's been said before, or if it's of any use at all)

Good news! Managed to duplicate Juan's suspend/restore solution.
What I did:

1) Updated BIOS to 1102 (not sure if this step was needed, since I never tried step 2 before)
2) Followed these instructions for the latest drivers: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
3) Reboot, suspend & resume now enables the microphone.

Comments:

*No PulseAudio installed.
*Alsamixer now shows my chip as 'Realtek ALC269VB' (used to say ALC259).
*Microphone works fine in Audacity and Skype.

EdwardoiD (edward-sarkisyan) wrote :

It work's for me now. I just downloaded and compiled last stable kernel source from kernel.org. :)

Kernel version: 2.6.37.3

lsmod's output:

Module Size Used by
aes_i586 7280 2
aes_generic 26875 1 aes_i586
binfmt_misc 6412 1
parport_pc 26084 0
ppdev 5238 0
snd_hda_codec_realtek 248339 1
snd_hda_intel 21656 6
arc4 1165 2
ath9k 93026 0
snd_hda_codec 83326 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5072 1 snd_hda_codec
snd_pcm 71538 4 snd_hda_intel,snd_hda_codec
joydev 8743 0
i915 373043 3
snd_seq_midi 4652 0
mac80211 234133 1 ath9k
snd_rawmidi 17836 1 snd_seq_midi
drm_kms_helper 31725 1 i915
ath9k_common 2563 1 ath9k
drm 174055 4 i915,drm_kms_helper
uvcvideo 57275 1
ath9k_hw 269575 2 ath9k,ath9k_common
ath 13001 2 ath9k,ath9k_hw
cfg80211 138563 3 ath9k,mac80211,ath
snd_seq_midi_event 6047 1 snd_seq_midi
videodev 67493 2 uvcvideo
v4l1_compat 13519 2 uvcvideo,videodev
intel_agp 9842 1 i915
eeepc_wmi 3214 0
sparse_keymap 3406 1 eeepc_wmi
snd_seq 46801 2 snd_seq_midi,snd_seq_midi_event
snd_timer 18657 2 snd_pcm,snd_seq
snd_seq_device 5776 3 snd_seq_midi,snd_rawmidi,snd_seq
i2c_algo_bit 4704 1 i915
intel_gtt 12830 3 i915,intel_agp
psmouse 55873 0
snd 48853 19 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
video 11506 1 i915
serio_raw 3990 0
output 1851 1 video
soundcore 880 1 snd
snd_page_alloc 7280 2 snd_hda_intel,snd_pcm
agpgart 30657 3 drm,intel_agp,intel_gtt
lp 7181 0
shpchp 25010 0
parport 31531 3 parport_pc,ppdev,lp
ahci 18338 3
atl1c 28909 0
libahci 19074 1 ahci

Nevyn (nevynh) wrote :

@EdwardoiD

Can we have more details? What works? I did manage to get the internal microphone going but does external work as well? And how are the noise levels? I haven't been able to get below "jet engine" type noise.

Personally I'd like to not have to maintain a kernel if I can possibly avoid it (I've now got around 500 machines in the wild).

Ali AlNoaimi (el7r) wrote :

Confirmed on ubuntu 11.04

Nevyn (nevynh) wrote :

Have got the internal microphone working a treat with 2.6.32-31. Needed to upgrade to alsa 1.0.24. Have attached my first packaging attempt. Haven't quite deployed yet - looking to tweak volume settings.

Still haven't gotten the headphone/microphone port working properly though I believe (unconfirmed) headphones at the very least work.

Unfortunately, this also means I'm going to have to compile for each kernel release. Don't want to use dkms in this case as the compile time is fairly high.

So linux-image-2.6.32-31 is required. This is for Lucid. Could solve other sound card issues? Wasn't discriminant when compiling.

Boibec (ichbeck) wrote :

Hi everybody!

Three weeks ago I made a fresh install of Linux Mint 11 GNOME DVD 32 bit
http://www.linuxmint.com/edition.php?id=81

and now internal microphone works "out of the box"!

Speakers works fine. Headphones works too - you don't need to do anything.
External microphone doesn't work now, but I don't need it.

If somebody needs additional information about my 1001px just let me know.

I've bought my Asus 1001px one year ago and all that time I coudnt use the internal microphone.

Boibec (ichbeck) wrote :

By the way, internal mic works without any noise. I've made tests with Skype and sound recorder.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers