Ubuntu

[Samsung R720] Subwoofer don't mute when plugging headphones

Reported by i.NoD on 2010-11-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.10 x64 on Samsung R720 (Subsystem ID: 0x144dc051).
I have the similar problem with alsa as in 611803 ( https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/611803 ).
I've used hda_analyzer tool and figured out that subw pin is 17.

Daniel T Chen (crimsun) wrote :

We lack sufficient information, specifically codec dump, to continue. Please use apport-collect 677830.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
i.NoD (i.nod) wrote :
i.NoD (i.nod) wrote :

Hope that help.

My guess is that fix is exactly as in ( http://git.alsa-project.org/?p=alsa-kernel.git;a=commitdiff;h=d41185882b828896ccecac319c9f65f708baaf0d;hp=4cb36310848fd17766aa72afd1f2873f54b4e055 )
Just need new line with the right subsystem ID in alc662_fixup_tbl structure.

Daniel T Chen (crimsun) wrote :
tags: added: patch
Changed in alsa-driver (Ubuntu):
status: Incomplete → In Progress
tags: added: patch-forwarded-upstream
removed: patch
Daniel T Chen (crimsun) wrote :
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
i.NoD (i.nod) wrote :

Hello,

I've installed latest alsa-driver from Ubuntu Audio Dev PPA and all works like it should now.

Thanks a lot for your help.

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

i.NoD (i.nod) wrote :

Hi,

I've installed (Ubuntu 2.6.35-25.43-generic 2.6.35.10) kernel from -proposed, but unfortunately radeon driver introduced some nasty bugs in it. I can't use it for test or anything as my screen is now more or less a random colored pixels. You could find details in https://bugzilla.redhat.com/show_bug.cgi?id=664206.

Anyway, I've managed to start a preview on audio file and it seems that kernel fix isn't working for some reason (I can see same strange story in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/611803). In the same time, I'm positive that it works fine from Ubuntu Audio Dev PPA.

I can't give any additional details because of aforementioned video problem, can't even check audio preferences...

Brad Figg (brad-figg) wrote :

This patch was applied to Maverick as part of an upstream stable update, therefore it doesn't require individual verification.

tags: added: verification-done
removed: verification-needed
Andy Whitcroft (apw) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux - 2.6.38-1.27

---------------
linux (2.6.38-1.27) natty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: AUFS -- update aufs-update to track new locations of headers
  * ubuntu: AUFS -- update to c5021514085a5d96364e096dbd34cadb2251abfd
  * SAUCE: ensure root is ready before running usermodehelpers in it
  * correct the Vcs linkage to point to natty
  * rebase to linux tip e78bf5e6cbe837daa6ab628a5f679548742994d3
  * [Config] update configs following rebase
    e78bf5e6cbe837daa6ab628a5f679548742994d3
  * SAUCE: Yama: follow changes to generic_permission
  * ubuntu: compcache -- follow changes to bd_claim/bd_release
  * ubuntu: iscsitarget -- follow changes to open_bdev_exclusive
  * ubuntu: ndiswrapper -- fix interaction between __packed and packed
  * ubuntu: AUFS -- update to 806051bcbeec27748aae2b7957726a4e63ff308e
  * update package version to match payload version
  * rebase to e6f597a1425b5af64917be3448b29e2d5a585ac8
  * rebase to v2.6.38-rc1
  * [Config] updateconfigs following rebase to v2.6.38-rc1
  * SAUCE: x86 fix up jiffies/jiffies_64 handling
  * rebase to linus tip 2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] updateconfigs following rebase to
    2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] disable CONFIG_TRANSPARENT_HUGEPAGE to fix i386 boot crashes
  * ubuntu: AUFS -- suppress benign plink warning messages
    - LP: #621195
  * [Config] CONFIG_NR_CPUS=256 for amd64 -server flavour
  * rebase to v2.6.38-rc2
  * rebase to mainline d315777b32a4696feb86f2a0c9e9f39c94683649
  * rebase to c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] update configs following rebase to
    c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] disable CONFIG_AD7152 to fix FTBS on armel versatile
  * [Config] disable CONFIG_AD7150 to fix FTBS on armel versatile
  * [Config] disable CONFIG_RTL8192CE to fix FTBS on armel omap
  * [Config] disable CONFIG_MANTIS_CORE to fix FTBS on armel versatile

  [ Kees Cook ]

  * SAUCE: kernel: make /proc/kallsyms mode 400 to reduce ease of attacking

  [ Stefan Bader ]

  * Temporarily disable RODATA for virtual i386
    - LP: #699828

  [ Tim Gardner ]

  * [Config] CONFIG_NLS_DEFAULT=utf8
    - LP: #683690
  * [Config] CONFIG_HIBERNATION=n
  * update bnx2 firmware files in d-i/firmware/nic-modules

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
  * packaging: make System.map mode 0600
  * thinkpad_acpi: Always report scancodes for hotkeys
    - LP: #702407
  * sched: tg->se->load should be initialised to tg->shares
  * Input: sysrq -- ensure sysrq_enabled and __sysrq_enabled are consistent
  * brcm80211: include linux/slab.h for kfree
  * pch_dma: add include/slab.h for kfree
  * i2c-eg20t: include linux/slab.h for kfree
  * gpio/ml_ioh_gpio: include linux/slab.h for kfree
  * tty: include linux/slab.h for kfree
  * winbond: include linux/delay.h for mdelay et al

  [ Upstream Kernel Changes ]

  * mark the start of v2.6.38 versioning
  * rebase v2.6.37 to v2.6.38-rc2 + c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
    - LP: #689886
    - LP: #702125
    - LP: #608775
    - LP: #215802
...

Read more...

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.