Ubuntu

[Lenovo IdeaPad Y550A] Subwoofer don't mute/unmute on plugging external acoustics

Reported by RussianNeuroMancer on 2010-07-30
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
David Henningsson
Maverick
Medium
Unassigned

Bug Description

Binary package hint: pulseaudio

On Kubuntu 10.04 (ALSA only) I when I put headphones - speakers muted automatic.
On Ubuntu 10.10 (with PulseAudio) when I put headphones subwoofer still continue to sound until I select "Analog Headphones" channel instead of "Analog Speakers" channel in system sound options.
Tested on Intel HDA (in my case it's Realtek ALC272 chip).

== Regression details ==
Discovered in version: maverick
Last known good version: lucid

CVE References

Is there an "Analog Output" selection in the dropdown?

Yes. When it's selected only headphones work.

David Henningsson (diwic) wrote :

Hi RussianNeuroMancer and thanks for helping us test the upcoming release of Ubuntu!

I've trying to analyze your problem and notice that on HDA node 0x0C, the speaker is disabled. I don't understand how this can be though, because when the chip is set up, the node 0x0c should be initialized correctly.

Anyway, if you open "alsamixer -D hw:Intel", there should be a "speaker" bar, that you could try muting and unmuting (press the "M" button). Does that help?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete

> I've trying to analyze your problem and notice that on HDA node 0x0C, the speaker is disabled.
> I don't understand how this can be though, because when the chip is set up,
> the node 0x0c should be initialized correctly.
I also analyze issue deeper and found something funny.
In sound option selected "Analog Speaker" output.
1. Headphones not attached. I try to playback music. It's sound from speakers. All is fine.
2. Headphones is attached. I try to playback music. Music sound from headphone and... laptop subwoofer!
Laptop model: Lenovo Y550-4CWI.
Maybe it's not PulseAudio bug, but ALSA? Or still PulseAudio bug?

> Anyway, if you open "alsamixer -D hw:Intel", there should be a "speaker" bar,
> that you could try muting and unmuting (press the "M" button). Does that help?
Yes.

description: updated
Changed in pulseaudio (Ubuntu):
status: Incomplete → New
David Henningsson (diwic) wrote :

It's an ALSA bug. We need to figure out what node the subwoofer actually has, likely it is NID 0x15, but we need to verify that.
You can try doing this with hda_analyzer, it's available in the snd-hda-tools package in ubuntu-audio-dev's PPA. Do you know how to use hda_analyzer?

affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Incomplete

> It's an ALSA bug.
Not just a bug, but regression.

> Do you know how to use hda_analyzer?
No. Maybe tutorial somewhere?

Also, because few annoying bugs, I back to Lucid currently. I can continue test Maverick only next week, after Beta is out.

I check ubuntu-audio-dev ppa, but package snd-hda-tools not available for Maverick.

You can add package for Maverick to this PPA?

> likely it is NID 0x15, but we need to verify that
How I can veriy that?

I also attach screenshot of NID 0x15.

tags: added: regression-potential
Changed in alsa-driver (Ubuntu):
status: Incomplete → New
David Henningsson (diwic) wrote :

You can click both the "Mute" checkboxes and see if either one mutes the subwoofer.

Thanks!
I check - subwoofer is NID 0x17.

Now possible fix this issue?

summary: - Speakers not mute automatic when headphones attached
+ [Lenovo IdeaPad Y550] Subwoofer not mute automatic when headphones
+ attached

Cool! I have a first version of the patch here. First make sure https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules is *not* installed. Then install
http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-diwic-ideapad-y550-dkms_1.0.23_all.deb
and reboot. Please report back whether it fixes your problem or not. Thanks!

Changed in alsa-driver (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)

I can not install this package.
make.log attached.

David Henningsson (diwic) wrote :

Okay, I can reproduce that error here. Here's how to fix:

First:

sudo apt-get remove alsa-intel-hda-update-diwic-ideapad-y550-dkms

Then check if there are traces left with

sudo dkms status

If there are still traces (shows up as "alsa-intel-hda-update-diwic-ideapad-y550, 1.0.23: added" ), do:

sudo dkms remove -m alsa-intel-hda-update-diwic-ideapad-y550 -v 1.0.23 --all

Then download and install http://people.canonical.com/~diwic/temp/alsa-intel-hda-diwic-ideapad-y550-dkms_1.0.23.diwic_all.deb
Reboot and retry. Sorry for the inconvenience.

Thanks for this patch!
With this version of ALSA issue is fixed.

Can you please check another regression-potential bug? https://bugs.launchpad.net/ubuntu/+source/linux/+bug/606839

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
David Henningsson (diwic) wrote :

Cool. The good news is that upstream has accepted the patch. The bad news is that it contains fixes to generic stuff which makes me unsure whether this can go into Maverick or not.

In other words, a few days from now, it should work with upstream snapshot according to: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

For bug #606839, I don't know much about network drivers, so I'm not the one to look into it.

summary: - [Lenovo IdeaPad Y550] Subwoofer not mute automatic when headphones
- attached
+ [Lenovo IdeaPad Y550] Subwoofer don't mute/unmute on plugging external
+ acoustics

Please check same bug with Acer Aspire 8943G laptop: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/656625 (probably same easy fix can be applied for this laptop).

description: updated

Since the manufacturer has made some changes to the their product classification I rename bug. Lenovo support say Y550 and Y550A are similar in many aspects, but I think do a clarification was necessary.

summary: - [Lenovo IdeaPad Y550] Subwoofer don't mute/unmute on plugging external
+ [Lenovo IdeaPad Y550A] Subwoofer don't mute/unmute on plugging external
acoustics

David, has the fix landed in maverick ?

tags: added: regression-release
removed: regression-potential
Changed in alsa-driver (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Incomplete
description: updated
bm (bmpinky) wrote :

Hi everyone. Newbie on Ubuntu and I had the same problem on a HP-Compaq Desktop Small Form Factor. Where or when can I find a patch? Thank you.

David Henningsson (diwic) wrote :

@Jean-Baptiste, no. For faster processing, see

@bm, if you're having different hardware, please file a separate bug - open up a terminal window, then enter this command:
ubuntu-bug audio
...and follow the instructions.
Thanks!

Thanks for the update. Marking as triaged then.

Changed in alsa-driver (Ubuntu Maverick):
status: Incomplete → Triaged
bm (bmpinky) wrote :

Hi, it's me again. Workaround I used is putting on Sound Preferences/Output/Connector to "Analog Headphones". And "mute" on alsamixer/Speaker.

@bm follow comments 6. 9, 11 for find right PIN. After that create different bug report.

Gary M (garym) on 2010-10-29
tags: added: hda-jack-sense
madbiologist (me-again) wrote :

This bug is fixed upstream in kernel 2.6.37-rc1. From the changelog:

commit 6cb3b707f95954ac18f19b4b3919af235738371a
Author: David Henningsson
Date: Thu Sep 9 08:51:44 2010 +0200

    ALSA: HDA: Add fixup pins for Ideapad Y550

    By adding the subwoofer as a speaker pin, it is treated correctly when auto-muting.

    BugLink: https://launchpad.net/bugs/611803
    Signed-off-by: David Henningsson
    Signed-off-by: Takashi Iwai

A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

madbiologist (me-again) wrote :

This bug is now also fixed upstream in linux kernel 2.6.36.2.

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in alsa-driver (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

I enable proposed yesterday, but there no any alsa related packages in proposed. I try to install all proposed packages, but bug is still present.

Are you sure that the fix is in the proposed?

> but there no any alsa related packages in proposed
And, sure, I recheck it five minutes ago.

Martin Pitt (pitti) wrote :

This got fixed in the linux kernel, not in alsa-driver. Fixing task.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)

Today I get new updates from proposed. There is new chromium-browser build, new linux kernel (something about omap in changelog), but there is nothing about this bug. After apply this updates problem still here.
I not sure, but looks like fix not in proposed, or now fix not work for me.

David Henningsson (diwic) wrote :

Could you make sure that you're running version 2.6.35-25.43 of the kernel and that you have no alsa driver updates (or dkms updates) that might interfere?

1. Currently I have 2.6.35-25.43 kernel on this laptop.
2. No special alsa driver updates. Package from commentary #15 is removed.
3. In dkms status I see only nvidia modules.

Brad Figg (brad-figg) wrote :

This patch was applied to Maverick as part of an upstream stable update, therefore it doesn't require individual verification.

tags: added: verification-done
removed: verification-needed
David Henningsson (diwic) wrote :

@RussianNeuroMancer, that's strange. Can you supply an alsainfo ( https://wiki.ubuntu.com/Audio/AlsaInfo ) for further analysis? Thanks!

Launchpad Janitor (janitor) wrote :
Download full text (24.4 KiB)

This bug was fixed in the package linux - 2.6.35-25.44

---------------
linux (2.6.35-25.44) maverick-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/kms: properly compute group_size on 6xx/7xx"
    - LP: #703553

linux (2.6.35-25.43) maverick-proposed; urgency=low

  [ Brad Figg ]

  - LP: #697948

  [ Andy Whitcroft ]

  * [Config] add vmware-balloon driver to -virtual flavour
    - LP: #592039

  [ Manoj Iyer ]

  * SAUCE: Enable jack sense for Thinkpad Edge 13
    - LP: #685015

  [ Robert Hooker ]

  * Revert "(pre-stable): input: Support Clickpad devices in ClickZone
    mode"
    - LP: #669399

  [ Stefan Bader ]

  * Set virtual flavour maximum of domain visible memory to 70G
    - LP: #667796

  [ Takashi Iwai ]

  * SAUCE: input: Support Clickpad devices in ClickZone mode
    - LP: #516329

  [ Tim Gardner ]

  * [Config] Add nfsd modules to -virtual flavour
    - LP: #688070
  * [Config] Added autofs4.ko to -virtual flavour
    - LP: #692917

  [ Upstream Kernel Changes ]

  * intel_idle: delete substates DEBUG modparam
    - LP: #684888
  * intel_idle: delete power_policy modparam, and choose substate functions
    - LP: #684888
  * intel_idle: add support for Westmere-EX
    - LP: #684888
  * intel_idle: recognize Lincroft Atom Processor
    - LP: #684888
  * x86, mwait: Move mwait constants to a common header file
    - LP: #684888
  * intel_idle: Change mode 755 => 644
    - LP: #684888
  * intel_idle: add missing __percpu markup
    - LP: #684888
  * cpuidle: extend cpuidle and menu governor to handle dynamic states
    - LP: #684888
  * intel_idle: Voluntary leave_mm before entering deeper
    - LP: #684888
  * intel_idle: enable Atom C6
    - LP: #684888
  * intel_idle: simplify test for leave_mm()
    - LP: #684888
  * intel_idle: delete bogus data from cpuidle_state.power_usage
    - LP: #684888
  * intel_idle: add initial Sandy Bridge support
    - LP: #684888
  * intel_idle: do not use the LAPIC timer for ATOM C2
    - LP: #684888
  * staging: usbip: Notify usb core of port status changes
    - LP: #686158
  * staging: usbip: Process event flags without delay
    - LP: #686158
  * Staging: phison: fix problem caused by libata change
    - LP: #686158
  * perf_events: Fix bogus AMD64 generic TLB events
    - LP: #686158
  * perf_events: Fix bogus context time tracking
    - LP: #686158
  * powerpc/perf: Fix sampling enable for PPC970
    - LP: #686158
  * pcmcia: synclink_cs: fix information leak to userland
    - LP: #686158
  * sched: Drop all load weight manipulation for RT tasks
    - LP: #686158
  * sched: Fix string comparison in /proc/sched_features
    - LP: #686158
  * bluetooth: Fix missing NULL check
    - LP: #686158
  * futex: Fix errors in nested key ref-counting
    - LP: #686158
  * cifs: fix broken oplock handling
    - LP: #686158
  * libahci: fix result_tf handling after an ATA PIO data-in command
    - LP: #686158
  * mm, x86: Saving vmcore with non-lazy freeing of vmas
    - LP: #686158
  * x86, cpu: Fix renamed, not-yet-shipping AMD CPUID feature bit
    - LP: #686158
  * x86, kexec: Make sure to stop all CPUs before exiting the kernel
    - LP: #686158
  * x86, olpc: Don...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2011-02-10
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers