Ubuntu

[, Analog Devices ID 1981, Green Speaker, Internal] No sound at all

Reported by boskysquelch on 2012-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

no sound

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic-pae 3.2.27
Uname: Linux 3.2.0-30-generic-pae i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: z 2049 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4624000 irq 46'
   Mixer name : 'Analog Devices ID 1981'
   Components : 'HDA:11d41981,103c30d8,00100200 HDA:11c11040,103c1378,00100200'
   Controls : 5
   Simple ctrls : 3
CurrentDmesg:
 [ 18.584837] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
 [ 18.585047] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 27.296050] eth2: no IPv6 routers present
 [ 29.552030] eth0: no IPv6 routers present
Date: Sun Sep 16 05:52:46 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel failed
Symptom_Card: Built-in Audio - HDA Intel
Symptom_DevicesInUse:
 2049/dev/snd/controlC0: z F.... pulseaudio
 AND
Symptom_Jack: Green Speaker, Internal
Symptom_Type: No sound at all
Title: [, Analog Devices ID 1981, Green Speaker, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/10/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68MDU Ver. F.09
dmi.board.name: 30D8
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 83.0E
dmi.chassis.asset.tag: CNU8230X0J
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68MDUVer.F.09:bd01/10/2008:svnHewlett-Packard:pn:pvrF.09:rvnHewlett-Packard:rn30D8:rvrKBCVersion83.0E:cvnHewlett-Packard:ct10:cvr:
dmi.product.version: F.09
dmi.sys.vendor: Hewlett-Packard
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2012-09-16T04:58:05.301836

boskysquelch (boskysquelch) wrote :
Daniel Letzeisen (dtl131) wrote :

In dmesg:
[17.493144] init: alsa-restore main process (918) terminated with status 19

Unfortunately, that message is not uncommon and breaks audio. I personally am unsure how to fix/debug it. Maybe D Henningsson will have an idea on how to proceed.

In the meantime, you should remove the following line from /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=generic

boskysquelch (boskysquelch) wrote :

@Dave Lentz . Thank-you for your response. I will remove the line as suggested. I won't have access to the machine for a few days now but would welcome any other suggestions or instructions to provide more reports if requested.

I should also mention I have also tried a variety of other suggestions and followed other instructions as supplied by the Ubuntu Community covering Sound bugs/problem eg checking for mute in alsamixer. reinstalling alsa/pulse.

And I will confirm that this problem has only happened

But I had already covered most of the bases through my own experiences in the past. Usually I have managed to resolve issues logically and methodically over the YEARS when this_similar Sound problems have occured...but this has really thrown me. Nothing obvious to me has worked. And chose to throw in this bug as it appeared very recently after minimal updating. And has not been resolved with a complete wipe of hard drive, reinstallation of 12.04 with a Canonical_LoCo provided readymade disc.

One positive observation was that an addition_plugin to pulse controller( the pauv_thingy) was that the system acknowledge that sound was being played(using youtube) and the level indicator demonstrated this with a moving bar pulsing to beats.

Sorry not a very good description... but it gave me some reassurance that sound data was being processed yet not being produced audibly, from the speakers.

Finally. May I ask if the descriptor of the bug is correct?
I am reporting that the onboard speakers no longer produce sound.
However sound IS produced if I use a usb powered speaker set through the headphones jack socket.

I admit I was a bit confused as what to put whilst filling out the apport requests. My bad. :/

Raymond (superquad-vortex2) wrote :

your are using generic codec parser instead of patch_analog.c

 0x03 [Audio Output] wcaps 0x441: Stereo
  Device: name="HDA Generic", type="Audio", device=0
  Converter: stream=8, channel=0
  Power states: D0 D3
  Power: setting=D0, actual=D0
  Processing caps: benign=1, ncoeff=70
Node 0x04 [Audio Input] wcaps 0x100511: Stereo
  Device: name="HDA Generic", type="Audio", device=0
  Converter: stream=4, channel=0
  SDI-Select: 0
  PCM:
    rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
    bits [0x6]: 16 20
    formats [0x1]: PCM
  Power states: D0 D3
  Power: setting=D0, actual=D0
  Connection: 1
     0x15

boskysquelch (boskysquelch) wrote :

@Raymond thanks for that. I am currently reading through this http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio.txt .

Not with the box ...agin...I was earlier..now I'm 50 miles from it...but as and when I implement a fix I will come back, report how I fixed it and update this bug report.

Thanks again. :)

boskysquelch (boskysquelch) wrote :

still stumped as to where and what I should further edit to use patch_analog.c

Anyone care to instruct?

boskysquelch (boskysquelch) wrote :

sorry still can't see what I am to do. :(

boskysquelch (boskysquelch) wrote :

the above is now alsa-base conf is now

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

options snd-hda-intel model=ref position_fix=1

having used the following command

echo "options snd-hda-intel model=ref position_fix=1" | sudo tee -a /etc/modprobe.d/alsa-base.conf > /dev/null

I think_know I not doing something simple correctly. can't see the wood for the trees. :(

boskysquelch (boskysquelch) wrote :

 I have jus run the ALSA Information Script v 0.4.61.

the txt provide is the result.

Raymond (superquad-vortex2) wrote :
boskysquelch (boskysquelch) wrote :

Please could someone tell me what to do.

I have spent hours and hours reading, writing, tapping Googling, reading, reading, reading and attempts at editing.

I presumed I would have to use the above patch. How do I do that?

How do I get this resolved please?

I want instructions please.

Raymond (superquad-vortex2) wrote :

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commitdiff;h=18a815d7426986890b88078ea63b77732baca0b5;hp=42611c02ac31e44abd53893209460ce60205cb8e

/* mute internal speaker if HP is plugged */
static void ad1981_hp_automute(struct hda_codec *codec)
{
       unsigned int present;

       present = snd_hda_codec_read(codec, 0x06, 0,
                                    AC_VERB_GET_PIN_SENSE, 0) & 0x80000000;
       snd_hda_codec_amp_update(codec, 0x05, 0, HDA_OUTPUT, 0,
                                0x80, present ? 0x80 : 0);
       snd_hda_codec_amp_update(codec, 0x05, 1, HDA_OUTPUT, 0,
                                0x80, present ? 0x80 : 0);
}

if you look at figure 1 functional block diagram

port A and port D only have selector to select dac 0x03 or mixer 0x0e

but ad1981_hp_automute seem treat them as mixer instead of selector

you must send email to the author who added the suuport of ad1981hd

Node 0x05 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
  Control: name="Master Playback Switch", index=0, device=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals: [0x00 0x00]
  Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
  Amp-Out vals: [0x3f 0x3f]
  Pincap 0x0001173f: IN OUT HP EAPD Detect Trigger ImpSense
    Vref caps: HIZ 50 GRD 80
  EAPD 0x2: EAPD
  Pin Default 0x92174110: [Fixed] Speaker at Int Front
    Conn = Analog, Color = Green
    DefAssociation = 0x1, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x40: OUT VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Connection: 2
     0x03 0x0e*
Node 0x06 [Pin Complex] wcaps 0x400185: Stereo Amp-Out
  Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
  Amp-Out vals: [0x3f 0x3f]
  Pincap 0x0000001f: OUT HP Detect Trigger ImpSense
  Pin Default 0x0321201f: [Jack] HP Out at Ext Left
    Conn = 1/8, Color = Grey
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0xc0: OUT HP
  Unsolicited: tag=37, enabled=1
  Connection: 2
     0x03 0x0e*

boskysquelch (boskysquelch) wrote :

I have just reinstalled 12.04 to see if anything would resolve itself. No luck.

I have sent the author an email to ask him to look at this.

Thank-you.

Raymond (superquad-vortex2) wrote :

there is only one combined volume control for speaker and headphone

so it iis unlikly for pulseaudio to find two path for headphone and speaker

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 63 [100%] [3.00dB] [on]
  Front Right: Playback 63 [100%] [3.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]

 active profile: <output:analog-stereo>
 sinks:
  alsa_output.pci-0000_00_1b.0.analog-stereo/#4: Built-in Audio Analogue Stereo
 sources:
  alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#6: Monitor of Built-in Audio Analogue Stereo
 ports:
  analog-output-speaker: Speakers (priority 10000, available: unknown)
   properties:

  analog-output-headphones: Headphones (priority 9000, available: unknown)
   properties:

  analog-input: Analogue Input (priority 10000, available: unknown)
   properties:

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
boskysquelch (boskysquelch) wrote :

still nothing.

Raymond (superquad-vortex2) wrote :

can you provide the pulsesink.txt by apport-bug.?

Node 0x0e [Audio Mixer] wcaps 0x200101: Stereo
  Connection: 8
     0x0d 0x11 0x12 0x13 0x1a 0x1b 0x1c 0x1d

Node 0x11 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Control: name="PCM Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="PCM Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals: [0x1f 0x1f]
  Connection: 1
     0x03

refer to ad1981hd datasheet

05 Port-D (Line Out) 4 Pin complex Port-D pin drivers. Typically used as rear panel line output.

06 Port-A (Headphone Out) 4 Pin complex Port-A pin drivers. Typically used as front panel headphone output

0E Analog Mixer 2 Audio mixer Selectively mixes analog input signals into a single signal.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers