Broken auto-mute with Realtek ALC889 chipset after 12.04 upgrade

Bug #1037820 reported by gidantribal on 2012-08-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Acer Aspire 6920G, ICH8 chipset, ALC889 audio
Linux gidan-notebook 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

What is expected to happen is when one plugs headphones into the audio jack of the powered off computer, boots the computer up, and when logged into the OS, play some music via VLC or Flash audio, remove the headphones from the audio jack, the audio switches from the headphones to the speakers automatically.

What happens instead is it does not.

This is a regression from 11.10.

This problem does not occur when using the repo Ubuntu kernel 3.2.0-29-generic and ALSA drivers (dkms-hda - 0.201208302203~precise1) https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+sourcepub/2626453/+listing-archive-extra .

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-29-generic 3.2.0-29.46
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gidan 2310 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc300000 irq 48'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,10250146,00100004 HDA:11c11040,10250146,00100200'
   Controls : 33
   Simple ctrls : 19
Date: Fri Aug 17 00:38:28 2012
HibernationDevice: RESUME=UUID=5d28ae79-1f15-447a-a660-2085428d7152
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Acer Aspire 6920
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=7c845f9d-d485-44d7-86fb-7ddc0e5891bf ro splash quiet vga=786 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-29-generic N/A
 linux-backports-modules-3.2.0-29-generic N/A
 linux-firmware 1.79
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-05-21 (87 days ago)
WifiSyslog:

dmi.bios.date: 01/22/10
dmi.bios.vendor: Acer
dmi.bios.version: V1.16
dmi.board.name: Aspire 6920
dmi.board.vendor: Acer
dmi.board.version: Aspire 6920
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrV1.16:bd01/22/10:svnAcer:pnAspire6920:pvrAspire6920:rvnAcer:rnAspire6920:rvrAspire6920:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 6920
dmi.product.version: Aspire 6920
dmi.sys.vendor: Acer

gidantribal (aedo999) wrote :
Brad Figg (brad-figg) on 2012-08-16
Changed in linux (Ubuntu):
status: New → Confirmed
gidantribal (aedo999) on 2012-08-16
description: updated
summary: - Broken auto-mute with Realtek ALC262 chipset after 12.04 upgrade
+ Broken auto-mute with Realtek ALC889 chipset after 12.04 upgrade

gidantribal, thank you for reporting this and helping make Ubuntu better.

Could you please provide the information following https://wiki.ubuntu.com/DebuggingSoundProblems ?

As well, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
gidantribal (aedo999) wrote :

followed information and performed action as per https://wiki.ubuntu.com/DebuggingSoundProblems.

tags: added: kernel-sound
gidantribal (aedo999) wrote :

Version 3.6.0-030600rc3-generic_3.6.0-030600rc3 tested, audio not recognized at all.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.6.0-030600rc3

gidantribal, thank you for testing the mainline kernel.

Regarding your test https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1037820/comments/3 , you upgraded to the newest ALSA snapshot and nothing changed?

gidantribal (aedo999) wrote :

Actually I had skipped this step and I have to say my bad, because I found out the bug seems to be solved in HDA-DKMS!

Now I plug the earphones and the speakers are properly muted. Unmuted after unplugging. I will double check no further regression will pup up!

Details:
dkms-hda - 0.201208292203~precise1
[https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+sourcepub/2626453/+listing-archive-extra]

Thanks a lot for your help

gidantribal (aedo999) wrote :

Actually I found out that the speakers muted after another reboot of the machine.. I had to uninstall the DKMS package and reinstall it (newer version, dkms-hda - 0.201208302203~precise1 ). Now the switching between earphones and speakers seems to work again, I will investigate how to reproduce the bug again.

gidantribal (aedo999) wrote :

I can confirm, the HKMS version of the ALSA drivers (dkms-hda - 0.201208302203~precise1) do not fix the bug, cause the audio is driven only by earphones after Suspend operation.

gidantribal, just to clarify, when you use the repo Ubuntu kernel 3.2.0-29-generic and ALSA drivers (dkms-hda - 0.201208302203~precise1), the bug occurs when coming back from a suspend, but not when coming up from a fresh boot?

gidantribal (aedo999) wrote :

yes, exactly.

gidantribal, ok. Regarding your Bug Description, were you reporting a problem coming up from a fresh boot or resuming from suspend?

David Raid (davidraid) wrote :

I've had this same problem. Oddly, the bug isn't present in the beta for 12.10.

gidantribal (aedo999) wrote :

@Christopher the bug is at boot with normal drivers, the description in #8 (bug at suspend) is with DMS drivers.

gidantribal, ok. Let us remain focused on one bug at boot for now.

Hence, to further focus this report down, I would like to redo the Bug Description to say:

<START>
Acer Aspire 6920G, ICH8 chipset, ALC889 audio
Linux gidan-notebook 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

What is expected to happen is when one plugs headphones into the audio jack of the powered off computer, boots the computer up, and when logged into the OS remove the headphones from the audio jack, the audio switches from the headphones to the speakers automatically.

What happens instead is it does not.

This is a regression from 11.10.

This problem does not occur when using the repo Ubuntu kernel 3.2.0-29-generic and ALSA drivers (dkms-hda - 0.201208302203~precise1) https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+sourcepub/2626453/+listing-archive-extra .
<END>

Is this change acceptable for you?

BTW, what program specifically are you using when you notice this problem (ex. Amarok, VLC, etc.)?

gidantribal (aedo999) wrote :

@Christopher, the description is fine for me (though we do not underline that the solution of DKMS drivers is partial). It happened using VLC and/or flash audio, but I double checked with the audio tests, of course.

gidantribal, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1037820/comments/15 :
>"@Christopher, the description is fine for me (though we do not underline that the solution of DKMS drivers is partial)."

This is intentional. Introducing a problem with standby is usually considered a separate bug, and may introduce unnecessary complexity into this report. Hence, let us leave this out for now, and once we have a Fix Released for this bug report, a new report should be opened by you to report any remaining bugs with the fix applied (ex. standby).

Toggling package to alsa-driver as problem was found to be in it. Please reassign if incorrect package or procedure.

Marking Triaged as newest alsa-daily tested, and all debugging information provided.

affects: linux (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
description: updated
gidantribal (aedo999) wrote :

errata corrige - today (probably after new kernel update) the reboot doesn't work: no audio at all, only from earphones! I i plug the earphones I have audio, when I unplug them no audio is restored from the speakers. Result: ubuntu inusable. switching to windows at least for the moment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers