Ubuntu

[Gateway 504GR, Realtek ALC880] Needed to manually modprobe snd-hda-intel

Reported by Richard Simpson on 2012-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I was having no sound; I did 'find /lib/modules/`uname -r` | grep snd' and found drivers were installed.
lspci -v | grep -A7 -i "audio" produced the following output:

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
 Subsystem: Gateway 2000 Device 4037
 Flags: bus master, fast devsel, latency 0, IRQ 11
 Memory at 73100000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel modules: snd-hda-intel

then I:
sudo modprobe snd-hda-intel

after which sound is now working. I have added it to my /etc/modules. I have not yet rebooted to confirm persistance.

I am running Ubuntu 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic-pae 3.2.18
Uname: Linux 3.2.0-25-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC880 Analog [ALC880 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: magnum 1569 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x73100000 irq 45'
   Mixer name : 'Realtek ALC880'
   Components : 'HDA:10ec0880,08600000,00090000'
   Controls : 29
   Simple ctrls : 17
Date: Tue Jun 19 11:11:27 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel successful
Symptom_Card: Built-in Audio - HDA Intel
Symptom_DevicesInUse:
 1569 magnum F.... pulseaudio
     PID ACCESS COMMAND
Symptom_Jack: Line Out, N/A
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: No sound at all
Title: [504GR, Realtek ALC880, Line Out, N/A] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/08/2004
dmi.bios.vendor: Intel Corp.
dmi.bios.version: AG91510J.15A.0579.2004.1008.1003
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: D915GAG
dmi.board.vendor: Intel Corporation
dmi.board.version: AAC77881-304
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrAG91510J.15A.0579.2004.1008.1003:bd10/08/2004:svnGateway:pn504GR:pvr:rvnIntelCorporation:rnD915GAG:rvrAAC77881-304:cvn:ct2:cvr:
dmi.product.name: 504GR
dmi.sys.vendor: Gateway

Richard Simpson (magnum1997) wrote :
description: updated
summary: - No sound at all for onbaord Intel
+ [Gateway 504GR, Realtek ALC880] Needed to manually modprobe snd-hda-
+ intel
Raymond (superquad-vortex2) wrote :

how many audio jacks at rear panel ?

any coaxial or optical jack ?

try model=3stack or model=3stack-digout

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commitdiff;h=67b6ec3196da235317ff1b9474f17379b78f3294;hp=29e3fdcc84e5da04cb7e6a36fee0a772c91d3b28

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers