alpine does not obsolete pine, package install fails

Bug #345813 reported by gcc on 2009-03-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alpine (Debian)
Fix Released
Unknown
alpine (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrade from gutsy to hardy:

chris@rocio(~)$ sudo apt-cache policy pine
pine:
  Installed: 4.64
  Candidate: 4.64
  Version table:
 *** 4.64 0
        100 /var/lib/dpkg/status

chris@rocio(~)$ apt-cache policy alpine
alpine:
  Installed: (none)
  Candidate: 1.0+dfsg-3
  Version table:
     1.0+dfsg-3 0
        500 http://gb.archive.ubuntu.com hardy/universe Packages

chris@rocio(~)$ sudo apt-get install alpine
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed
  alpine
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/2794kB of archives.
After this operation, 6291kB of additional disk space will be used.
(Reading database ... 217777 files and directories currently installed.)
Unpacking alpine (from .../alpine_1.0+dfsg-3_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/alpine_1.0+dfsg-3_i386.deb (--unpack):
 trying to overwrite `/usr/share/man/man1/rpload.1.gz', which is also in package pine
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/alpine_1.0+dfsg-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The alpine package should conflict with and replace pine if they can't both be installed at the same time.

chris@rocio(~)$ lsb_release -rd
Description: Ubuntu 8.04.2
Release: 8.04

gcc (chris+ubuntu-qwirx) wrote :
Changed in alpine (Debian):
status: Unknown → New
Charlie_Smotherman (cjsmo) wrote :

I have set up a bzr branch with gcc fix

https://code.edge.launchpad.net/~cjsmo/+junk/alpine

Attaching a diff also

Best regards

Charlie Smotherman

Changed in alpine (Ubuntu):
status: New → Confirmed
Andreas Moog (ampelbein) wrote :

There is no package named "pine" with published binaries in ubuntu.

Changed in alpine (Ubuntu):
status: Confirmed → Invalid
Geoffrey Thomas (geofft) wrote :

Even so, it's possible for people to have the pine package installed. The source package is provided in

http://archive.ubuntu.com/ubuntu/pool/multiverse/p/pine/

with the intention of people building it manually because binaries can't be distributed (see debian/rules). So the packaging for alpine should be fixed, because Ubuntu intends you to have binary pine packages, whether or not archive.ubuntu.com has the built versions of those packages.

Changed in alpine (Ubuntu):
status: Invalid → New
Changed in alpine (Debian):
status: New → Fix Committed
Changed in alpine (Debian):
status: Fix Committed → Fix Released
Evan Broder (broder) wrote :

Ubuntu now carries 2.02-3; this bug was fixed in 2.02-2.

Changed in alpine (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.