alacarte crashed with AttributeError in split()

Bug #187919 reported by sojourner on 2008-02-01
418
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Alacarte Menu Editor
Fix Released
Medium
alacarte (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: alacarte

to reproduce open alacarte and check a menu item , note ! alacarte crashes but does not exit can be crashed multiple times.

ProblemType: Crash
Architecture: amd64
Date: Thu Jan 31 20:45:51 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/alacarte
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: alacarte 0.11.3-1ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python -OOt /usr/bin/alacarte
ProcCwd: /home/ron
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/alacarte']
SourcePackage: alacarte
Title: alacarte crashed with AttributeError in split()
Uname: Linux ron-desktop 2.6.24-5-generic #1 SMP Thu Jan 24 19:29:14 UTC 2008 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dhcp dialout dip fax floppy haldaemon lpadmin netdev plugdev powerdev scanner users video

sojourner (itsmealso2) wrote :
sojourner (itsmealso2) wrote :

further investigation shows it is only trying to add the item "debian" that causes the problem

Pedro Villavicencio (pedro) wrote :

thanks for your report.

Changed in alacarte:
assignee: nobody → amaranth
importance: Undecided → Medium
status: New → Triaged
miked (miked11) wrote :

Me too.
root@2HewittRand-desktop:~# gksudo cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
root@2HewittRand-desktop:~#
Hardy Heron 8.04 Alpha 4

ShadowMax (shadowmax76) wrote :

I have the same problem after upgrading from Gutsy Gibbon to Hardy Heron 8.04 Alpha 6 (x86)

coubi64 (frederic-valentin) wrote :

Same problem for me when trying to delete a "Debian" menu inside Gnome "Applications" menu:

frederic@PC-portable-PB:~$ alacarte
/usr/lib/python2.5/site-packages/apt/progress.py: inconsistent use of tabs and spaces in indentation
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 430, in on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 215, in setVisible
    self.__writeMenu(item, no_display=True)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 576, in __writeMenu
    file_id = os.path.split(menu.get_desktop_file_path())[1]
  File "/usr/lib/python2.5/posixpath.py", line 77, in split
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'

Linuxadditc (boinaverde1996) wrote :

this happens when I try to remove wine from the menu list

Tom rooze.sen (tomrooze-sen) wrote :

further investigation shows it is only trying to add the item "debian" that causes the problem

tom rooze wrote:
> further investigation shows it is only trying to add the item "debian"
> that causes the problem
>
>
HI Tom

Thx a lot for the feedback

Regards

coubi64 (frederic-valentin) wrote :

Problem still exists (when trying deleting Debian menu in 'Applications'):

frederic@PC-portable-PB:~$ alacarte
/usr/lib/python2.5/site-packages/apt/progress.py: inconsistent use of tabs and spaces in indentation
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 430, in on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 215, in setVisible
    self.__writeMenu(item, no_display=True)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 576, in __writeMenu
    file_id = os.path.split(menu.get_desktop_file_path())[1]
  File "/usr/lib/python2.5/posixpath.py", line 77, in split
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'
frederic@PC-portable-PB:~$

Bernhard Schuster (drahnr) wrote :

This bug is still alive. Whenerver I try to delete a folder from my menu, it gives me that crash/error.

LeoSolaris (quiet-style) wrote :

I decided to change my menu around a little, and it crashed (without closing) when I went to properties, and when I tried to check or uncheck folders.

Dell Inspiron 1520
Hardy 8.04 32-bit

fenris@thinkbuntu:~$ alacarte
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 430, in on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 215, in setVisible
    self.__writeMenu(item, no_display=True)
  File "/usr/lib/python2.5/site-packages/Alacarte/MenuEditor.py", line 576, in __writeMenu
    file_id = os.path.split(menu.get_desktop_file_path())[1]
  File "/usr/lib/python2.5/posixpath.py", line 77, in split
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'
fenris@thinkbuntu:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

michaelries (ubuntu-mikeries) wrote :

Every other check box works, except Cedega's TransGaming menu.
After final release of Hardy, I upgraded from Gutsy.

**** From console, after clicking checkbox:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/Maitype filter textnWindow.py", line 99, in loadUpdates
    item_id = os.path.split(items[iter][3].get_desktop_file_path())[1]
  File "/usr/lib/python2.5/posixpath.py", line 77, in split
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'

**** Right clicking and choosing Properties on the menu gives:
/usr/lib/python2.5/site-packages/apt/progress.py: inconsistent use of tabs and spaces in indentation
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 367, in on_edit_properties_activate
    parser.write(open(file_path))
IOError: [Errno 2] No such file or directory: 'alacarte-made.directory'

Looking in my /home/michael/.local/share/applications directory, there's no alacarte-made.directory, not sure if I'm looking in the right place. I tried restoring a copy of alacarte-made.directory from a backup made before the upgrade, and I get the following when right clicking and choosing properties:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 367, in on_edit_properties_activate
    parser.write(open(file_path))
  File "/usr/lib/python2.5/site-packages/Alacarte/util.py", line 69, in write
    file_object.write('[Desktop Entry]\n')
IOError: [Errno 9] Bad file descriptor

Javier AN (fjanavas) wrote :

Thks for the support,

still same crash on latest 8.04 from7.10 update

deleting any directory

it says to restar app and then everything fine

Forwarded upstream to GNOME Bugzilla.

Changed in alacarte:
status: Unknown → New
Changed in alacarte:
assignee: amaranth → nobody
Jon Arnold (jonarnoldsemail) wrote :

I get this error after upgrading to Intrepid with a ".hidden" folder in my main menu. It happens when I try to uncheck it or delete it, or even move it.

Should i make a seperate bug report?

Freak (thenetfreaker) wrote :

1. why do you have a hidden folder in your main menu ?
2. why do you need it there ?
3. If it keeps appearing after deleting it, it should me there...
(especially if it happens after a restart)
4. why do you ask me ?
5 why not try reporting it...

manuel (tepazepam) wrote :

----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Sat, 11 Oct 2008 00:32:09 +0000
> Subject: Re: [Bug 187919] Re: alacarte crashed with AttributeError in split()
>
> 1. why do you have a hidden folder in your main menu ?
> 2. why do you need it there ?
> 3. If it keeps appearing after deleting it, it should me there...
> (especially if it happens after a restart)
> 4. why do you ask me ?
> 5 why not try reporting it...
>
> --
> alacarte crashed with AttributeError in split()
> https://bugs.launchpad.net/bugs/187919
> You received this bug notification because you are a direct subscriber
> of the bug.

LO SIENTO PERO NO ENTIENDO NADA DE TU IDIOMA. POCO PUEDO AYUDAR. CREÍA QUE CON SOLO ENVIAR EL INFORME YA AYUDABA A LA COMUNIDAD, NO PUEDO HACER MÁS
_________________________________________________________________
Prueba los prototipos de los últimos en MSN Motor
http://motor.es.msn.com/

Ahmet Sezen (asezen) wrote :

Could someone explain me why am i getting these mails? I have got NO
relationship with alacarte?

Regards

On Sat, Oct 11, 2008 at 11:51 AM, manuel <email address hidden> wrote:
>
> ----------------------------------------
>> From: <email address hidden>
>> To: <email address hidden>
>> Date: Sat, 11 Oct 2008 00:32:09 +0000
>> Subject: Re: [Bug 187919] Re: alacarte crashed with AttributeError in split()
>>
>> 1. why do you have a hidden folder in your main menu ?
>> 2. why do you need it there ?
>> 3. If it keeps appearing after deleting it, it should me there...
>> (especially if it happens after a restart)
>> 4. why do you ask me ?
>> 5 why not try reporting it...
>>
>> --
>> alacarte crashed with AttributeError in split()
>> https://bugs.launchpad.net/bugs/187919
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>
>
> LO SIENTO PERO NO ENTIENDO NADA DE TU IDIOMA. POCO PUEDO AYUDAR. CREÍA QUE CON SOLO ENVIAR EL INFORME YA AYUDABA A LA COMUNIDAD, NO PUEDO HACER MÁS
> _________________________________________________________________
> Prueba los prototipos de los últimos en MSN Motor
> http://motor.es.msn.com/
>
> --
> alacarte crashed with AttributeError in split()
> https://bugs.launchpad.net/bugs/187919
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Alacarte Menu Editor: New
> Status in "alacarte" source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: alacarte
>
> to reproduce open alacarte and check a menu item , note ! alacarte crashes but does not exit can be crashed multiple times.
>
> ProblemType: Crash
> Architecture: amd64
> Date: Thu Jan 31 20:45:51 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/alacarte
> InterpreterPath: /usr/bin/python2.5
> NonfreeKernelModules: nvidia
> Package: alacarte 0.11.3-1ubuntu1
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python -OOt /usr/bin/alacarte
> ProcCwd: /home/ron
> ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/alacarte']
> SourcePackage: alacarte
> Title: alacarte crashed with AttributeError in split()
> Uname: Linux ron-desktop 2.6.24-5-generic #1 SMP Thu Jan 24 19:29:14 UTC 2008 x86_64 GNU/Linux
> UserGroups: adm admin audio cdrom dhcp dialout dip fax floppy haldaemon lpadmin netdev plugdev powerdev scanner users video
>

Freak (thenetfreaker) wrote :

I think it's because bad headers from the Ubuntu Team side... lol..
because not only i'm not connected to them, i'm a simple user just as you :)

luiz.mineo (luiz-mineo) wrote :

It was originally a bug report. I think all of us reported this bug
during the beta fase of hardy (I did),
But I don't no why it turned into an e-mail thread.

2008/10/11 Freak <email address hidden>:
> I think it's because bad headers from the Ubuntu Team side... lol..
> because not only i'm not connected to them, i'm a simple user just as you :)
>
> --
> alacarte crashed with AttributeError in split()
> https://bugs.launchpad.net/bugs/187919
> You received this bug notification because you are a direct subscriber
> of the bug.
>

luiz.mineo (luiz-mineo) wrote :

*I don't know....

Sorry for my bad english

2008/10/11 Luiz Mineo <email address hidden>:
> It was originally a bug report. I think all of us reported this bug
> during the beta fase of hardy (I did),
> But I don't no why it turned into an e-mail thread.
>
> 2008/10/11 Freak <email address hidden>:
>> I think it's because bad headers from the Ubuntu Team side... lol..
>> because not only i'm not connected to them, i'm a simple user just as you :)
>>
>> --
>> alacarte crashed with AttributeError in split()
>> https://bugs.launchpad.net/bugs/187919
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>

Freak (thenetfreaker) wrote :

me neither ... ;)

Evan Buswell (ebuswell) wrote :

When you report a bug, it places you on the email update list, so
changes in the status of the bug are forwarded to you. If you want
that to stop, go to https://bugs.launchpad.net/bugs/187919, log in,
and remove yourself from the updates list.

This is standard procedure for all bugs you report. Usually, either a
bug is widespread and short-lived or rare and long-lived. Since this
is long-lived and widespread (grumble, grumble...), these scattered
updates are taking y'all by surprise.

Naaman Campbell (naamanc) wrote :

Still present in Karmic Alpha 5.

Graham F (gandalfmeister) wrote :

still present in Karmic beta

Fred Korz (korz-vendor) wrote :

and in Karmic as dist-upgraded from Jaunty (9.04) 2 days after the Karmic release on 2009.10.29

altima (timashkov) wrote :

Ubuntu 9.10. when trying to remove a menu item that is left there after removing the programme.

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- דניאל

דניאל קוליעקוב
Student at Sami Shammon college
Israel

Confirm that you know דניאל קוליעקוב
https://www.linkedin.com/e/vwbysv-gcki7yaz-3j/isd/1540194885/Czd07_BU/

------
(c) 2010, LinkedIn Corporation

Changed in alacarte:
importance: Unknown → Medium
Dave Stroud (bigdavesr) wrote :

this is now happening on 11.10. alpha 2

Nicolas Diogo (nicolasdiogo) wrote :

this is now happening on 11.10. alpha 2

Changed in alacarte:
status: New → Fix Released
Nazar Mokrynskyi (nazar-pc) wrote :

Again, Ubuntu 13.04 with newest alacarte.
Occurs when try to edit category item. Properties window doesn't appear.

Pavel Roskin (proski) wrote :

Just installed 15.04 prerelease, ran "alacarte", selected "Electronics", clicked on "Move Down". The exception appeared.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.