Alacarte ignores XDG_MENU_PREFIX

Bug #1069207 reported by LaChild on 2012-10-20
144
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Alacarte Menu Editor
Fix Released
Medium
alacarte (Ubuntu)
Medium
Unassigned
Quantal
High
Unassigned
Raring
Medium
Unassigned

Bug Description

[Impact]
* Inability to edit a menu when its filename is "$XDG_MENU_PREFIX"applications.menu instead of only applications.menu.

[Test case]
* Start your Xubuntu session.
* Open Alacarte (Settings > Main menu).
* Try to unhide a desktop file, e.g. check GParted in System.
* Close Alacarte, check your menu, nothing changed.
* Install alacarte from -proposed
* Repeat the steps above.
* The changes are now applied, e.g. GParted should now appear in the System submenu.

[Regression Potential]
* On systems where XDG_MENU_PREFIX is set but applications.menu is used, alacarte won't write to the correct menu file (this case shouldn't happen naturally, even gnome-menus supports this envvar).

On a fresh install of XUbuntu 64bit I am unable to add items to the main menu. All the buttons seem to work but when you hit "New Item" or "New Menu", type in your settins and click "create" nothing happens.

Also attempted to disable some menu items and while the menu editor shows the changes there are no changes to the actual menu, even after restarting X.

Let me know if you need anything else,
Westin Shafer

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xubuntu-default-settings 12.10.7
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Sat Oct 20 15:42:51 2012
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
PackageArchitecture: all
SourcePackage: xubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

LaChild (shafer-w2002) wrote :
affects: xubuntu-default-settings (Ubuntu) → alacarte (Ubuntu)
SteveZalek (zaleksf) wrote :

Same problem with my fresh install of Xubuntu/Lubuntu 12.10 x64

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xubuntu-default-settings 12.10.7
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Oct 19
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
PackageArchitecture: all
SourcePackage: xubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alacarte (Ubuntu):
status: New → Confirmed
Martin Spacek (mspacek) wrote :

I've also noticed this (Xubuntu 12.10 amd64). Nothing in alacarte actually does anything. Deleting items doesn't do anything, except sometimes it does work for the top two entries (Web Browser and Mail Reader). Hiding items doesn't work. Showing hidden items doesn't work. After changing the show toggle, the settings mysteriously revert back after a couple of seconds. Adding new menus or menu items doesn't do anything either. It's obvious from within alacarte that's something's wrong.

I've also tried running alacarte from the command line, to see if any error messages print out. Nothing. I tried running it using sudo and gksudo, but those both failed in different ways.

I've found that the changes are saved in ~/.config/menus/applications.menu, which is ignored by xfce. Renaming the file to xfce-applications.menu applies the changes -- a workaround.

Martin Spacek (mspacek) wrote :

@Marcel, I think I've noticed the same. I copied the system's xfce-applications.menu (either from /etc/xdg/menus/xfce-applications.menu or /etc/xdg/xdg-xubuntu/menus/xfce-applications.menu, I don't remember which) to my ~/.config/menus folder, and have been editing that file by hand. In the "Applications Menu" dialog that pops up when you right click the menu and choose properties, I have the custom menu file option selected, and I have it set to ~/.config/menus/xfce-applications.menu

Morgan (mrh9724) wrote :

I can confirm this bug as well. Following @Marcel's instructions worked as a great work around. A co-worker of mine also has this issue. Hopefully there is an update to fix this soon.

Lionel Le Folgoc (mrpouit) wrote :
summary: - Unable to edit or add items to main menu
+ Alacarte ignores XDG_MENU_PREFIX
Changed in alacarte:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in alacarte (Ubuntu Quantal):
status: New → Triaged
Changed in alacarte (Ubuntu Raring):
status: Confirmed → Triaged
Changed in alacarte (Ubuntu Quantal):
importance: Undecided → High
Changed in alacarte (Ubuntu Raring):
importance: Undecided → Medium
Lionel Le Folgoc (mrpouit) wrote :

Should be fixed in raring.

description: updated
Changed in alacarte (Ubuntu Raring):
status: Triaged → Fix Released
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to quantal-proposed, waiting for approval (so the test case steps above can't be followed yet).

Hello LaChild, or anyone else affected,

Accepted alacarte into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alacarte/3.5.5-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in alacarte (Ubuntu Quantal):
status: Triaged → Fix Committed
tags: added: verification-needed
Morgan (mrh9724) wrote :

Verified proposed package fixes this issue.

tags: added: verification-done
removed: verification-needed

I've managed to enable Quantal proposed but I don't see alacarte anywhere. Would it have a different name?

Thanks.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alacarte - 3.5.5-0ubuntu1.1

---------------
alacarte (3.5.5-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches:
    - 40-xdg-menu-prefix: updated and reenabled to bring back support of
      $XDG_MENU_PREFIX. lp: #1069207
 -- Lionel Le Folgoc <email address hidden> Fri, 02 Nov 2012 20:22:40 +0100

Changed in alacarte (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.