Ubuntu

"No resource agents found" error when starting for the first time

Reported by Davor Cubranic on 2010-04-15
134
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
akonadi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

KUbuntu Lucid installed from scratch and running in VirtualBox

When I started Kontact for the first time, I got an error that said that no resource agents were found for Akonadi. I'm attaching the "Akonadi server self-test report".

Davor Cubranic (cubranic) wrote :
Jonathan Thomas (echidnaman) wrote :

Have you run updates? A akonadi update from yesterday or so should fix this problem.

affects: kdepim (Ubuntu) → akonadi (Ubuntu)
Changed in akonadi (Ubuntu):
status: New → Incomplete
Davor Cubranic (cubranic) wrote :

I'm pretty sure I this was just after updating and rebooting the machine today.

Harald Sitter (apachelogger) wrote :

Jonathan, maybe this is another too-short-a-timeout-bug? After all it says there are no agents but lists a billion of those in the directory.... ?

Harald Sitter (apachelogger) wrote :

So I was looking a bit into the code.

Test 13 gets skipped, and I think in consequence test 14 probably failed. Both query the servermanager itself for protocol version and agents. It is however weird that the protocolversion did not report anything useful, since according to the other tests all is in order.

Also, something that just came to mind... in order to even get the dialog the akonadi startup loop must either terminate with error or not return within one minute, both very odd. Unless the system is super slow akonadi should definitely start within one minute, and should akonadi terminate with error should that show up in the test report.

For the time being I really dont know what to do.

DavorCubranic, please run the program kdebugdialg (either from konsole or alt+f2) and activate --> all <-- options there. Then please try to trigger the issue again (i.e. maybe try a reboot in roughly the same situation (open apps an all) as you did before that error occured. Should the error appear again, please attach the file .xsession-errors, located in your home directory, to this report.

Thanks

Paul Worrall (nicknak) wrote :

I submitted a similar bug report #565460 which has been marked as a duplicate of this, so I'm attaching my .xsession-errors as requested by Harald

Changed in akonadi (Ubuntu):
status: Incomplete → Confirmed
Hein van Rensburg (hvralpha) wrote :

I can also confirm it is the status in Kubuntu Lucid beta version :

Linux version 2.6.32-21-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010

Error report attached.

Must be show stopper for Lucid release.

Matthew Mott (orbweaver) wrote :

I did also encounter this problem when using the KDE SC 4.4 packages from the Kubuntu PPA with Karmic, so it could be a wider KDE issue rather than something specific to Lucid.

Hein van Rensburg (hvralpha) wrote :

And now for Lucid RC also. Kontact have to be restarted several times for Akonadi to pick up contacts. I do not think Akonadi is ready for prime time especially in a LTS release.

Loïc Minier (lool) wrote :

This was added to the release notes, thanks:

== Kubuntu's Akonadi may need restarting ==

Akonadi startup is sometimes faulty preventing access to the address book and other resources. To work around this, close and restart Kontact. (Bug:564263)

Changed in ubuntu-release-notes:
status: New → Fix Released
reini (rrumberger) wrote :

> Unless the system is super slow akonadi should definitely start within one minute,
> and should akonadi terminate with error should that show up in the test report.

Actually, when KDE ist started, there is enough disk activity for it to become *super* slow for more than a minute. As a result, Akonadi regularly displays the error dialog. Adding it to autostart definitely helped here, though.

Thom Stone (obi-tomkenobi) wrote :

I did a clean install of lucid. The first thing I did was to open KAddressBook and create a new addressbook. Now Akonadi and Kmail and Kontact; et al are working fine. I haven't yet figured how to fix this on my other box (upgraded from karmic); trying to avoid install.
More later if work around found.

The current thinking is that most cases of this are really slow akonadi startup. Try exiting the package you manually started (e.g. Kontact/Kmail) and then starting it again a few minutes later. If you don't get the error again, it was just slow startup and should work fine after.

I am also hit by this bug, but in a slightly different configuration. Everything ran fine on a Ubuntu (not kubuntu) karmic with the kontact deb's from "deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu karmic main", with a Kolab 2.2.3 server.

After the upgrade to Lucid, I see exactly the same behaviour as DavorCubranic. I do not start akonadi automatically, but by launching kontact. The message in the log is exactly the same as initally reported by DavorCubranic.

When I exit and re-start kontact, the error disappears, and apparently I *have* access to the address books (as the mail composer finds them), but when I switch to Contacts in kontact (or launch only kaddressbook), nothing is shown. Thus, for me it's actually two bugs - the startup issue, and that I cannot see any contacts upon any further launch of kontact...

Jawnboy (john-bazza) wrote :

I had problems with Akonadi after adding google contacts to it, I think the default setup in Kubuntu is incorrect.

You are supposed to use Akonadi as the "standard" while a fresh install of Kubuntu has a file-resource setup for both Contacts and Calendar.

I can confirm this on 3 PCs, fresh install and adding google contacts, removing the file resource for both contacts and calendar and adding Akonadi resources for these have resolved the issue, this is also mentioned at:

http://userbase.kde.org/Akonadi

http://userbase.kde.org/KAddressBook_4.4

According to those pages it's a "migration" issue, but this is a fresh install of Kubuntu, so I guess it's some sort of default to use the file resources as standard instead of Akonadi.

Someone else had the same issue:

http://forum.kde.org/viewtopic.php?f=20&t=86053

So I guess some sort of package update that sets Akonadi as standard when first logging in to KDE rather than files for KDE Resources.

After this I've had no more problems with Kontact. Hope this helps.

Note before doing anything, I waited a few minutes after logging in to KDE, it was repeatable almost every time.

eiapopeia (post-eiapopeia) wrote :

I think that the slow akonadi-startup is the problem.
I usally let KDE start the last session at startup. This usally startet akonadi AND Kontact at the same time. So I excluded Kontact from this proces via the system-settings. Then i made a autostart script in ~/.kde/Autostart with the following lines:

#!/bin/bash
/usr/bin/akonadictl start
sleep 15
kontact

This delayed the startup of kontact and everything is fine. This is not the golden way bot it works.

Jawnboy (john-bazza) wrote :

Sorry, this is still happening to me upon reboot. The Akonadi error report shows that test 12 is failing, exactly the same problem as everyone else. Then contacts are unavailable. I don't have a particularly slow PC, so yes it seems this on demand start of Akonadi just doesn't work properly.

Davor Cubranic (cubranic) wrote :

After upgrading an older PC from KUbuntu Karmic to Lucid (by doing a clean install to the root partition and keeping '/home' one), I get this error all the time. Closing the dialog exits KMail, so I basically have no mail on that machine until this is fixed.

Davor Cubranic (cubranic) wrote :
Download full text (3.3 KiB)

I tried running 'akonadictl start' from the command line, and it fails to start because I haven't installed MySql. Console output is below:

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
[akonadiserver] search paths: ("/home/cubranic/bin", "/home/cubranic/bin", "/usr/local/sbin", "/usr/local/bin", "/usr/sbin", "/usr/bin", "/sbin", "/bin", "/usr/games", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Found mysql_install_db: "/usr/bin/mysql_install_db"
[akonadiserver] Found mysql_upgrade: "/usr/bin/mysql_upgrade"
"akonadiserver" [out] "Looking for 'mysql' as: /usr/bin/mysql
"
"akonadiserver" [out] "Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
"
"akonadiserver" [out] "Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock' '--socket=/home/cubranic/.local/share/akonadi/db_misc/mysql.socket'
"
[akonadiserver] /usr/bin/mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/home/cubranic/.local/share/akonadi/db_misc/mysql.socket' (2) when trying to connect
[akonadiserver] FATAL ERROR: Upgrade failed
[akonadiserver] Database process exited unexpectedly during initial connection!
[akonadiserver] executable: "/usr/sbin/mysqld-akonadi"
[akonadiserver] arguments: ("--defaults-file=/home/cubranic/.local/share/akonadi//mysql.conf", "--datadir=/home/cubranic/.local/share/akonadi/db_data/", "--socket=/home/cubranic/.local/share/akonadi/db_misc/mysql.socket")
[akonadiserver] stdout: ""
[akonadiserver] stderr: ""
[akonadiserver] exit code: 1
[akonadiserver] process error: "Unknown error"
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x35) [0x8052265]
[akonadiserver] 1: akonadiserver() [0x8052726]
[akonadiserver] 2: [0xb5d400]
[akonadiserver] 3: [0xb5d422]
[akonadiserver] 4: /lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0x4d1651]
[akonadiserver] 5: /lib/tls/i686/cmov/libc.so.6(abort+0x182) [0x4d4a82]
[akonadiserver] 6: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x8c) [0x16d2dc]
[akonadiserver] 7: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x80537a4]
[akonadiserver] 8: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x8e) [0x20546e]
[akonadiserver] 9: /usr/lib/libQtCore.so.4(+0x10a275) [0x21a275]
[akonadiserver] 10: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3d) [0x21b78d]
[akonadiserver] 11: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804dea3]
[akonadiserver] 12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer25startMysqlDatabaseProcessEv+0x2071) [0xe50cb1]
[akonadiserver] 13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x263) [0xe53da3]
[akonadiserver] 14: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x7d) [0xe5403d]
[akonadiserver] 15: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xe554f8]
[akonadiserver] 16: akonadiserver(main+0x374) [0x804d204]
[akonadiserver] 17: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x4bdbd6]
[akonadiserver] 18: akonadiserver() [0x804cdc1]
[ak...

Read more...

Davor Cubranic (cubranic) wrote :

Issure reported in comments #19 and #20 is probably a different bug. I'll file a new report for it.

Davor Cubranic (cubranic) wrote :

(re comment #20: filed as Bug #578357)

Jürgen (j-w-ott) wrote :

I have the same problem. Looking through the messages when starting kmail it seems to be a problem with mysql, allthough I haven found out yet what exactly ist passed to mysqltest. Changing single parameters could then reduce the possible causes.

Davor Cubranic (cubranic) wrote :

Jürgen, the output of 'akonadictl start' is totally bogus when it comes to identifying errors with MySql storage. See bug #578357 for details of my case, but if you want to find out what the real cause of your problem is, you have to look in ~/.local/share/akonadi/db_data/mysql.err.

Rafal-maj-it (rafal-maj-it) wrote :

rememer to disable apparmor / apparmor profile for akonadi / akonadi-mysql

Ludwin Janvier (lud-janvier) wrote :

Isn't this a duplicate of #554514 ?

Davor Cubranic (cubranic) wrote :

It may be, Ludwin. More self tests pass in the report attached in comment #1, but otherwise it looks the same.

Hein's error in comment #7 is something else, though. It mention's MySql failing to start because of problems locking the log file, and so looks more similar to the one I filed as bug #578357, where the Akonadi error was just a symptom of an underlying problem with the database.

Crashit (johanschutten) wrote :

Got same error message. For people who don't want to get the akonadi-error everytime they start Kontact, I have a little workaround.

-> Go to System Preferences
-> Open Autostart
-> Add program...
-> insert: akonadictl start
-> Select "start in terminal" (or something like that)
-> Ok
-> Ok
-> Close program and restart (K)Ubuntu.

That should fix the problem, although it's only a workaround. Everytime you start Kontact for the first time, it starts faster than akonadi. That's causing the error. By starting akonadi earlier (at boottime), you prevent the error from occuring.

Harald Sitter (apachelogger) wrote :

duplicate of bug #583735

Changed in akonadi (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers