Aegisub crashes immediately after opening the context menu

Bug #1841381 reported by scx on 2019-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aegisub (Debian)
Fix Released
Unknown
aegisub (Ubuntu)
Undecided
Unassigned

Bug Description

I hit a similar problem in another distribution. I believe that this is related to the spell checking code (list available languages).
The same error occurs in Debian 10.0.0 (debian-live-10.0.0-amd64-mate.iso).
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=935724
It should be mention that this bug doesn't affect Aegisub in Ubuntu 16.04 LTS.

Steps to reproduce:
1. Run aegisub-3.2
2. Disable update checker if needed (first run only)
3. Press the context menu key

I suspect these components as the cause of the error:
a. libstdc++:
It may be a problem with Dual ABI.
However, it should also affect package in Ubuntu 16.04 LTS, but it doesn't.
https://wiki.debian.org/GCC5
https://gcc.gnu.org/onlinedocs/gcc-5.2.0/libstdc++/manual/manual/using_dual_abi.html

b. GCC:
Maybe this is caused by aggressive GCC 8 optimizations.
Maybe this is about some hardening flags (-D_GLIBCXX_ASSERTIONS)?

c. Boost:
Aegisub may be not 100% compatible with the latest Boost. TUV doesn't even support Boost 1.69 OOTB. I believe that they are still using Boost 1.58.

gdb output:
> Thread 1 "aegisub-3.2" received signal SIGSEGV, Segmentation fault.
> 0x00005555559b6cab in SubsTextEditCtrl::OnContextMenu (this=0x555556395b80,
> event=...) at /usr/include/c++/8/bits/unique_ptr.h:342
> warning: Source file is more recent than executable.
> 342 get() const noexcept

I don't use Debian/Ubuntu on a daily basis. I used LiveDVD (ubuntu-mate-19.04-desktop-amd64.iso).

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: aegisub 3.2.2+dfsg-4
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27.1
Architecture: amd64
CasperVersion: 1.405
CurrentDesktop: MATE
Date: Sun Aug 25 18:25:18 2019
ExecutablePath: /usr/bin/aegisub-3.2
LiveMediaBuild: Ubuntu-MATE 19.04 "Disco Dingo" - Release amd64 (20190416)
ProcEnviron:
 SHELL=/bin/bash
 LANG=C.UTF-8
 TERM=xterm-256color
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
SourcePackage: aegisub
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.apport.crashdb.conf: 2019-08-25T17:56:30.734947

Revision history for this message
scx (the-scx) wrote :
Revision history for this message
scx (the-scx) wrote :

A similar error occurs in Debian 9 oldstable (debian-live-9.9.0-amd64-mate.iso) and openSUSE Tumbleweed (openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20190823-Media.iso).
In the second case, you have to manually install the 'myspell*' packages.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=935724#10

Revision history for this message
scx (the-scx) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Fix crashing when picking language" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in aegisub (Debian):
status: Unknown → New
Changed in aegisub (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.